Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have a problem with connection secure

more options

Hello.. I have this problem on my phone for a long time..Always when i open my mozilla firefox it says that my connection is not secure and someone is trying to imitate page.I try everything..i uninstall and install app, i try to fix problem on my laptop but nothing works. Can you please help me? Thank you in advance Andrea

Chosen solution

I would certainly recommend making sure you have a strong WiFi signal.

Read this answer in context 👍 0

All Replies (13)

more options

HI

Do you have any add-ons installed? If so, please can you list them?

This will help us to look into this issue further for you.

more options

hii,thanks for replying i have adguard app and i try to find how to remove my problem.So i find out that i need to delete Ca certificate so I did.It work perfectly well for about 15 minutes.After 15 minutes i open again mozilla and it says that my connection is not secure again.I dont know what to do

more options

Hi

I recommend that you try uninstalling Adguard and using uBlock instead.

The issue that you are reporting has been seen before with Adguard, but I believe dies not happen with uBlock.

Modified by Seburo

more options

thanks for replying again.. so i deeleted adguard and try to install uBlock but it says that the only version of this app is desktop version but i need app for my phone

more options

Hi

This is the link for uBlock Origin for Android.

I hope this helps.

Modified by Seburo

more options

I dit it..thank you Will that app block adds?

more options

i mean will that block youtube adds because that is important to me

more options

Yes, it is an ad-blocking add-on.

more options

i did everything so i think everythings fine thank you

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.

more options

Everythings fine now but once i open mozilla and it says that server is not found i dont know was problem my connection or..im afarid that will happen again but everything is fine and mozilla works good. Do you have any suggestion what i can do if that happens again?

more options

Chosen Solution

I would certainly recommend making sure you have a strong WiFi signal.

more options

okay i will thank u .. sorry for a lot of questions i have one more problem.. so i have my youtube playlist in mozillla browser .So in that playlist i have around 40 songs.When the last song ends i want it to play again but that isnt happening.I press loop button(button for infinite reproduction )but still isnt working. automatically reproduction option is allowed but it wont play again when the last video in playlist is over