X
Tap here to go to the mobile version of the site.

Support Forum

When typing or clicking in a blank field, caret jumps right then left in an instant.

Posted

The "ghost" caret also appears when I'm pressing left or right arrow keys to move the caret. It seems to be white, even when the real caret is black on white background. It is easily seen when a text field background is a dark color. It appears for about one frame, my screen refresh rate is 60Hz.

It doesn't seem to be a "fake" caret or merely a graphical element. When I'm editing a field of text, eg. in Google Docs, I've occasionally started editing or selecting text one character to the right. Like as if in that split second I just happened to send the keystroke when the ghost caret appeared. But because it was so brief, it is near impossible to replicate.

I've tried Firefox in safe-mode and there was no ghost caret. So I removed all add-ons/extensions, but the ghost caret still appears even if I have no extensions installed, which is why it's so baffling. I've refreshed and re-installed Firefox, both didn't work.

This "ghosting" only happens in Firefox, not in IE nor Chrome.

I used a screen capturing software and recorded this problem, then extracted a frame from the video to show the real caret and ghost caret side by side. Hope this better illustrates what I'm seeing. I have Dark Reader activated so the ghost caret can be easily seen. If Dark Reader isn't activated, it would be impossible to see due to the white background.

I do most of my work on cloud based platforms so this ghosting is very annoying and distracting. Or worse, could it be a keylogger or malicious program causing this?

Please help, Thank you!

The "ghost" caret also appears when I'm pressing left or right arrow keys to move the caret. It seems to be white, even when the real caret is black on white background. It is easily seen when a text field background is a dark color. It appears for about one frame, my screen refresh rate is 60Hz. It doesn't seem to be a "fake" caret or merely a graphical element. When I'm editing a field of text, eg. in Google Docs, I've occasionally started editing or selecting text one character to the right. Like as if in that split second I just happened to send the keystroke when the ghost caret appeared. But because it was so brief, it is near impossible to replicate. I've tried Firefox in safe-mode and there was no ghost caret. So I removed all add-ons/extensions, but the ghost caret still appears even if I have no extensions installed, which is why it's so baffling. I've refreshed and re-installed Firefox, both didn't work. This "ghosting" only happens in Firefox, not in IE nor Chrome. I used a screen capturing software and recorded this problem, then extracted a frame from the video to show the real caret and ghost caret side by side. Hope this better illustrates what I'm seeing. I have Dark Reader activated so the ghost caret can be easily seen. If Dark Reader isn't activated, it would be impossible to see due to the white background. I do most of my work on cloud based platforms so this ghosting is very annoying and distracting. Or worse, could it be a keylogger or malicious program causing this? Please help, Thank you!
Attached screenshots
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17342 solutions 156777 answers

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

You can try to disable hardware acceleration in Firefox. *Options/Preferences -> General: Performance<br>remove checkmark: [ ] "Use recommended performance settings"<br>remove checkmark: [ ] "Use hardware acceleration when available" *https://support.mozilla.org/en-US/kb/performance-settings Close and restart Firefox after modifying the setting for changes to take effect. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.