Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Facebook Messenger audio files will not play in Firefox. They play in Chrome. Audio contained in video files plays just fine

  • 3 replies
  • 1 has this problem
  • 9 views
  • Last reply by jscher2000

more options

All other audio files play without a problem in Firefox, the Facebook Messenger audio files seem to be the only ones affected. This has been a continuing problem under all Windows versions of Firefox for at least the past 6 months. I'm using Windows 10, version 1803 and Firefox, both automatically updated to the latest downloads.

All Replies (3)

more options

Hi Catmandu2, I don't use FB Messenger, so I haven't tested this for myself.

If you haven't already, could you turn off the anti-autoplay feature to see whether that makes any difference? This article will get you to that checkbox: Allow or block media autoplay in Firefox.

more options

Thank you for the reply, jschaer2000, but that didn't solve the problem. When I click on an audio message file to play it, the circular "wait" arrow starts spinning, but no sound is ever produced. Chrome will play those files with no problem, but I'd rather not have to run Chrome if there's a way around it.

more options

Hi Catmandu2, I haven't been able to go into FB and exchange audio with someone, so could I give you some general suggestions?

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Content blocking.

(B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?