X
Tap here to go to the mobile version of the site.

Support Forum

Why is Firefox rendering pages with the "Last Resort" font replacing some or all text? Chrome and Safari are not having this issue.

Posted

I recently had a font management program affect the fonts on my computer in an unexpected and unwanted manner. Immediately after this happened Firefox was no longer rendering type correctly on a number of webpages. Some were completely compromised with "Last Resort" (i.e., rounded boxes with question marks for each character) replacing all text, and some with only certain portions affected. At the time I did not check other browsers to see if/how they were affected.

I replaced/reinstalled the Mac system fonts, and reinstalled around 90% of the additional fonts that I've collected over the years, however, Firefox was still having issues. At this point I uninstalled Firefox and pulled down a fresh copy, cleared all caches, and checked both Chrome and Safari. Firefox is still not working correctly and the other two browsers show no sign of the problem (if they ever had it all). Attached are screen shots of my My Yahoo! page in Chrome and Firefox showing the results of the issue.

I would really love to keep using Firefox, but this problem would be a deal breaker.

Cheers Randy

I recently had a font management program affect the fonts on my computer in an unexpected and unwanted manner. Immediately after this happened Firefox was no longer rendering type correctly on a number of webpages. Some were completely compromised with "Last Resort" (i.e., rounded boxes with question marks for each character) replacing all text, and some with only certain portions affected. At the time I did not check other browsers to see if/how they were affected. I replaced/reinstalled the Mac system fonts, and reinstalled around 90% of the additional fonts that I've collected over the years, however, Firefox was still having issues. At this point I uninstalled Firefox and pulled down a fresh copy, cleared all caches, and checked both Chrome and Safari. Firefox is still not working correctly and the other two browsers show no sign of the problem (if they ever had it all). Attached are screen shots of my My Yahoo! page in Chrome and Firefox showing the results of the issue. I would really love to keep using Firefox, but this problem would be a deal breaker. Cheers Randy
Attached screenshots
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • Firefox 68.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:68.0) Gecko/20100101 Firefox/68.0
  • Support URL: https://support.mozilla.org/1/firefox/68.0/Darwin/en-US/

Extensions

  • AdBlocker Ultimate 2.38 (adblockultimate@adblockultimate.net)
  • Amazon.com 1.1 (amazondotcom@search.mozilla.org)
  • Bing 1.0 (bing@search.mozilla.org)
  • DuckDuckGo 1.0 (ddg@search.mozilla.org)
  • eBay 1.0 (ebay@search.mozilla.org)
  • ETP Search Volume Study 1.2 (etp-search-volume-study@shield.mozilla.org)
  • Facebook Container 2.0.1 (@contain-facebook)
  • Google 1.0 (google@search.mozilla.org)
  • Norton Safe Web 3.8.0.6 (nortonsafeweb@symantec.com)
  • Twitter 1.0 (twitter@search.mozilla.org)
  • Wikipedia (en) 1.0 (wikipedia@search.mozilla.org)
  • Adobe Acrobat 18.0.10 (web2pdfextension.17@acrobat.adobe.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x67ef
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • contentUsesTiling: True
  • crashGuards: []
  • driverDate:
  • driverVendor:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'opt-in', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}], u'name': u'WEBRENDER'}, {u'status': u'blacklisted', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blacklisted', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • info: {u'TileHeight': 1024, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'TileWidth': 1024, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 4
  • targetFrameRate: 60
  • usesTiling: True
  • webgl1DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_disjoint_timer_query EXT_float_blend EXT_frag_depth EXT_shader_texture_lod EXT_sRGB EXT_texture_compression_rgtc EXT_texture_filter_anisotropic OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: ATI Technologies Inc. -- AMD Radeon Pro 560X OpenGL Engine
  • webgl1Version: 4.1 ATI-2.9.26
  • webgl1WSIInfo: CGL
  • webgl2DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl2Extensions: EXT_color_buffer_float EXT_disjoint_timer_query EXT_float_blend EXT_texture_compression_rgtc EXT_texture_filter_anisotropic OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
  • webgl2Renderer: ATI Technologies Inc. -- AMD Radeon Pro 560X OpenGL Engine
  • webgl2Version: 4.1 ATI-2.9.26
  • webgl2WSIInfo: CGL
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8568 solutions 70056 answers

Hi Randy, do you use a third party font manager like Suitcase?

I don't use Mac, but I can refer you to a recent thread about the "Last Resort" font issue:

Does that seem relevant?

Hi Randy, do you use a third party font manager like Suitcase? I don't use Mac, but I can refer you to a recent thread about the "Last Resort" font issue: * [https://support.mozilla.org/questions/1263110 Browser displays hex a in square instead of actual text characters.] Does that seem relevant?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17334 solutions 156717 answers

You can check for sandbox security issues when Firefox has a problem to access fonts installed locally. See:

You can set this pref to 2 or 1 on the about:config page to reduce the sandbox security level.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

You can check for sandbox security issues when Firefox has a problem to access fonts installed locally. See: *https://wiki.mozilla.org/Security/Sandbox#Content_Levels You can set this pref to 2 or 1 on the <b>about:config</b> page to reduce the sandbox security level. *security.sandbox.content.level = 1 *close and restart Firefox to make the change effective. If '1' still doesn't have effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.