X
Tap here to go to the mobile version of the site.

Support Forum

Unable to choose Google as search engine

Posted

I recently stared using Firefox (updated 68.0) on Mac OS 10.14.5. It defaulted to Bing as a search engine, but I prefer Google. However, when I go under Preferences to Search, the only search engines listed are Bing, Amazon, and Ebay. "Restore Default Search Engines" is grayed out. There does not seem to be a way to add a search engine o that box. I did click "Find more search engines . . . " but regular Google.com (as opposed to google.ru, etc) was not included in that list.

I did more noodling around and tried going to Google.com, clicking the three dots in the URL, and choosing "Add Search Engine." But "Add Search Engine" is not available at google.com. That suggests to me that it should already be on the list, but it isn't.

Can anyone suggest something I haven't tried?

I recently stared using Firefox (updated 68.0) on Mac OS 10.14.5. It defaulted to Bing as a search engine, but I prefer Google. However, when I go under Preferences to Search, the only search engines listed are Bing, Amazon, and Ebay. "Restore Default Search Engines" is grayed out. There does not seem to be a way to add a search engine o that box. I did click "Find more search engines . . . " but regular Google.com (as opposed to google.ru, etc) was not included in that list. I did more noodling around and tried going to Google.com, clicking the three dots in the URL, and choosing "Add Search Engine." But "Add Search Engine" is not available at google.com. That suggests to me that it should already be on the list, but it isn't. Can anyone suggest something I haven't tried?
Attached screenshots

Chosen solution

Hi kcatmull, could you try resetting your search engine settings by removing the settings file. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default, double-click it to display the contents of that profile folder.

Leaving that window open, switch back to Firefox and Quit, either:

  • "3-bar" menu button > Quit
  • (menu bar) Firefox > Quit

Pause while Firefox finishes its cleanup, then rename search.json.mozlz4 to something like searchOLD.json.mozlz4.

Start Firefox back up again. Are all of the built-in search engines listed on the Preferences page?

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.2 r153

Application

  • Firefox 68.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:68.0) Gecko/20100101 Firefox/68.0
  • Support URL: https://support.mozilla.org/1/firefox/68.0/Darwin/en-US/

Extensions

  • Amazon.com 1.1 (amazondotcom@search.mozilla.org)
  • Bing 1.0 (bing@search.mozilla.org)
  • eBay 1.0 (ebay@search.mozilla.org)
  • Adobe Acrobat 18.0.10 (web2pdfextension.17@acrobat.adobe.com) (Inactive)
  • Freedom - Website Blocker for Firefox 16 (freedom@freedom.to) (Inactive)
  • Library Extension 2019.702.2 (firefox@libraryextension.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x162b
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • contentUsesTiling: True
  • crashGuards: []
  • driverDate:
  • driverVendor:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'unavailable-in-safe-mode', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable-in-safe-mode', u'message': u'Safe-mode is enabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'blacklisted', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blacklisted', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'blocked', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'OMTP blocked by safe-mode', u'type': u'runtime'}], u'name': u'OMTP'}]}
  • info: {u'TileHeight': 1024, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'TileWidth': 1024, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: {u'key': u''}
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: False
  • offMainThreadPaintWorkerCount: 0
  • targetFrameRate: 60
  • usesTiling: True
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No

Question owner

ugh sorry, part of my question disappeared. It should have said

I did more noodling around and tried going to Google, clicking the three dots in the search bar, and choosing "Add Search Engine" but "Add Search Engine" was not available. Which suggests it should already be in the list but it's not. It's kind of maddening.

ugh sorry, part of my question disappeared. It should have said I did more noodling around and tried going to Google, clicking the three dots in the search bar, and choosing "Add Search Engine" but "Add Search Engine" was not available. Which suggests it should already be in the list but it's not. It's kind of maddening.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4191 solutions 58517 answers

Check out https://mycroftproject.com/


Separate Security Issue: Update your Flash Player or remove it using these links; Uninstall Flash Player | Windows {web link} Uninstall Flash Player | Mac {web link}

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version 32.0.0.223

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Check out https://mycroftproject.com/ --------------- '''Separate Security Issue:''' Update your Flash Player or remove it using these links; [http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows] {web link} [http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac] {web link} '''Note: Windows users''' should download the '''ActiveX''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player '''Version 32.0.0.223 ''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Modified by FredMcD

Was this helpful to you? 0
Quote

Question owner

Yes, I noticed that Flash was installed as well. Will uninstall.

As for my actual problem, the mycroft link did not work, as apparently--and as I guessed in my question--Google is already installed. It just is no showing up in my list of choices.

Yes, I noticed that Flash was installed as well. Will uninstall. As for my actual problem, the mycroft link did not work, as apparently--and as I guessed in my question--Google is already installed. It just is no showing up in my list of choices.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8580 solutions 70157 answers

Chosen Solution

Hi kcatmull, could you try resetting your search engine settings by removing the settings file. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default, double-click it to display the contents of that profile folder.

Leaving that window open, switch back to Firefox and Quit, either:

  • "3-bar" menu button > Quit
  • (menu bar) Firefox > Quit

Pause while Firefox finishes its cleanup, then rename search.json.mozlz4 to something like searchOLD.json.mozlz4.

Start Firefox back up again. Are all of the built-in search engines listed on the Preferences page?

Hi kcatmull, could you try resetting your search engine settings by removing the settings file. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Enter/Return In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default, double-click it to display the contents of that profile folder. Leaving that window open, switch back to Firefox and Quit, either: * "3-bar" menu button > Quit * (menu bar) Firefox > Quit Pause while Firefox finishes its cleanup, then rename '''search.json.mozlz4''' to something like '''searchOLD.json.mozlz4'''. Start Firefox back up again. Are all of the built-in search engines listed on the Preferences page?
Was this helpful to you? 1
Quote

Question owner

yes! that solved it, thank you SO much!

yes! that solved it, thank you SO much!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.