X
Tap here to go to the mobile version of the site.

Support Forum

My non-main-inbox open IMAP folders don't update when getting new messages

Posted

I use Thunderbird to read mail from a number of IMAP servers (some gmail, some dovecot). I have many sub-folders into which mail is automatically sorted by the various IMAP servers.

I generally have a number of tabs open in my Thunderbird windows. However, tabs which are for folders which are not the main INBOX for an account never show new messages which come in once the tab was opened. Even if I hit the "get new messages" button, the INBOXs update, but noting else does.

The only way I can get the new messages is either to read an unread message in the folder in question, or to close and reopen the folder's tab. How do I get all of the tabs to automatically update with new messages just like the INBOX folder does?

I use Thunderbird to read mail from a number of IMAP servers (some gmail, some dovecot). I have many sub-folders into which mail is automatically sorted by the various IMAP servers. I generally have a number of tabs open in my Thunderbird windows. However, tabs which are for folders which are not the main INBOX for an account never show new messages which come in once the tab was opened. Even if I hit the "get new messages" button, the INBOXs update, but noting else does. The only way I can get the new messages is either to read an unread message in the folder in question, or to close and reopen the folder's tab. How do I get all of the tabs to automatically update with new messages just like the INBOX folder does?

Chosen solution

If you right-click a folder, Properties, is the 'When getting new messages...' box unchecked?

Read this answer in context 2
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.100 Safari/537.36

More Information

sfhowes
  • Top 10 Contributor
1438 solutions 6818 answers

Chosen Solution

If you right-click a folder, Properties, is the 'When getting new messages...' box unchecked?

If you right-click a folder, Properties, is the 'When getting new messages...' box unchecked?
Was this helpful to you? 2
Quote

Question owner

I didn't know that checkbox existed, and indeed it wasn't checked, and checking it seems to have solved my issue.

Thanks!

I didn't know that checkbox existed, and indeed it wasn't checked, and checking it seems to have solved my issue. Thanks!
Was this helpful to you?
Quote
petitfiat 0 solutions 1 answers

Thanks, it is very helpful for one single folder. For general preferences, is there any setting to enable auto folder update for all the folders?

Thanks, it is very helpful for one single folder. For general preferences, is there any setting to enable auto folder update for all the folders?
Was this helpful to you?
Quote
sfhowes
  • Top 10 Contributor
1438 solutions 6818 answers

petitfiat said

Thanks, it is very helpful for one single folder. For general preferences, is there any setting to enable auto folder update for all the folders?

Set mail.server.default.check_all_folders_for_new to true in Config. editor.

http://kb.mozillazine.org/Checking_for_new_messages_in_other_folders_-_Thunderbird

''petitfiat [[#answer-1245272|said]]'' <blockquote> Thanks, it is very helpful for one single folder. For general preferences, is there any setting to enable auto folder update for all the folders? </blockquote> Set ''mail.server.default.check_all_folders_for_new'' to true in Config. editor. http://kb.mozillazine.org/Checking_for_new_messages_in_other_folders_-_Thunderbird
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.