Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Add filetype associations to options -> applications (so I can autosave them to disk)

  • 6 replies
  • 1 has this problem
  • 6960 views
  • Last reply by cor-el

more options

I'm trying to find a way to add entries to the list in the attached screencap. What I want is to always save certain filetypes, like .rs, .qdp, and any others I might want, without having to manually click 'save' each time. No matter where I download these from, the option to 'do this automatically' is always greyed out, and I haven't found a workaround for that, so I'm hoping this is possible to do as I download 10-20 files of these types on any given day.

In case the image doesn't load, I'll post an imgur link: https://i.imgur.com/KiPhV73.png

I'm trying to find a way to add entries to the list in the attached screencap. What I want is to always save certain filetypes, like .rs, .qdp, and any others I might want, without having to manually click 'save' each time. No matter where I download these from, the option to 'do this automatically' is always greyed out, and I haven't found a workaround for that, so I'm hoping this is possible to do as I download 10-20 files of these types on any given day. In case the image doesn't load, I'll post an imgur link: https://i.imgur.com/KiPhV73.png

Chosen solution

I spotted the error...the entry that I posted earlier, needs to be pasted in the mimetypes section. For your reference, i have posted the corrected code below: https://pastebin.com/Cp4LMr17 Please copy paste the code in your handlers.json file, save it and then fire up Firefox and check...

Read this answer in context 👍 1

All Replies (6)

more options

Hi, I would request you to follow the steps:

1. First install the latest version of Firefox.

2. If the problem persists, please type "about:support" without the quotes, in a new tab.

3. It should open up a page where you should see a table named"Application Basics". In the table look for the entry "Profile Directory". You should see a clickable button "Open Directory". Click on it and it should open up the directory in Explorer. Alternatively, you can also note down the directory path beside the button and open it in explorer.

4. Once the directory is opened, you should see a file called "handlers.json", open it using notepad.

5. Please post this file here or alternatively, you can add the following entry in the file before the last curly brace...

,"application/rs-file":{"action":0,"extensions":["rs"]},"application/qdp-file":{"action":0,"extensions":["qdp"]}

...and save the file. Restart Firefox and check if Firefox automatically downloads the file types.

Modified by frontlemon

more options

Hey, thank you for the help! I've followed your instructions but it hasn't resolved the issue. For reference I've posted my handlers.json file here: https://pastebin.com/raw/dhrSwYe4

more options

Chosen Solution

I spotted the error...the entry that I posted earlier, needs to be pasted in the mimetypes section. For your reference, i have posted the corrected code below: https://pastebin.com/Cp4LMr17 Please copy paste the code in your handlers.json file, save it and then fire up Firefox and check...

more options

Thanks so much! That fixed the issue. I'll be able to add more filetypes to that json file in the future, right?

more options

Yes definitely, you can, but make sure that the added file types are added in the mimetypes section and not in other sections: the mistake I made earlier...

more options

action:

saveToDisk = 0;
alwaysAsk = 1;
useHelperApp = 2;
handleInternally = 3;
useSystemDefault = 4;