Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox is Using the Internet without my permission

  • 8 replies
  • 1 has this problem
  • Last reply by P_Cohen

more options

Hello everyone! This letter was translated by Google Translation, so sorry if the language is not so correct. I recently noticed that my Internet is being used without my knowledge, which means that the network icon next to the clock indicates that there is data communication but there is no software I use on the Internet. I suspected that someone was hacking into my computer or having spyware or a virus on my computer so I installed NetLimiter to find some software that uses the Internet without my knowledge. To my surprise, I discovered that FireFox and Internet Download Manager (IDM) software download data (and lots) even though these software interfaces show that there is no data transfer. Moreover, even after I close FireFox, NetLimiter detects that FireFox continues to download data! I checked the IP address from which these programs are downloading data, I copied the IP address to the browser and to my surprise the main page of ... Google. For some reason FireFox and IDM download data from Google, and for some reason neither show it nor ask for permission, and of course I can not stop downloading data through them except with NetLimiter. So why does FireFox download data from Google without my knowledge and without my permission ?!

All Replies (8)

more options
more options

Hi P_Cohen!

I would recommend you check two settings of your firefox browser: - updates: check if you have given Firefox permission to automatically update itself, or to automatically update its search engines. Also check whether you have authorized it to use a background service to install those updates

Look into options and preferences (more details here: Select General panel (you can also type this in the adress bar, without <> of course: <about:preferences#general>) Then look for the update section You should see three relevant settings about updates (boxes to check or uncheck), set them accordingly to your preferences.

- data collection, this setting is located in the Privacy and security panel (you can type this in the adress bar to access it: <about:preferences#privacy>) Then look for data collection options. There should be 4 relevant settings (boxes to check or uncheck again), set them accordingly to your preferences.

Hope this helps, please tell me if this information did help you or if it wasn't enough to solve your problem. Enjoy the rest of your day

more options

Hello to both of you! First, thanks for the help, especially for the quick answers. Sorry again if English is broken ... Regarding the link given by christ1 - this is the name of connections FireFox creates during its session. ("List of all connections that Firefox may establish at application startup").

Regarding what Neo_Dreamy wrote: I have probably a slightly different version of your own FireFox, I use 52.9.0 (32-bit). I found the update settings in the "Advanced" pane, and there is actually a check box that says "Use a background service to install updates" which definitely explains how FireFox downloaded data after I closed the program ... And there is also an option to automatically update FireFox search engines, which explains why FireFox has downloaded a data from Google ... But in the Privacy panel I did not find what you wrote "data collection". And what is data collection at all? What data does FireFox collect? As for the link you have entered, it comes to "Page Not Found".

However, as I wrote, it may well be that FireFox updated its search engines with the background service, so it may well be that the problem has already been resolved, but I will wait a while to make sure the problem is resolved.

Thank you very much! have a good day!

more options

Unfortunately the problem has not been solved ... Again I "caught" the FireFox downloading without my knowledge 1. From IP address Port 443 (this is a Google address) 2. From IP Address Port 80

more options

That sounds like you got a Google Toolbar installed so it keeps the connection alive or you got Addons/Extensions that keep the connection alive. So your going to have to check other locations for the issue. When I close firefox it stops even with my addons. So there is more going on here then what is being said.

more options

No, I do not have a Google Toolbar installed ...

more options

So is IDM running when your using firefox? What happens if you change it's setting to run only when you use it? The Browser doesn't usually download anything unless you tell it to download or if it's a update to the Browser.

more options

Hope I got you right. I will try to close IDM when I recognize that FireFox is downloading data in the background.