Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I need add-ons for old version of firefox , I can,t update browser , I can,t buy new hardware , help me

  • 21 replies
  • 1 has this problem
  • 61 views
  • Last reply by McCoy

more options

So many people are very poor and they can not buy new and strong computer hardware , But Firefox force us to use new hardware because new version need new hardware , and new add-ons need new version browser ... It is unfair , What dose add-ons do for us that you force us to buy new hardware? , whereas we have not enough money ... Is not Mozilla a non-profit organization ? For example in Iran, internet censored by criminal government and we strongly need free "VPN add-ons" at old versions of Firefox ... (especially 47 & less)

Thanks for your notice

چرا نمیگذارید از افزونه ها در نسخه های قدیم فایرفاکس استفاده کنیم ؟ ما نمیتوانیم نسخه جدید مرورگر را بکار ببریم چون پول کافی برای خرید سخت افزار کامپیوتر جدید نداریم . مگر یک افزونه چه میکند که اینگونه لازم به بروزرسانی باشد ؟ بگذارید از همان نسخه های قدیم استفاده کامل بکنیم ، مگر بنیاد موزیلا غیرانتفاعی نیست ؟ پس چه فایده ای دارد که مردم را مجبور به خرید کامپیوتر جدید کنید ؟ بطور مثال در ایران اینترنت توسط حکومت جنایتکار سانسور میشود و ما نیاز فراوان به فیلترشکن از نوع افزونه ای داریم ، لطفا اینقدر ما را اذیت نکنید!

سپاس از توجه شما

Modified by saminur

All Replies (20)

more options

The latest version of Firefox that runs on Windows XP is 52. You can download it from http://ftp.mozilla.org/pub/firefox/releases/52.9.0esr/win32/

Unfortunately we can't provide support for old versions of Windows forever, and since Windows XP has not been supported by Microsoft for many years it is not safe to continue to use on the internet anyway.

If you're wanting to use a VPN, I'd suggest using a whole computer VPN, not a free VPN add-on in the browser anyway.

more options

Is this what you are looking for? http://legacycollector.org/firefox-addons/

more options

The newest Firefox possible version at my hardware is 47 because its CPU dose not support SSE2 , and there is no any add-ons searchable in the Add-ons tab. and I can,t use a whole computer VPN , and security is not most important topic for us ... , Please Please Please help us , for the Mozilla,s main aim : access to the web for all people !

Thanks a lot for your notice !

more options

Unfortunately in that case there isn't much that can happen. I understand your predicament but at a certain point we have to make the decision to no longer support certain operating systems. Mozilla provided support for Windows XP for many years after Microsoft themselves stopped, and further support was not possible after a certain point.

more options

The newest Firefox possible version at my hardware is 47 because its CPU dose not support SSE2 , and there is no any add-ons searchable in the Add-ons tab. and I can,t use a whole computer VPN , and security is not most important topic for us ... , Please Please Please help us , for the Mozilla,s main aim : access to the web for all people !

Thanks a lot for your notice !

more options

FredMcD said

Is this what you are looking for? http://legacycollector.org/firefox-addons/

Thanks alot , But dose not work for me !

Modified by saminur

more options

Tyler Downer said

The latest version of Firefox that runs on Windows XP is 52. You can download it from http://ftp.mozilla.org/pub/firefox/releases/52.9.0esr/win32/ Unfortunately we can't provide support for old versions of Windows forever, and since Windows XP has not been supported by Microsoft for many years it is not safe to continue to use on the internet anyway. If you're wanting to use a VPN, I'd suggest using a whole computer VPN, not a free VPN add-on in the browser anyway.


The newest Firefox possible version at my hardware is 47 because its CPU dose not support SSE2 , and there is no any add-ons searchable in the Add-ons tab. and I can,t use a whole computer VPN , and security is not most important topic for us ... , Please Please Please help us , for the Mozilla,s main aim : access to the web for all people !

Thanks a lot for your notice !

more options

Hello saminur,

Maybe you could let us know which add-on(s) you need  ?

more options

McCoy said

Hello saminur, Maybe you could let us know which add-on(s) you need  ?

I need only an anti-censorship add-on

Until a few days ago "connected over" was useful.

Modified by saminur

more options

saminur said

I need only an anti-censorship add-on

Maybe you could contact the developers of the add-ons you are looking for on the addons.mozilla.org page, if they have a version of their add-on that will work with Firefox 47 ..... (?)

Like this one :

https://addons.mozilla.org/en-US/firefox/addon/stealthy/

email address :     info@stealthy.co

Or this one :

https://addons.mozilla.org/en-US/firefox/addon/anonymox/

Under "More information" => Support Email

more options

saminur said

Until a few days ago "connected over" was useful.

You just added this to your post ....

Is this the one you're talking about ?

https://addons.mozilla.org/en-US/firefox/addon/connectedover/

If so : their oldest version will work with Firefox 48 and not 47 ......

But you could send them an email - see under "More information" => Support Email.

Modified by McCoy

more options

Extensions like Browsec VPN and anonymoX still have a WebExtension version, so their Legacy version should probably still work.

more options

cor-el said

Extensions like Browsec VPN and anonymoX still have a WebExtension version, so their Legacy version should probably still work.

In Iran dose not work

more options

McCoy said

saminur said
Until a few days ago "connected over" was useful.

You just added this to your post ....

Is this the one you're talking about ?

https://addons.mozilla.org/en-US/firefox/addon/connectedover/

If so : their oldest version will work with Firefox 48 and not 47 ......

But you could send them an email - see under "More information" => Support Email.

Firefox 48 need SSE2 and maximum version for me is 47

more options

saminur said

Until a few days ago "connected over" was useful.

This add-on is indeed not listed on legacycollector.org/firefox-addons/

Firefox version 48 is the oldest version that add-on will work with; unless you're willing to try one of the legacy add-ons that are listed on legacycollector.org/firefox-addons - you could try to contact the developer, as you mention that it worked just fine till a few days ago .....

Modified by McCoy

more options

This article would suggest that Firefox 49 requires SSE2 and that Firefox 48 still should work. Note that recommended doesn't mean that you actually need SSE2

The System Requirement pages confirm this. Recommended HardwareL Pentium 4 or newer processor that supports SSE2

Pentium 4 or newer processor that supports SSE2

All Firefox releases on the Mozilla server:

more options

Thank you all friends , But my problem did not solved !

more options

Were you able to install Firefox 48.0.2?

more options

cor-el said

Were you able to install Firefox 48.0.2?

I installed Firefox 48.0.2 now .

Modified by saminur

  1. 1
  2. 2