Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Multiple profiles in Firefox 67 broke default browser click!

more options

Hi all,

Since Firefox 67 we can use more profiles at once. But this broke default click settings when the profile is not in the default place.

Before Firefox 67: If Firefox was the default browser, and the profile was for example d:\firefox, and I clicked a link in other program, for example mail client, the link was just passed to firefox.exe, and Firefox knew the profile (if it is running) so just started the link in the correct profile.

But now: If I click a link outside firefox, the browser just launches with an another, default firefox profile (c:\users\appdata... etc).

So how can I fix this? Can I disable this new multiple profile thing?

Modified by Ternex

Chosen solution

Thanks for this! The solution was editing the installs.ini and profiles.ini as:

installs.ini:


[308046B0AF4A39CB] Default=d:\Firefox Locked=1



and profiles.ini:


[Install308046B0AF4A39CB] Default=d:\Firefox Locked=1

[Profile0] Name=Default User IsRelative=0 Path=d:\Firefox

[General] StartWithLastProfile=1 Version=2


Read this answer in context 👍 0

All Replies (9)

more options

You can change your default profile in Firefox by opening the Profile Manager and checking the Use the selected profile without asking at startup option.

Hope this helps.

more options

Yes, I think that this is related to the new feature that allows to lock profiles to be used with a specific Firefox version. The installs.ini file is used to link a specific Firefox installation to a specific profile. If this profile isn't active then Firefox can launch a new instance that uses this profile. I don't know whether and how this possibly could be circumvented via editing profiles.ini and installs.ini.

more options

Wesley Branton said

You can change your default profile in Firefox by opening the Profile Manager and checking the Use the selected profile without asking at startup option. Hope this helps.

Sorry, but no. There is no profiles at all. If I start firefox with "C:\Program Files\Mozilla Firefox\firefox.exe" -profile d:\firefox there will be no saved profiles.

more options

cor-el said

Yes, I think that this is related to the new feature that allows to lock profiles to be used with a specific Firefox version. The installs.ini file is used to link a specific Firefox installation to a specific profile. If this profile isn't active then Firefox can launch a new instance that uses this profile. I don't know whether and how this possibly could be circumvented via editing profiles.ini and installs.ini.

Sorry, but that also not helps.

more options

Is there any way to disable multiple profiles?

more options

In Windows, go to the following file path %appdata%\Mozilla\Firefox and open the installs.ini file.

If you only have one version of Firefox, there should be only one install listed. For example, this is what mine looks like:

[AA0410758320E61A]
Default=Profiles/2pq09vj2.Wesley
Locked=1

Now open the profiles.ini file in the same folder. There should be just one profile listed, although sometimes there are multiple. For example, I have multiple profiles, so this is what part of my file looks like:

[Profile1]
Name=Mozilla Support
IsRelative=1
Path=Profiles/obf202yn.Mozilla Support

[Profile0]
Name=Wesley
IsRelative=1
Path=Profiles/2pq09vj2.Wesley
Default=1

[General]
StartWithLastProfile=1
Version=2

[InstallAA0410758320E61A]
Default=Profiles/2pq09vj2.Wesley
Locked=1

You want to make sure that the "Default" value of each install matches the "Path" value of the file that you want to use. You also need to move the "Default=1" part to the profile that you want to use.

For example, if I wanted to change my "Mozilla Support" profile to be the default instead of my "Wesley" profile, my files would have the following changes:

installs.ini file:

[AA0410758320E61A]
Default=Profiles/obf202yn.Mozilla Support
Locked=1

profiles.ini file:

[Profile1]
Name=Mozilla Support
IsRelative=1
Path=Profiles/obf202yn.Mozilla Support
Default=1

[Profile0]
Name=Wesley
IsRelative=1
Path=Profiles/2pq09vj2.Wesley

[General]
StartWithLastProfile=1
Version=2

[InstallAA0410758320E61A]
Default=Profiles/obf202yn.Mozilla Support
Locked=1

Hopefully it's not confusing what I've just explained. If you have more than one install listed, you have more than one different version of Firefox installed on your computer. Therefore, the "Default" value should be the same for each install.

Hope this helps.

more options

Chosen Solution

Thanks for this! The solution was editing the installs.ini and profiles.ini as:

installs.ini:


[308046B0AF4A39CB] Default=d:\Firefox Locked=1



and profiles.ini:


[Install308046B0AF4A39CB] Default=d:\Firefox Locked=1

[Profile0] Name=Default User IsRelative=0 Path=d:\Firefox

[General] StartWithLastProfile=1 Version=2


more options

I have the same problem. However, there are no "profiles.ini" or "installs.ini" files on my machine anywhere. Either under portable or desktop FF.

more options

Hi ensta! I'd recommend creating a new thread with as much details about your specific issue.

Doing so will allow the Mozilla volunteers to give you solutions that are more helpful to you. This may help them to solve your problem faster and more efficiently.