X
Tap here to go to the mobile version of the site.

Support Forum

How do I stop Firefox fro. Saving the (expletive) history?

Posted

I do not want to save search history.

I do not want to be (expletive) monitored.

I used to love Firefox. Now with you forcing me to use the app in a way that I do not want to, Firefox is starting to really (expletive) about me.

I do not want to save search history. I do not want to be (expletive) monitored. I used to love Firefox. Now with you forcing me to use the app in a way that I do not want to, Firefox is starting to really (expletive) about me.

Modified by Seburo

Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Android 9; Mobile; rv:66.0) Gecko/66.0 Firefox/66.0

More Information

Seburo
  • Top 10 Contributor
  • Moderator
682 solutions 5017 answers

Hi

I have edited your question as with this being an open forum, we try to keep things family friendly.

If you want to stop Firefox for Android displaying the search history when you search, select the options menu and select Settings. Select Search and at the bottom of the screen are options to stop the search history from being displayed.

In addition to this, I recommend clearing the browser history which you can do from the home screen by selecting History and tapping the clear history button.

I hope this helps.

Hi I have edited your question as with this being an open forum, we try to keep things family friendly. If you want to stop Firefox for Android displaying the search history when you search, select the options menu and select '''Settings'''. Select '''Search''' and at the bottom of the screen are options to stop the search history from being displayed. In addition to this, I recommend clearing the browser history which you can do from the home screen by selecting '''History''' and tapping the clear history button. I hope this helps.
Was this helpful to you? 0
Quote

Question owner

This didn't solve my problem.

I don't want it saving the history on the first place.

Hiding the tab doesn't solve the problem.

How do I set incognito mode as the default?

This didn't solve my problem. I don't want it saving the history on the first place. Hiding the tab doesn't solve the problem. How do I set incognito mode as the default?
Was this helpful to you?
Quote
Seburo
  • Top 10 Contributor
  • Moderator
682 solutions 5017 answers

Hi

You should check out Firefox Focus, a browser that basically runs in private browsing mode all the time. This is available from Google Play.

Hi You should check out Firefox Focus, a browser that basically runs in private browsing mode all the time. This is available from Google Play.
Was this helpful to you?
Quote

Question owner

WOW!

Is that the best you could come up with?

WOW! Is that the best you could come up with?
Was this helpful to you?
Quote
Seburo
  • Top 10 Contributor
  • Moderator
682 solutions 5017 answers

Hi

Just trying to find a solution to help. Essentially it is impossible for the device not to download the contents of pages to your device - it needs to do this to be able to display them on the screen for you.

Have you tried the methods listed here?

Hi Just trying to find a solution to help. Essentially it is impossible for the device not to download the contents of pages to your device - it needs to do this to be able to display them on the screen for you. Have you tried the methods listed [https://support.mozilla.org/en-US/kb/clear-your-browsing-history-and-other-personal-data here]?
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.