X
Tap here to go to the mobile version of the site.

Support Forum

Lass Pass, Ublock Origin, and DuckDuckGo are still not working in Linux. They are all ok in Windows. Do you have a fix?

Posted

Linux Ubuntu - fails to download Last Pass, Ublock, and DuckDuckGo. HTTPS works - it's the only one that came back after the add-ons problem starting May 3, 2019. Add-ons Manager shows them as Legacy Extensions.

My Windows pc updated and all add-ons are back no problem.

Any help for Linux?

Linux Ubuntu - fails to download Last Pass, Ublock, and DuckDuckGo. HTTPS works - it's the only one that came back after the add-ons problem starting May 3, 2019. Add-ons Manager shows them as Legacy Extensions. My Windows pc updated and all add-ons are back no problem. Any help for Linux?

Chosen solution

Many distributions, probably including yours, have custom tweaked variants of Firefox that may take longer to catch up with official releases. Please check your repo.

You also have the option to switch to Mozilla's version, although, I don't know if you can just drop it in or whether some settings might be incompatible. https://www.mozilla.org/firefox/all/

Read this answer in context 0
Quote

Additional System Details

Application

  • Firefox 66.0.3
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:66.0) Gecko/20100101 Firefox/66.0
  • Support URL: https://support.mozilla.org/1/firefox/66.0.3/Linux/en-US/

Extensions

  • HTTPS Everywhere 2019.5.6.1 (https-everywhere@eff.org)
  • DuckDuckGo Privacy Essentials 2019.4.26 (jid1-ZAdIEUB7XOzOJw@jetpack) (Inactive)
  • LastPass: Free Password Manager 4.27.2.10 (support@lastpass.com) (Inactive)
  • uBlock Origin 1.18.16 (uBlock0@raymondhill.net) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) 945GM x86/MMX/SSE2
  • adapterDeviceID: Mesa DRI Intel(R) 945GM x86/MMX/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • contentUsesTiling: False
  • crashGuards: []
  • driverDate:
  • driverVersion: 1.4 Mesa 18.2.8
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'CairoUseXRender': 0, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • lowEndMachine: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: {u'key': u'blocked-gfx-card'}
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 1
  • targetFrameRate: 60
  • usesTiling: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL creation failed: * Refused to create native OpenGL context because of blacklist entry: FEATURE_FAILURE_OPENGL_1 * Exhausted GL driver options.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL creation failed: * Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_OPENGL_1
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4194 solutions 58544 answers

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version 66.0.4 May 5, 2019 Fixes add-on certificate issue. 66.0.5 May 7, 2019 Further improvements to re-enable web extensions

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version '''66.0.4''' May 5, 2019 Fixes add-on certificate issue. '''66.0.5''' May 7, 2019 Further improvements to re-enable web extensions
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8583 solutions 70216 answers

Chosen Solution

Many distributions, probably including yours, have custom tweaked variants of Firefox that may take longer to catch up with official releases. Please check your repo.

You also have the option to switch to Mozilla's version, although, I don't know if you can just drop it in or whether some settings might be incompatible. https://www.mozilla.org/firefox/all/

Many distributions, probably including yours, have custom tweaked variants of Firefox that may take longer to catch up with official releases. Please check your repo. You also have the option to switch to Mozilla's version, although, I don't know if you can just drop it in or whether some settings might be incompatible. https://www.mozilla.org/firefox/all/
Was this helpful to you?
Quote

Question owner

All set now. Thanks for fixing! No action was needed. Everything came back in Linux Ubuntu.

All set now. Thanks for fixing! No action was needed. Everything came back in Linux Ubuntu.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.