X
Tap here to go to the mobile version of the site.

Support Forum

Running Firefox 52.9.0 on XP, Addblock disabled by Firefox. Please, how to enable - getting bombed with ads now :(

Posted

I know I'm running an old firefox on an old system. I know it's not safe but it's all I have. Would love to know how to enable Addblock plus again. Thanks.

I know I'm running an old firefox on an old system. I know it's not safe but it's all I have. Would love to know how to enable Addblock plus again. Thanks.

Chosen solution

Yes, running like before.

Thank you very much,

Monique

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.141.2 for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 32.0 r0
  • 5.1.30514.0
  • VLC media player Web Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5282 solutions 23337 answers

Helpful Reply

hi moniquelaw, sorry for this mishap! mozilla is considering in which way the problem should be addressed for users on legacy versions at the moment.

this would be an unofficial workaround i can offer in the meantime (basically the same steps that the automated hotfix was performing in the still supported versions of the browser):

=

(1) Download the fixed certificate

The updated necessary certificate is available for download at https://hg.mozilla.org/releases/mozilla-release/raw-file/tip/security/apps/addons-public-intermediate.crt

Go to the Options/Preferences page, Advanced section, Certificates panel, then click Certificate Manager. Make sure the Authorities tab is selected, then click Import. Find the file you downloaded and open it, then you should get a dialog - don't check any of the boxes, just click OK. Then you should see the new cert in the list in the Certificate Manager, as shown in Screenshot #1.

(2) Clear the time Firefox last re-verified

This will set Firefox up to check much sooner than it otherwise would check.

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(B) In the search box above the list, type or paste xpi- and pause while the list is filtered

(C) Right-click the app.update.lastUpdateTime.xpi-signature-verification preference and click Reset on the context menu

Screenshot #2 illustrates the expected result.

(3) Restart Firefox

You can exit Firefox normally, then start it up again. It should take a few seconds, but then your addons should turn back into an active state

Hopefully that will work for you.

hi moniquelaw, sorry for this mishap! mozilla is considering in which way the problem should be addressed for users on legacy versions at the moment. this would be an unofficial workaround i can offer in the meantime (basically the same steps that the automated hotfix was performing in the still supported versions of the browser): === (1) Download the fixed certificate The updated necessary certificate is available for download at https://hg.mozilla.org/releases/mozilla-release/raw-file/tip/security/apps/addons-public-intermediate.crt Go to the Options/Preferences page, Advanced section, Certificates panel, then click Certificate Manager. Make sure the Authorities tab is selected, then click Import. Find the file you downloaded and open it, then you should get a dialog - don't check any of the boxes, just click OK. Then you should see the new cert in the list in the Certificate Manager, as shown in Screenshot #1. (2) Clear the time Firefox last re-verified This will set Firefox up to check much sooner than it otherwise would check. (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (B) In the search box above the list, type or paste xpi- and pause while the list is filtered (C) Right-click the '''app.update.lastUpdateTime.xpi-signature-verification''' preference and click Reset on the context menu Screenshot #2 illustrates the expected result. (3) Restart Firefox You can exit Firefox normally, then start it up again. It should take a few seconds, but then your addons should turn back into an active state Hopefully that will work for you.
Was this helpful to you? 1
Quote

Chosen Solution

Yes, running like before.

Thank you very much,

Monique

Yes, running like before. Thank you very much, Monique
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.