X
Tap here to go to the mobile version of the site.

Support Forum

extensions not working

Posted

All at once, extensions/ add-ons just stopped working. Nothing was installed, or added on. Nothing was being done. Just basic browsing. Then all at once they disappeared... now marked as legacy.... impossible.

x-notifier 1password ablock plus amazon assistant lastpass ebates rakuten wikibuy etc

Yes, I have the latest browser. Yes, I downloaded it again. v 66.03

All at once, extensions/ add-ons just stopped working. Nothing was installed, or added on. Nothing was being done. Just basic browsing. Then all at once they disappeared... now marked as legacy.... impossible. x-notifier 1password ablock plus amazon assistant lastpass ebates rakuten wikibuy etc Yes, I have the latest browser. Yes, I downloaded it again. v 66.03
Attached screenshots

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8492 solutions 69396 answers

Helpful Reply

Sorry, the Add-ons team is working on a fix for this. It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.)

I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon.

Sorry, the Add-ons team is working on a fix for this. It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.) I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon.
nn6o 0 solutions 1 answers

There's a work-around if you're using the ESR, Developer, or Nightly Builds versions - disable the signing requirement.

Change the following preference to "false" in about:config:

 xpinstall.signatures.required

This is documented in the "Add-on signing in Firefox" document on the Mozilla support site:

 http://mzl.la/1J7Lcsp

I just made the change in FF 66.6.1 ESR and it works - the effect is immediate and my extensions are all working again!

 - nn6o
There's a work-around if you're using the ESR, Developer, or Nightly Builds versions - disable the signing requirement. Change the following preference to "false" in about:config: xpinstall.signatures.required This is documented in the "Add-on signing in Firefox" document on the Mozilla support site: http://mzl.la/1J7Lcsp I just made the change in FF 66.6.1 ESR and it works - the effect is immediate and my extensions are all working again! - nn6o
tahwos 2 solutions 16 answers

Helpful Reply

That's some BS right there... right in the middle of browsing, a bright yellow banner pops up, ""All of your add-ons have been disabled...blah, blah, blah" Really Mozilla? f'n really? Well, no YouTube for me tonight - off to bed I guess...

That's some BS right there... right in the middle of browsing, a bright yellow banner pops up, ""All of your add-ons have been disabled...blah, blah, blah" Really Mozilla? f'n really? Well, no YouTube for me tonight - off to bed I guess...

Modified by tahwos

jscher2000
  • Top 10 Contributor
8492 solutions 69396 answers

The Add-ons team is still working on a fix for this. Official updates are expected to be posted here:

https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047

Currently, the only workaround for the regular release of Firefox is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so I understand this option isn't ideal.

The Add-ons team is still working on a fix for this. Official updates are expected to be posted here: https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047 Currently, the only workaround for the regular release of Firefox is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so I understand this option isn't ideal.
Chris Ilias
  • Top 25 Contributor
  • Moderator
336 solutions 1895 answers

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Preferences > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Preferences > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.
FF_Help_user 1 solutions 20 answers

Didn't work...

Chris Ilias said

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled
  1. Go to [=] > Preferences > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.
I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.
Didn't work... ''Chris Ilias [[#answer-1218418|said]]'' <blockquote> Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Preferences > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated. </blockquote>
FF_Help_user 1 solutions 20 answers

Working now...

FF_Help_user said

Didn't work... Chris Ilias said
Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled
  1. Go to [=] > Preferences > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.
I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.
Working now... ''FF_Help_user [[#answer-1218542|said]]'' <blockquote> Didn't work... ''Chris Ilias [[#answer-1218418|said]]'' <blockquote> Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Preferences > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated. </blockquote> </blockquote>
Rich_S 0 solutions 1 answers

I tried what nn6o suggested. (In about:config, set xpinstall.signatures.required = false) But also, I had to go to about:addons, and click on Disable twice (to re-enable each add-on). That made them immediately work (no relaunch needed).

I'm running FF as PortableApp (on a locked-down office PC). I think that complicates the updating...

I tried what nn6o suggested. (In about:config, set xpinstall.signatures.required = false) But also, I had to go to about:addons, and click on Disable twice (to re-enable each add-on). That made them immediately work (no relaunch needed). I'm running FF as PortableApp (on a locked-down office PC). I think that complicates the updating...