X
Tap here to go to the mobile version of the site.

Support Forum

thunderbird cannot connect to comcast imap

Posted

Last December I suddenly developed a problem connecting to my comcast imap account. Discussed and resolved here: https://forums.xfinity.com/t5/Email-Web-Browsing/Thunderbird-suddently-cannot-connect-to-imap-comcast-net/td-p/3168566

As discussed in that thread, the solution (and it only seemed to affect Ubuntu clients) was to change the designated imap server from imap.comcast.net to imap.ge.xfinity.com.

So I made that change and all was well until the last couple of days. I double checked my properties to make sure they still specified imap.ge.xfinity.com, but when I try to retrieve my email, I notice that the error pop-up says that it cannot connect to imap.comcast.net.

So why would the error report one server, when the account properties clearly indicate a different server? And how do I fix it?

Last December I suddenly developed a problem connecting to my comcast imap account. Discussed and resolved here: https://forums.xfinity.com/t5/Email-Web-Browsing/Thunderbird-suddently-cannot-connect-to-imap-comcast-net/td-p/3168566 As discussed in that thread, the solution (and it only seemed to affect Ubuntu clients) was to change the designated imap server from imap.comcast.net to imap.ge.xfinity.com. So I made that change and all was well until the last couple of days. I double checked my properties to make sure they still specified imap.ge.xfinity.com, but when I try to retrieve my email, I notice that the error pop-up says that it cannot connect to imap.comcast.net. So why would the error report one server, when the account properties clearly indicate a different server? And how do I fix it?
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

Question owner

FWIW, this seems strangely connected to the ISP. My own ISP is Comcast, but the problem only occurred when I was traveling and the local wifi was using HugesNet. I just returned home, back on Comcast, and the problem does not occur. Very strange.

FWIW, this seems strangely connected to the ISP. My own ISP is Comcast, but the problem only occurred when I was traveling and the local wifi was using HugesNet. I just returned home, back on Comcast, and the problem does not occur. Very strange.
Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3234 solutions 22197 answers

Helpful Reply

Not strange at all. Some US ISP's have for decades only allowed you to send mail if you are using their network to connect to the network. I would guess comcast have a restriction on accessing their mail servers using the same twisted logic. You might try asking them.

I think you will find the problem is defective IPv6 settings in comcasts network and that is is the root cause of both of your mysteries. Use the Config Editor to modify the setting network.dns.disableIPv6 boolean to true. That will disable the use of IPv6 in Thunderbird and probably fix the issue permanently, or until you actually have to use IPv6 for a mail server. I don;t think there are any in the wild that do not use IPV4 addresses.


Note. imap.ge.xfinity.com and imap.comcast.net both map to the same IP address. 96.118.148.75 so you connect to the same place regardless of the name used. DNS resolves the names to the same address.

Not strange at all. Some US ISP's have for decades only allowed you to send mail if you are using their network to connect to the network. I would guess comcast have a restriction on accessing their mail servers using the same twisted logic. You might try asking them. I think you will find the problem is defective IPv6 settings in comcasts network and that is is the root cause of both of your mysteries. Use the [[config editor]] to modify the setting network.dns.disableIPv6 boolean to true. That will disable the use of IPv6 in Thunderbird and probably fix the issue permanently, or until you actually have to use IPv6 for a mail server. I don;t think there are any in the wild that do not use IPV4 addresses. Note. imap.ge.xfinity.com and imap.comcast.net both map to the same IP address. 96.118.148.75 so you connect to the same place regardless of the name used. DNS resolves the names to the same address.
Was this helpful to you? 1
Quote

Question owner

One thing I forgot to mention, and that is that I had no problem getting my email on my Android, using the same local wifi network - HugesNet. And we had no cell phone signal there, so any and all access for any and all devices was via the HN wifi. So while accessing through HugesNet was most likely necessary to produce the problem, it was not in itself sufficient. This particular issue has only ever occurred on my Ubuntu laptop, running T'bird. First occurrence was at home, back in December. Then I eventually found lots of message traffic about other people having the same problem, starting about the same time, and only for Ubuntu users. The fix was to change the server name in the T'bird config, and that worked for me. Then the second occurrence was this last week when I had to access via HugesNet, and it resolved itself when I returned home. I would also note that back in October I was at the same location, on the same HN access, and had no issues at all.

One thing I forgot to mention, and that is that I had no problem getting my email on my Android, using the same local wifi network - HugesNet. And we had no cell phone signal there, so any and all access for any and all devices was via the HN wifi. So while accessing through HugesNet was most likely necessary to produce the problem, it was not in itself sufficient. This particular issue has only ever occurred on my Ubuntu laptop, running T'bird. First occurrence was at home, back in December. Then I eventually found lots of message traffic about other people having the same problem, starting about the same time, and only for Ubuntu users. The fix was to change the server name in the T'bird config, and that worked for me. Then the second occurrence was this last week when I had to access via HugesNet, and it resolved itself when I returned home. I would also note that back in October I was at the same location, on the same HN access, and had no issues at all.
Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3234 solutions 22197 answers

No point reiterating what you have said or expanding on it. Apply the change to settings. That has been the real fix for about 6 months now.

No point reiterating what you have said or expanding on it. Apply the change to settings. That has been the real fix for about 6 months now.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.