X
Tap here to go to the mobile version of the site.

Support Forum

How to disable firefox "visit this website" suggestion in url?

Posted

Firefox keeps suggesting random websites in my url bar with "visit this" on first line, even though I configured to suggest only my bookmarks and nothing else.

The answer to similar questions here were to go into about:config and disable "browser.urlbar.unifiedcomplete" option. But it seems Firefox team has deleted that option, it is no more there, I can't find it.

I disabled all suspicious browser.urlbar options and its still not helping.

Honestly, while operating by muscle memory I accidentally hit enter and go to those random sites and it drives me super really mad, it breakes all my workflow and thoughts. If there is no solution in order to save my nerves and mental health I'm gonna have to move to Google chrome or even Microsoft browser for that matter.

https://pp.userapi.com/c856132/v856132786/10712/mGrdRZTFJKI.jpg

Firefox keeps suggesting random websites in my url bar with "visit this" on first line, even though I configured to suggest only my bookmarks and nothing else. The answer to similar questions here were to go into about:config and disable "browser.urlbar.unifiedcomplete" option. But it seems Firefox team has deleted that option, it is no more there, I can't find it. I disabled all suspicious browser.urlbar options and its still not helping. Honestly, while operating by muscle memory I accidentally hit enter and go to those random sites and it drives me super really mad, it breakes all my workflow and thoughts. If there is no solution in order to save my nerves and mental health I'm gonna have to move to Google chrome or even Microsoft browser for that matter. https://pp.userapi.com/c856132/v856132786/10712/mGrdRZTFJKI.jpg

Chosen solution

The "in-URL-bar" autofill feature always suggests top level domains from history, only some of which are bookmarked. So you might prefer to disable that feature completely. Then your address bar will always search unless you enter something that "looks like" a domain name, such as mozilla.org or window.open, for example, in which case it then will try to visit that.

Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.autoFill preference to switch the value from true to false

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Chosen Solution

The "in-URL-bar" autofill feature always suggests top level domains from history, only some of which are bookmarked. So you might prefer to disable that feature completely. Then your address bar will always search unless you enter something that "looks like" a domain name, such as mozilla.org or window.open, for example, in which case it then will try to visit that.

Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.autoFill preference to switch the value from true to false

The "in-URL-bar" autofill feature always suggests top level domains from history, only some of which are bookmarked. So you might prefer to disable that feature completely. Then your address bar will always search unless you enter something that "looks like" a domain name, such as mozilla''.''org or window.open, for example, in which case it then will try to visit that. Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''URLB''' and pause while the list is filtered (3) Double-click the '''browser.urlbar.autoFill''' preference to switch the value from true to false
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.