Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to hide address bar + tabs in fullscreen on Mac—how to?

  • 12 replies
  • 1 has this problem
  • 8673 views
  • Last reply by cor-el

more options

Hello. I've been struggling to figure out how to get the address bar and tabs to hide when in fullscreen mode on my Mac. At first, I thought this was just the default setting, but after browsing other Community posts and discussions on Reddit and such, I began to suspect those are supposed to hide by default, but are not in my case.

Please see the photo attached for what I mean—the tabs and address bar never go away, if they are supposed to, regardless of whether I have a new tab or a webpage open.

I tried Firefox with all my add-ons turned off, because some posts suggested they can prevent auto-hiding. I have looked for CSS solutions and extensions which could help, but I am utterly frustrated. Please help!

Thanks in advance.

Attached screenshots

Modified by potatemodern

Chosen solution

All Replies (12)

more options

As a Windows user, I don't completely understand how Firefox runs on Mac, but for what it's worth:

Issue #1: If the cursor is in the address bar when you go to full screen, the toolbar area doesn't hide. Click out of the address bar, then exit full screen and enter it again.

Issue #2: Firefox has a switch for whether to hide the toolbar area in fullscreen. You can double-check that here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste FULLS and pause while the list is filtered

(3) If the browser.fullscreen.autohide preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

Was that relevant?

more options

Hey @jscher2000, thanks so much for your detailed reply!

Unfortunately, neither of those options work :(

At this point, I'm not even sure if FF on Mac even allows the tabs and address bar to get hidden!

more options

Some features are different on Mac and Linux than they are on Windows, but you still should have some kind of full screen feature...

Does it matter which method you use:

  • (menu bar) View > Full Screen
  • menu button > Full Screen button at the end of the "Zoom" controls
  • Command+Shift+F
more options

Hey mister, thanks for your quick follow-up once again. Unfortunately, all three methods just work the same way.

Wish I had another Mac to test if it's somehow my configuration which is making it glitch. No luck even with freshly-downloaded, un-modified install of FF.

Thanks for your help though!

more options

To test configuration, you could try:

New Profile Test

This takes about 3 minutes, plus the time to test full screen.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like April2019, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new. Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Does full screen work any better in the new profile?

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

more options

Hello, thanks again for trying to help out with this troublesome issue, and sorry for all the trouble.

I followed all your steps, and no luck—it unfortunately looks like maybe stock FF on Mac doesn't allow hiding the address bar/tabs. I'm honestly surprised how such a basic thing isn't part of the app.

Thanks again for your detailed instructions and kind attempt to solve my problem!

more options

Chosen Solution

See this topic.

more options

Hi @TyDraniu, thanks for sharing your idea! This is definitely a good fix for now, and it makes the website fill up my screen rather nicely.

That said, I will keep hoping for another solution or extension which makes it possible to auto-hide the tabs and address bar, and show them again on taking my mouse to the top of the screen (as it happens in Safari).

Thank you anyhow, will use your nice bookmarklet for now!

more options

Did you try the extension mentioned further down in that thread?

Note that some extensions aren't working on Mozilla website because of CSP rules.

more options

@cor-el, thanks for sharing, but it unfortunately just does what the normal menu bar fullscreen button does, without hiding address bar/tabs.

more options

I installed the add on, and it didn't do anything at all? anyone able to help?

more options

Keep in mind that web extensions do not work on Mozilla websites (you can't inject JavaScript files) if you only tried it there.