X
Tap here to go to the mobile version of the site.

Support Forum

Draft messages to group addresses disappear when edited

Posted

Data loss error with Thunderbird Drafts folder.

Thunderbird - Write email with group address. Save as draft. Appears in Drafts folder. Edit email without closing it - save as draft again - works as expected - Message box with green progress bar opens & closes, draft appears with updated time. Go to drafts folder, edit draft, save as draft - message disappears from Drafts folder!

Further details: Open from Drafts and edit - note that TO: address changed to Staff2019 <> This happened before 60.5.2, but the emails saved anyway. They would not send because of invalid recipient address, so sender could simply set the recipients when ready to send. Same process with a single email address (not a group) - works properly. Edited - save as draft - updated email arrived in Drafts. Not tested with a single invalid address.

Noted since ver 60.5.2, still happens in 60.5.3, and still happens after update to Thunderbird 60.6 (32 bit) This is on a system using Exquilla to work with Microsoft Exchange server. The draft is removed from both the online webmail Drafts and from the local client Drafts folder. No error message or warning.

I have a screen shot - shows the email I am editing that was in Drafts - but clearly visible Drafts folders no longer contain the message. Many thanks for any help or news of a future fix. Agnes

Data loss error with Thunderbird Drafts folder. Thunderbird - Write email with group address. Save as draft. Appears in Drafts folder. Edit email without closing it - save as draft again - works as expected - Message box with green progress bar opens & closes, draft appears with updated time. Go to drafts folder, edit draft, save as draft - message disappears from Drafts folder! Further details: Open from Drafts and edit - note that TO: address changed to Staff2019 <> This happened before 60.5.2, but the emails saved anyway. They would not send because of invalid recipient address, so sender could simply set the recipients when ready to send. Same process with a single email address (not a group) - works properly. Edited - save as draft - updated email arrived in Drafts. Not tested with a single invalid address. Noted since ver 60.5.2, still happens in 60.5.3, and still happens after update to Thunderbird 60.6 (32 bit) This is on a system using Exquilla to work with Microsoft Exchange server. The draft is removed from both the online webmail Drafts and from the local client Drafts folder. No error message or warning. I have a screen shot - shows the email I am editing that was in Drafts - but clearly visible Drafts folders no longer contain the message. Many thanks for any help or news of a future fix. Agnes
Attached screenshots

Modified by AgnesRM

Chosen solution

I would guess the issue is with the add-on, not Thunderbird. I suggest you try this add-on instead. https://addons.thunderbird.net/en-US/thunderbird/addon/owl-for-exchange/?src=hp-dl-upandcoming

It has recently been adopted as the add-on that Thunderbird will offer to install if your using an exchange server and attempt to add an exchange server account, so I might be more reliable than exeqilla which the author has basically handed to he community.

Note the same folk are behind both add-ons.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

Matt
  • Top 10 Contributor
  • Moderator
3237 solutions 22245 answers

Chosen Solution

I would guess the issue is with the add-on, not Thunderbird. I suggest you try this add-on instead. https://addons.thunderbird.net/en-US/thunderbird/addon/owl-for-exchange/?src=hp-dl-upandcoming

It has recently been adopted as the add-on that Thunderbird will offer to install if your using an exchange server and attempt to add an exchange server account, so I might be more reliable than exeqilla which the author has basically handed to he community.

Note the same folk are behind both add-ons.

I would guess the issue is with the add-on, not Thunderbird. I suggest you try this add-on instead. https://addons.thunderbird.net/en-US/thunderbird/addon/owl-for-exchange/?src=hp-dl-upandcoming It has recently been adopted as the add-on that Thunderbird will offer to install if your using an exchange server and attempt to add an exchange server account, so I might be more reliable than exeqilla which the author has basically handed to he community. Note the same folk are behind both add-ons.

Question owner

Matt, thank you for the news about Owl addon. I was wondering what we would do once Exquilla got too far behind. I will try to find time to install and test it. That may not happen right away as the Drafts problem is avoidable. Marking this as solved, but acknowledging that I have not tested Owl.

Matt, thank you for the news about Owl addon. I was wondering what we would do once Exquilla got too far behind. I will try to find time to install and test it. That may not happen right away as the Drafts problem is avoidable. Marking this as solved, but acknowledging that I have not tested Owl.