Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Autoplay can't be disabled for Yahoo

  • 4 replies
  • 1 has this problem
  • 120 views
  • Last reply by MozInAZ

more options

I am aware of the change in settings for the latest versions of Firefox. They work just about everywhere but on Yahoo.com. In addition to the global settings, I have explicitly disallowed autoplay on many Yahoo domains(e.g. https://news.yahoo.com). However the videos with sound still autoplay there, and sometimes on Fox.com (not sure whether they all do, since I seldom use that site).

How can I make Yahoo.com respect my desire not to see or hear their videos?

I've seen other topics like this, but they all are marked as solved, yet people like me keep posting in those threads, that this isn't solved. I filed a bug report, but nothing has changed in a couple releases since then.

Chosen solution

To make the "stop autoplay" work again use these settings:

media.autoplay.default: 1 media.autoplay.enabled.user-gestures-needed: false media.autoplay.allow-muted: false

Although the "media.autoplay.enabled.user-gestures-needed" seems to be wrong it brings back the "stop autoplay" feature.

Read this answer in context 👍 1

All Replies (4)

more options

I think that it is normally sufficient to create an exception for the top level domain with the correct protocol.

See also this extension.

more options

You're probably right "that it is normally sufficient to create an exception for the top level domain with the correct protocol". But for Yahoo, it doesn't work. specifying individual subdomains doesn't help.

I tried installing the add-on, and it also doesn't prevent Yahoo from autoplaying video with sound. It has a per-domain table, but there doesn't appear any way to add domains and configure preferences for those individual domains.

UPDATE: I restarted Firefox after uninstalling the add-on and then undoing that (thinking better of it). Now it works. Looks like autoplay is actually disabled everywhere!!! THANK YOU

2nd UPDATE: Now it doesn't work anymore (Yahoo.com autoplays video + sound). Thank you anyway! .

Modified by MozInAZ

more options

Chosen Solution

To make the "stop autoplay" work again use these settings:

media.autoplay.default: 1 media.autoplay.enabled.user-gestures-needed: false media.autoplay.allow-muted: false

Although the "media.autoplay.enabled.user-gestures-needed" seems to be wrong it brings back the "stop autoplay" feature.

more options

That did it! I've been fretting about this for months! THANKS!