X
Tap here to go to the mobile version of the site.

Support Forum

Firefox Add-on webpages look wrong and can neither install nor download extensions

Posted

Hi,

I am experiencing some troubles with Firefox Add-on webpages since, as I can estimate, version 60 onwards.

- Firefox Add-on webpages (https://addons.mozilla.org/en-US/firefox/) look wrong and I cannot download or install any extension.

- Also the Firefox Add-on tab (about:addons) looks weird and updating extensions fails.

- Trying to download an extension directly (such, for instance, https://addons.cdn.mozilla.net/user-media/addons/1347/clippings-6.1.3.1-fx.xpi?filehash=sha256%3A07b13f5ecfb2e4c960980faa7c8e4ef4a2ac7f9c458bf083c7bcb72efb674edf) renders a "Unable to connect" error.

- I can see Firefox Add-on pages correctly in Chrome but not in Vivaldi and Safari.


I have unsuccessfully tried the following suggested solutions:

- Refresh the page.

- Clear cookies and cache.

- Re-start Firefox with add-ons disabled.

- Refresh (reset) Firefox.

- Create a new profile.

- Disable hardware (acceleration) performance.

- Disable anti-virus.

- Disable firewall.


I have also tried to follow the suggestions in the following links without any success:

- https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently

- https://support.mozilla.org/en-US/kb/fix-problems-images-not-show

When I load the Firefox Add-ons main page the console outputs:


Content Security Policy: Directive ‘child-src’ has been deprecated. Please use directive ‘worker-src’ to control workers, or directive ‘frame-src’ to control frames respectively.

Content Security Policy: Couldn't process unknown directive 'prefetch-src'

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://addons-amo.cdn.mozilla.net/amo-c9540ad5377a2101592d.css. (Reason: CORS request did not succeed).[Learn More]

Content Security Policy: The page's settings blocked the loading of a resource at inline ("script-src"). firefox:9:1

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://addons-amo.cdn.mozilla.net/amo-0760732e46f8f83d4fa1.js. (Reason: CORS request did not succeed).[Learn More]

None of the "sha512" hashes in the integrity attribute match the content of the subresource.


So I think that there may be a problem with CSP or with CORS. I have managed to disable CORS but does not do the trick. I can find a way of disable CSP.


I am running:

Name: Firefox Version: 65.0.1 Build ID: 20190211233335 Update Channel: release User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:65.0) Gecko/20100101 Firefox/65.0 OS: Darwin 17.7.0

Any ideas?

Thanks a lot for your attention and time.

Hi, I am experiencing some troubles with Firefox Add-on webpages since, as I can estimate, version 60 onwards. - Firefox Add-on webpages (https://addons.mozilla.org/en-US/firefox/) look wrong and I cannot download or install any extension. - Also the Firefox Add-on tab (about:addons) looks weird and updating extensions fails. - Trying to download an extension directly (such, for instance, https://addons.cdn.mozilla.net/user-media/addons/1347/clippings-6.1.3.1-fx.xpi?filehash=sha256%3A07b13f5ecfb2e4c960980faa7c8e4ef4a2ac7f9c458bf083c7bcb72efb674edf) renders a "Unable to connect" error. - I can see Firefox Add-on pages correctly in Chrome but not in Vivaldi and Safari. I have unsuccessfully tried the following suggested solutions: - Refresh the page. - Clear cookies and cache. - Re-start Firefox with add-ons disabled. - Refresh (reset) Firefox. - Create a new profile. - Disable hardware (acceleration) performance. - Disable anti-virus. - Disable firewall. I have also tried to follow the suggestions in the following links without any success: - https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently - https://support.mozilla.org/en-US/kb/fix-problems-images-not-show When I load the Firefox Add-ons main page the console outputs: Content Security Policy: Directive ‘child-src’ has been deprecated. Please use directive ‘worker-src’ to control workers, or directive ‘frame-src’ to control frames respectively. Content Security Policy: Couldn't process unknown directive 'prefetch-src' Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://addons-amo.cdn.mozilla.net/amo-c9540ad5377a2101592d.css. (Reason: CORS request did not succeed).[Learn More] Content Security Policy: The page's settings blocked the loading of a resource at inline ("script-src"). firefox:9:1 Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://addons-amo.cdn.mozilla.net/amo-0760732e46f8f83d4fa1.js. (Reason: CORS request did not succeed).[Learn More] None of the "sha512" hashes in the integrity attribute match the content of the subresource. So I think that there may be a problem with CSP or with CORS. I have managed to disable CORS but does not do the trick. I can find a way of disable CSP. I am running: Name: Firefox Version: 65.0.1 Build ID: 20190211233335 Update Channel: release User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:65.0) Gecko/20100101 Firefox/65.0 OS: Darwin 17.7.0 Any ideas? Thanks a lot for your attention and time.

Modified by JVJV

Chosen solution

Finally, I have traced the source of my problems. It is Hands Off!, a internet monitor for macOs.

It blocks the connections to add-ons page even when it is supposely disabled. I must say that I have not any rule that can cause this (at least, I can find it).

I removed Hands Off and re-started the computer and Firefox ran fine. Once Hands Off! was restored, the issue re-emerged.

I have tested Hands Off! as a source of troubles in many occasions but I have ever uninstalled it before.

So, thank to all of you for your help. Sorry for inconvenience.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

FredMcD
  • Top 10 Contributor
4224 solutions 58943 answers

Looks Like you tried everything.

Let’s do a full clean re-install;

Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Note: Check Both Folders

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Looks Like you tried everything. Let’s do a full clean re-install; [http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems] {web link} Save the file. Then '''Close Firefox. ''' Using your file browser, open the '''Programs Folder''' on your computer. '''Windows: ''' C:\Program Files C:\Program Files (x86) '''Note:''' Check Both Folders '''Mac: ''' Open the ''' "Applications" ''' folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac '''Linux: ''' Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any '''Mozilla''' or '''Firefox''' program folders. Do not remove the '''Mozilla Thunderbird''' folder if there is one. '''Do Not''' remove any profile folders. After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your '''Computer''' in safe mode and try again. http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Question owner

I have tried a clean installation in the past without any result.

Let's give it a try again.

Thanks.

I have tried a clean installation in the past without any result. Let's give it a try again. Thanks.

Question owner

I cannot even download Firefox inside Firefox: https://download-installer.cdn.mozilla.net/pub/firefox/releases/65.0.2/mac/en-GB/Firefox%2065.0.2.dmg is "Unable to connect".

I cannot even download Firefox inside Firefox: https://download-installer.cdn.mozilla.net/pub/firefox/releases/65.0.2/mac/en-GB/Firefox%2065.0.2.dmg is "Unable to connect".

Question owner

Clean re-installation does not work.

Clean re-installation does not work.
FredMcD
  • Top 10 Contributor
4224 solutions 58943 answers

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Secure''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Question owner

I re-started my computer in safe mode and add-on pages work perfectly in Firefox. I do not try "Secure websites" (I am not really sure what I should done).

Once again in "normal" mode, the issue remains.

What does it means?

I re-started my computer in safe mode and add-on pages work perfectly in Firefox. I do not try "Secure websites" (I am not really sure what I should done). Once again in "normal" mode, the issue remains. What does it means?
FredMcD
  • Top 10 Contributor
4224 solutions 58943 answers

That means something on the computer is creating the issue.

As a test, disable your protection programs.

https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently

That means something on the computer is creating the issue. As a test, disable your protection programs. https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently

Question owner

Disabling the anti-virus and the Internet monitor have no effect

I have also tried these solutions but they all of them have fail:

- Changing GPU driver from Nvidia to default macOs driver

- Updating Flash Player (tough I regularly make updates)

- Updating CUDA driver

- Reviewing macOs login items and remove unneccessary ones

- Checking fonts for duplicates and errors

- Removing all system, fonts, and application caches

- Re-building launch services

- Clearing DNS cache

- Changing Firefox Network preferences from No Proxy to Autodetect

- Changing DNS server

- Some solutions provided at https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently

- Solutions from https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

- Running EtreCheck and resolve some minor issues on my system.

- Testing a different version of Firefox (60.5.1 which is properly working under Tor Browser)

None of these made a difference.

How can I find what is causing this issue?

Thanks.

Disabling the anti-virus and the Internet monitor have no effect I have also tried these solutions but they all of them have fail: - Changing GPU driver from Nvidia to default macOs driver - Updating Flash Player (tough I regularly make updates) - Updating CUDA driver - Reviewing macOs login items and remove unneccessary ones - Checking fonts for duplicates and errors - Removing all system, fonts, and application caches - Re-building launch services - Clearing DNS cache - Changing Firefox Network preferences from No Proxy to Autodetect - Changing DNS server - Some solutions provided at https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently - Solutions from https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can - Running EtreCheck and resolve some minor issues on my system. - '''Testing a different version of Firefox (60.5.1 which is properly working under Tor Browser)''' None of these made a difference. How can I find what is causing this issue? Thanks.
FredMcD
  • Top 10 Contributor
4224 solutions 58943 answers

I called for more help.

I called for more help.
jscher2000
  • Top 10 Contributor
8635 solutions 70627 answers

Do all the problem URLs have the letters cdn somewhere in them? Some users have filtering (security or parental control) software that is allergic to CDN addresses, but I can't recall ever learning the name of the product(s) involved.

Do all the problem URLs have the letters '''cdn''' somewhere in them? Some users have filtering (security or parental control) software that is allergic to CDN addresses, but I can't recall ever learning the name of the product(s) involved.

Question owner

Not specifically. Most failing URLs are related with mozilla.org

For instance, some URLs return a "Unable to connect" page, such as:

Otherwise, some other mozilla-related pages are simply render wrong, such as:

Of course, there are lots of mozilla pages that work properly and as rendered as expected.

There are also some other URLs (no-Mozilla ones) that are not well rendered or which cannot be reached, but I can see any pattern in these troubling URLs.

All the URLs failing in Firefox can be opened in other browsers such as Chrome, Vivaldi, and Safari so I doubt that could be a firewall issue.

However, as soon as I can (I am working now with my computer), I will try to completely remove the internet firewall from my system to test this possibility.

Thanks.

Not specifically. Most failing URLs are related with mozilla.org For instance, some URLs return a "Unable to connect" page, such as: * https://developer.mozilla.org * https://mixedreality.mozilla.org * https://games.mozilla.org/ * https://donate.mozilla.org/ * https://addons.cdn.mozilla.net/ Otherwise, some other mozilla-related pages are simply render wrong, such as: * https://addons.mozilla.org * https://getpocket.com Of course, there are lots of mozilla pages that work properly and as rendered as expected. There are also some other URLs (no-Mozilla ones) that are not well rendered or which cannot be reached, but I can see any pattern in these troubling URLs. All the URLs failing in Firefox can be opened in other browsers such as Chrome, Vivaldi, and Safari so I doubt that could be a firewall issue. However, as soon as I can (I am working now with my computer), I will try to completely remove the internet firewall from my system to test this possibility. Thanks.

Chosen Solution

Finally, I have traced the source of my problems. It is Hands Off!, a internet monitor for macOs.

It blocks the connections to add-ons page even when it is supposely disabled. I must say that I have not any rule that can cause this (at least, I can find it).

I removed Hands Off and re-started the computer and Firefox ran fine. Once Hands Off! was restored, the issue re-emerged.

I have tested Hands Off! as a source of troubles in many occasions but I have ever uninstalled it before.

So, thank to all of you for your help. Sorry for inconvenience.

Finally, I have traced the source of my problems. It is '''Hands Off!''', a internet monitor for macOs. It blocks the connections to add-ons page even when it is supposely disabled. I must say that I have not any rule that can cause this (at least, I can find it). I removed Hands Off and re-started the computer and Firefox ran fine. Once Hands Off! was restored, the issue re-emerged. I have tested Hands Off! as a source of troubles in many occasions but I have ever uninstalled it before. So, thank to all of you for your help. Sorry for inconvenience.

Modified by JVJV

FredMcD
  • Top 10 Contributor
4224 solutions 58943 answers

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

Your solution today can help others in the future. That is not an inconvenience.

You might want to tell Hands Off! support about the issue.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know. Your solution today can help others in the future. That is not an inconvenience. You might want to tell Hands Off! support about the issue.