X
Tap here to go to the mobile version of the site.

Support Forum

Ubuntu Linux: No sound at all in Firefox 65.0.1

Posted

All other apps (like Chrome, Spotify, and audio configuration sound test) sound fine.

I've tried -safe-mode, re-installing, and removing duplicate Flash plugins. My /etc/hosts file is Xhosts, I've cleared the cache, pulseaudio is running, all pop-ups are allowed,

Description: Ubuntu 18.10 Codename: cosmic Linux Who 4.18.0-16-generic #17-Ubuntu SMP Fri Feb 8 00:06:57 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux buster/sid GNOME Shell 3.30.2

For sound-test I've used both of these in both Chrome and Firefox: http://camendesign.com/code/video_for_everybody/test.html https://www.youtube.com/watch?v=Lo01PcgxHMU

Thanks, 
    Warren (fredistic@gmail.com)

PS: The "Automatically add" green button below only brings up a page that says it's lost.

All other apps (like Chrome, Spotify, and audio configuration sound test) sound fine. I've tried -safe-mode, re-installing, and removing duplicate Flash plugins. My /etc/hosts file is Xhosts, I've cleared the cache, pulseaudio is running, all pop-ups are allowed, Description: Ubuntu 18.10 Codename: cosmic Linux Who 4.18.0-16-generic #17-Ubuntu SMP Fri Feb 8 00:06:57 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux buster/sid GNOME Shell 3.30.2 For sound-test I've used both of these in both Chrome and Firefox: http://camendesign.com/code/video_for_everybody/test.html https://www.youtube.com/watch?v=Lo01PcgxHMU Thanks, Warren (fredistic@gmail.com) PS: The "Automatically add" green button below only brings up a page that says it's lost.

Chosen solution

As it is based on Debian, I suppose the desktop independent method on Ubuntu is putting start-pulseaudio-x11 & into ~/.xsessionrc (see https://wiki.debian.org/Xsession#User_configuration and https://www.debian.org/doc/manuals/debian-reference/ch07.en.html#_customizing_the_x_session_new_method).

You can of course also add the command to the autostart applications specific to your environment - there's probably a GUI interface for doing that in the settings (see https://wiki.archlinux.org/index.php/Autostarting#On_desktop_environment_startup). level 4 diarrheaninja 2 points · 5 months ago

Alright, it looks like it was definitely a problem with pulseaudio, but I couldn't figure out how to make it run. It kept saying failed to start.

I found the solution on this page. Posting the fix in case anyone else has this problem:

In the terminal, type:

rm ~/.config/pulse/*

And hit enter.

Then reboot.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Safari/537.36

More Information

davidspriggs 3 solutions 67 answers

Chosen Solution

As it is based on Debian, I suppose the desktop independent method on Ubuntu is putting start-pulseaudio-x11 & into ~/.xsessionrc (see https://wiki.debian.org/Xsession#User_configuration and https://www.debian.org/doc/manuals/debian-reference/ch07.en.html#_customizing_the_x_session_new_method).

You can of course also add the command to the autostart applications specific to your environment - there's probably a GUI interface for doing that in the settings (see https://wiki.archlinux.org/index.php/Autostarting#On_desktop_environment_startup). level 4 diarrheaninja 2 points · 5 months ago

Alright, it looks like it was definitely a problem with pulseaudio, but I couldn't figure out how to make it run. It kept saying failed to start.

I found the solution on this page. Posting the fix in case anyone else has this problem:

In the terminal, type:

rm ~/.config/pulse/*

And hit enter.

Then reboot.

As it is based on Debian, I suppose the desktop independent method on Ubuntu is putting start-pulseaudio-x11 & into ~/.xsessionrc (see https://wiki.debian.org/Xsession#User_configuration and https://www.debian.org/doc/manuals/debian-reference/ch07.en.html#_customizing_the_x_session_new_method). You can of course also add the command to the autostart applications specific to your environment - there's probably a GUI interface for doing that in the settings (see https://wiki.archlinux.org/index.php/Autostarting#On_desktop_environment_startup). level 4 diarrheaninja 2 points · 5 months ago Alright, it looks like it was definitely a problem with pulseaudio, but I couldn't figure out how to make it run. It kept saying failed to start. I found the solution on this page. Posting the fix in case anyone else has this problem: In the terminal, type: rm ~/.config/pulse/* And hit enter. Then reboot.
Was this helpful to you? 1
Quote

Question owner

Hey! This worked! Crazy Man! Thank You! Thank You very much!!!!!!!!!!!!!

Hey! '''This worked'''! Crazy Man! Thank You! Thank You very much!!!!!!!!!!!!!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.