X
Tap here to go to the mobile version of the site.

Support Forum

Thunderbird keeps deleting all my AOL emails.

Posted

I was trying to fix my mail filters and when I selected "match all meaasges" as the criterior Thunderbird deleted all the email in my AOL account on both the server and my computer. Luckily I had just copied all my email folders from Thunderbird over to a different drive, but when I copy the AOL folder back over to Thunderbird and click the AOL folder in Thunderbird I see the emails briefly just before Thunderbird deletes everything I just copied over.

How can I stop Thunderbird from deleting the emails. I want to be able to upload them back to the AOL server. How can I fix this situation?

I was trying to fix my mail filters and when I selected "match all meaasges" as the criterior Thunderbird deleted all the email in my AOL account on both the server and my computer. Luckily I had just copied all my email folders from Thunderbird over to a different drive, but when I copy the AOL folder back over to Thunderbird and click the AOL folder in Thunderbird I see the emails briefly just before Thunderbird deletes everything I just copied over. How can I stop Thunderbird from deleting the emails. I want to be able to upload them back to the AOL server. How can I fix this situation?

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

sfhowes
  • Top 10 Contributor
1492 solutions 7071 answers

'Match all messages' applies the selected Action to all messages in the folder, irrespective of the rules or criteria. So, if one of the actions is to move or delete, it will do that to the entire folder.

Select 'Match all of the following' so that messages must satisfy all of the criteria, or 'Match any of the following' to have any of the criteria satisfied.

'Match all messages' applies the selected Action to all messages in the folder, irrespective of the rules or criteria. So, if one of the actions is to move or delete, it will do that to the entire folder. Select 'Match all of the following' so that messages must satisfy all of the criteria, or 'Match any of the following' to have any of the criteria satisfied.

Question owner

sfhowes said

'Match all messages' applies the selected Action to all messages in the folder, irrespective of the rules or criteria. So, if one of the actions is to move or delete, it will do that to the entire folder. Select 'Match all of the following' so that messages must satisfy all of the criteria, or 'Match any of the following' to have any of the criteria satisfied.

So how is this going to help me solve my question? I thought answering a question would involve a solution of some sort. So where is your solution?

''sfhowes [[#answer-1203994|said]]'' <blockquote> 'Match all messages' applies the selected Action to all messages in the folder, irrespective of the rules or criteria. So, if one of the actions is to move or delete, it will do that to the entire folder. Select 'Match all of the following' so that messages must satisfy all of the criteria, or 'Match any of the following' to have any of the criteria satisfied. </blockquote> So how is this going to help me solve my question? I thought answering a question would involve a solution of some sort. So where is your solution?
sfhowes
  • Top 10 Contributor
1492 solutions 7071 answers

Helpful Reply

Don't copy the mail back to the folder which is acted upon by the incorrect filter. Copy it to a subfolder of Local Folders. If you must upload messages to the IMAP folder, do it in small batches, and don't do so until the filter is corrected.

Don't copy the mail back to the folder which is acted upon by the incorrect filter. Copy it to a subfolder of Local Folders. If you must upload messages to the IMAP folder, do it in small batches, and don't do so until the filter is corrected.

Question owner

I found a solution to my problem.

1) I downloaded and installed the ImportExportTools addon for Thunderbird from https://freeshell.de/~kaosmos/importexporttools-en.html.

2) I turned off my wifi connection then copied my saved emails over to my AOL account in Thunderbird then exported the emails into a separate folder on my desktop.

3) I turned Wifi back on and imported the emails from step 2 back into my AOL account which was setup as IMAP. When Thunderbird imported the emails from the folder on my desktop it also uploaded them to the AOL server simultaneously.

Problem solved. Thunderbird no longer deletes the emails as it did before.

I found a solution to my problem. 1) I downloaded and installed the ImportExportTools addon for Thunderbird from https://freeshell.de/~kaosmos/importexporttools-en.html. 2) I turned off my wifi connection then copied my saved emails over to my AOL account in Thunderbird then exported the emails into a separate folder on my desktop. 3) I turned Wifi back on and imported the emails from step 2 back into my AOL account which was setup as IMAP. When Thunderbird imported the emails from the folder on my desktop it also uploaded them to the AOL server simultaneously. Problem solved. Thunderbird no longer deletes the emails as it did before.

Question owner

sfhowes said

Don't copy the mail back to the folder which is acted upon by the incorrect filter. Copy it to a subfolder of Local Folders. If you must upload messages to the IMAP folder, do it in small batches, and don't do so until the filter is corrected.

There was no filter being applied because I deleted and recreated the AOL account in Thunderbird several times and copied over the saved emails from a different location on my hard drive but the minute Thunderbird saw the copied emails it deleted them. I was only able to fix things by following the steps I just outlined above. Thanks though for trying to help.

''sfhowes [[#answer-1204072|said]]'' <blockquote> Don't copy the mail back to the folder which is acted upon by the incorrect filter. Copy it to a subfolder of Local Folders. If you must upload messages to the IMAP folder, do it in small batches, and don't do so until the filter is corrected. </blockquote> There was no filter being applied because I deleted and recreated the AOL account in Thunderbird several times and copied over the saved emails from a different location on my hard drive but the minute Thunderbird saw the copied emails it deleted them. I was only able to fix things by following the steps I just outlined above. Thanks though for trying to help.
Matt
  • Top 10 Contributor
  • Moderator
3233 solutions 22195 answers

SpeakEasy said

Problem solved. Thunderbird no longer deletes the emails as it did before.


Just to be clear, Thunderbird was not deleting the messages, AOL was. While I don't understand IMAP speak the conversation would have gone something like.

Thunderbird: Hi Thunderbird here. Whats new in the inbox. AOL: Funny your should ask, delete the lot. changes before XXXXX Mine is empty. Thunderbird: OK, get right to it. I have nothing new bye.


By doing what you did, the mail get to the inbox as a new item. so Thunderbird after it deletes everything to get back into sync say.

Thunderbird: Got this new mail. This one. AOL: Got it. Reference XXXXXXXX Thunderbird :here is another and so on 20,000 times or however many mails there are.

''SpeakEasy [[#answer-1204077|said]]'' <blockquote> Problem solved. Thunderbird no longer deletes the emails as it did before. </blockquote> Just to be clear, Thunderbird was not deleting the messages, AOL was. While I don't understand IMAP speak the conversation would have gone something like. Thunderbird: Hi Thunderbird here. Whats new in the inbox. AOL: Funny your should ask, delete the lot. changes before XXXXX Mine is empty. Thunderbird: OK, get right to it. I have nothing new bye. By doing what you did, the mail get to the inbox as a new item. so Thunderbird after it deletes everything to get back into sync say. Thunderbird: Got this new mail. This one. AOL: Got it. Reference XXXXXXXX Thunderbird :here is another and so on 20,000 times or however many mails there are.