X
Tap here to go to the mobile version of the site.

Support Forum

message filters not working acurately

Posted

I have created several filters for my email. Several emails keep getting filtered out of my inbox into the wrong folder, and it is not clear why. I made the filter mark everything with a star as it moved them, and the ones that are incorrect were moved, but never starred. The filter log lists everything that was moved correctly, but the ones that are incorrect are not listed. I'm mystified at this point.

I have created several filters for my email. Several emails keep getting filtered out of my inbox into the wrong folder, and it is not clear why. I made the filter mark everything with a star as it moved them, and the ones that are incorrect were moved, but never starred. The filter log lists everything that was moved correctly, but the ones that are incorrect are not listed. I'm mystified at this point.

Chosen solution

Is it an IMAP account and you have filters moving mail on another device, or server side? That is the usual cause of complaints filters don't work reliably.

That and the filters are not actually in the account that need to be to filter mail.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

Matt
  • Top 10 Contributor
  • Moderator
3234 solutions 22200 answers

Chosen Solution

Is it an IMAP account and you have filters moving mail on another device, or server side? That is the usual cause of complaints filters don't work reliably.

That and the filters are not actually in the account that need to be to filter mail.

Is it an IMAP account and you have filters moving mail on another device, or server side? That is the usual cause of complaints filters don't work reliably. That and the filters are not actually in the account that need to be to filter mail.
bobgru 0 solutions 14 answers

I have a related problem. A few weeks ago the filters that I've had to set up to send offensive spam to the Trash folder QUIT WORKING so that the garbage remains in my Inbox. This happens with several of my email addresses that all receive similar criminal purpose spams from an ever changing variety of abusive spammers using different sending names. Even after I set up the filters against the "new" senders, the trash remains in my Inbox and *won't* move to the Trash folder.

I have a related problem. A few weeks ago the filters that I've had to set up to send offensive spam to the Trash folder QUIT WORKING so that the garbage remains in my Inbox. This happens with several of my email addresses that all receive similar criminal purpose spams from an ever changing variety of abusive spammers using different sending names. Even after I set up the filters against the "new" senders, the trash remains in my Inbox and *won't* move to the Trash folder.