X
Tap here to go to the mobile version of the site.

Support Forum

Firefox in Ubuntu is slow resolving any host for the first time, then it's fine

Posted

Affected OSes: Ubuntu/Xubuntu 18.04.1/18.04.2 LTS

Non-affected OSes: Windows 10

Browser: Firefox latest stable version and some previous versions at least back to when Ubuntu 18.04.1 was out.

Machines: Intel Core i5, desktop PC, either using a GPU card or the integrated one. Asus X553M, notebook

Problem: Firefox is very slow when loading a given host for the first time, e.g. www.google.com or www.youtube.com After it's done loading, browsing on that domain is ok. Please watch the video (it's on veoh.com) since it's the best way to understand the problem. https://vimeo.com/319319274 Some text and web pages content are in italian because of the geolocalization. In the video I use VirtualBox for recording convenience but it's the same behaviour in the host machine.

Tried: Everything (Ubuntu clean install, reset Firefox profile, proxy settings, disable hardware acceleration, disabling/removing all plugins and extensions, connect to cable - no router).

Important: Chromium and Opera work fine. Therefore this is obviously a bug in Firefox. Of course it may only happen under very specific hardware / network combinations, otherwise one thousand people would lament this problem. So I'm open to give additional information.

Related bug report link: https://bugzilla.mozilla.org/show_bug.cgi?id=1530205

Affected OSes: Ubuntu/Xubuntu 18.04.1/18.04.2 LTS Non-affected OSes: Windows 10 Browser: Firefox latest stable version and some previous versions at least back to when Ubuntu 18.04.1 was out. Machines: Intel Core i5, desktop PC, either using a GPU card or the integrated one. Asus X553M, notebook Problem: Firefox is very slow when loading a given host for the first time, e.g. www.google.com or www.youtube.com After it's done loading, browsing on that domain is ok. Please watch the video (it's on veoh.com) since it's the best way to understand the problem. https://vimeo.com/319319274 Some text and web pages content are in italian because of the geolocalization. In the video I use VirtualBox for recording convenience but it's the same behaviour in the host machine. Tried: Everything (Ubuntu clean install, reset Firefox profile, proxy settings, disable hardware acceleration, disabling/removing all plugins and extensions, connect to cable - no router). Important: Chromium and Opera work fine. Therefore this is obviously a bug in Firefox. Of course it may only happen under very specific hardware / network combinations, otherwise one thousand people would lament this problem. So I'm open to give additional information. Related bug report link: https://bugzilla.mozilla.org/show_bug.cgi?id=1530205

Chosen solution

Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/71.0.3578.98 Chrome/71.0.3578.98 Safari/537.36

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17219 solutions 155544 answers

Chosen Solution

Try to disable IPv6 (check for other possible causes as well).

Try to disable IPv6 (check for other possible causes as well). *https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can
Was this helpful to you? 1
Quote

Question owner

cor-el said

Try to disable IPv6 (check for other possible causes as well).

Thank you, this solved the problem.

''cor-el [[#answer-1199846|said]]'' <blockquote> Try to disable IPv6 (check for other possible causes as well). *https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can </blockquote> Thank you, this solved the problem.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17219 solutions 155544 answers

You're welcome.

You're welcome.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.