X
Tap here to go to the mobile version of the site.

Support Forum

How to efficiently clear Cookies and History, yet preserve manually pinned Top Sites?

Posted

Hi everyone,

Clearing all cookies and history is something that I frequently do. Unfortunately, doing so also removes all Top Sites that I may have manually pinned in new tab (Firefox Home).

Do you know of an efficient way to prevent that to happen when clearing absolutely all the rest? Just preserve the pinned tabs, nothing else.

I know that in about:config, they also have they special entry: browser.newtabpage.pinned, and I think it does kind of make sense to see these manually pinned tabs more as bookmarks than as temporary cookies, really.

Thanks for your time :)

Hi everyone, Clearing all cookies and history is something that I frequently do. Unfortunately, doing so also removes all Top Sites that I may have manually pinned in new tab (Firefox Home). Do you know of an efficient way to prevent that to happen when clearing absolutely all the rest? Just preserve the pinned tabs, nothing else. I know that in about:config, they also have they special entry: browser.newtabpage.pinned, and I think it does kind of make sense to see these manually pinned tabs more as bookmarks than as temporary cookies, really. Thanks for your time :)

Chosen solution

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on Cache and Form And Search History and whatever else you want.

Read this answer in context 1
Quote
AndRo Marian 2 solutions 29 answers

Helpful Reply

I can't reproduce this. I have 2 pinned tabs and i clear all the history without cookies and after relaunch is still there.

I can't reproduce this. I have 2 pinned tabs and i clear all the history without cookies and after relaunch is still there.
Was this helpful to you? 1
Quote
FredMcD
  • Top 10 Contributor
4149 solutions 57924 answers

Chosen Solution

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on Cache and Form And Search History and whatever else you want.

Type '''about:preferences#privacy'''<enter> in the address bar. The button next to '''History, ''' select '''Use Custom Settings. ''' Turn off '''Always Use Private Browsing Mode''' Turn on '''Remember My Browsing And Download History''' At the bottom of the page, turn on '''Clear History When Firefox Closes. ''' At the far right, press the '''Settings''' button. Turn on '''Cache''' and '''Form And Search History''' and whatever else you want.
Was this helpful to you? 1
Quote

Question owner

Thanks a lot! I must have done something wrong or stupid without noticing; I'm very happy it works now. Have a very nice day!

Thanks a lot! I must have done something wrong or stupid without noticing; I'm very happy it works now. Have a very nice day!

Modified by _HAL9k_

Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4149 solutions 57924 answers

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.