X
Tap here to go to the mobile version of the site.

Support Forum

How do I prevent the welcome screens from appearing on startup?

Posted

For security purposes, EVERY time I start Firefox, the profile directory is wiped, and a very basic profile is restored from a backup (the most significant changes from the default being a prefs.js modified for enhanced security and privacy).

The downside of this is that every time I start Firefox, I have to go through the welcome screens. What option in prefs.js controls this (I will add that change to prefs.js in the empty profile)?

For security purposes, EVERY time I start Firefox, the profile directory is wiped, and a very basic profile is restored from a backup (the most significant changes from the default being a prefs.js modified for enhanced security and privacy). The downside of this is that every time I start Firefox, I have to go through the welcome screens. What option in prefs.js controls this (I will add that change to prefs.js in the empty profile)?

Chosen solution

Try this pref setting: user_pref("browser.startup.homepage_override.mstone", "ignore");

Maybe you also need a compatibility.ini file if you aren't using it yet.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

FredMcD
  • Top 10 Contributor
4230 solutions 59028 answers

When the profile is whipped, the 'flags' that tell the browser you have already seen that message gets cleared. And so you will keep seeing those messages.

Do you really need to clear the profile?

Food for thought;

http://portableapps.com/apps/internet/firefox_portable Mozilla Firefox, Portable Edition

A fully functional package of Firefox optimized for use on a USB key drive. A specialized launcher will allow most favorite extensions to work as you switch computers.

Firefox Portable is a 3rd-party build. Support is available here: http://portableapps.com/forums/support/firefox_portable

You can use sync to share data between profiles. But some data

When the profile is whipped, the 'flags' that tell the browser you have already seen that message gets cleared. And so you will keep seeing those messages. Do you really need to clear the profile? Food for thought; http://portableapps.com/apps/internet/firefox_portable '''Mozilla Firefox, Portable Edition''' A fully functional package of Firefox optimized for use on a USB key drive. A specialized launcher will allow most favorite extensions to work as you switch computers. Firefox Portable is a 3rd-party build. Support is available here: http://portableapps.com/forums/support/firefox_portable You can use sync to share data between profiles. But some data
FredMcD
  • Top 10 Contributor
4230 solutions 59028 answers

cannot be shared between different versions.

cannot be shared between different versions.
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157452 answers

Chosen Solution

Try this pref setting: user_pref("browser.startup.homepage_override.mstone", "ignore");

Maybe you also need a compatibility.ini file if you aren't using it yet.

Try this pref setting: user_pref("browser.startup.homepage_override.mstone", "ignore"); Maybe you also need a compatibility.ini file if you aren't using it yet.

Modified by cor-el

Question owner

FredMcD said

Do you really need to clear the profile?

Yes, I do. There is FAR too much spyware in Firefox. Why do I want it keeping track of the number of times I have run Firefox, for example (browser.laterrun.bookkeeping.sessionCount in prefs.js)?

I want a clean prefs.js on every start so that things like that are not stored.

''FredMcD [[#answer-1194371|said]]'' <blockquote> Do you really need to clear the profile? </blockquote> Yes, I do. There is FAR too much spyware in Firefox. Why do I want it keeping track of the number of times I have run Firefox, for example (browser.laterrun.bookkeeping.sessionCount in prefs.js)? I want a clean prefs.js on every start so that things like that are not stored.

Question owner

cor-el said

Try this pref setting: user_pref("browser.startup.homepage_override.mstone", "ignore"); Maybe you also need a compatibility.ini file if you aren't using it yet.

That worked (without any compatibility.ini file)! Thank you very much.

''cor-el [[#answer-1194580|said]]'' <blockquote> Try this pref setting: user_pref("browser.startup.homepage_override.mstone", "ignore"); Maybe you also need a compatibility.ini file if you aren't using it yet. </blockquote> That worked (without any compatibility.ini file)! Thank you very much.
FredMcD
  • Top 10 Contributor
4230 solutions 59028 answers

n.p. said

There is FAR too much spyware in Firefox.

Firefox downloaded from Mozilla is clean. In many cases, any kind of bad programs comes from contaminated websites and program installers.

Do you think you have ad/mal-ware? Further information can be found in this article; https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

''n.p. [[#answer-1194958|said]]'' <blockquote> There is FAR too much spyware in Firefox. </blockquote> Firefox downloaded from Mozilla is clean. In many cases, any kind of bad programs comes from contaminated websites and program installers. Do you think you have ad/mal-ware? Further information can be found in this article; https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.