X
Tap here to go to the mobile version of the site.

Support Forum

Glitch in copying emails from Local Folders to IMAP folders

Posted

I am trying to copy all the emails from one Local Folder to an IMAP folder. In the Local Folder, there are 4430 emails. However, when I copy all them to the IMAP folder, I end up with 4424. I can't understand why. Anyone have an idea? Thanks for your help.

See attached screenshots. First one is of Local Folders, second one is of IMAP folder.

I am trying to copy all the emails from one Local Folder to an IMAP folder. In the Local Folder, there are 4430 emails. However, when I copy all them to the IMAP folder, I end up with 4424. I can't understand why. Anyone have an idea? Thanks for your help. See attached screenshots. First one is of Local Folders, second one is of IMAP folder.
Attached screenshots

Chosen solution

Right click, select properties and then repair. I would say the index is just not quite right.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36

More Information

Matt
  • Top 10 Contributor
  • Moderator
3213 solutions 21974 answers

Chosen Solution

Right click, select properties and then repair. I would say the index is just not quite right.

Right click, select properties and then repair. I would say the index is just not quite right.

Question owner

Tried that but no joy.  :-(

Thanks for the idea, though. Got any other?

Tried that but no joy. :-( Thanks for the idea, though. Got any other?
Matt
  • Top 10 Contributor
  • Moderator
3213 solutions 21974 answers

No idea, could be that the mail is not fully formed for some reason and therefore just does not copy. I have seen all sorts of weirdness caused by anti virus programs "scanning" while copy occurs.

We recommend here that you create an exception in your anti virus scanner for the Thunderbird profile folder and it's sub folders. That is not to say you can not scan them when you close Thunderbird, just that Thunderbird does not take well to having files locked when it is trying to use them. Interestingly you will find anti virus programs do not scan PST files in outlook, just mail files in Thunderbird. I find that interesting because Thunderbird stores mail completely inertly as text files and never executed scripts in the mail. Outlook stores attachments as complete binary files and can be convinced to run scripts in email bodies. Go figure.

No idea, could be that the mail is not fully formed for some reason and therefore just does not copy. I have seen all sorts of weirdness caused by anti virus programs "scanning" while copy occurs. We recommend here that you create an exception in your anti virus scanner for the Thunderbird profile folder and it's sub folders. That is not to say you can not scan them when you close Thunderbird, just that Thunderbird does not take well to having files locked when it is trying to use them. Interestingly you will find anti virus programs do not scan PST files in outlook, just mail files in Thunderbird. I find that interesting because Thunderbird stores mail completely inertly as text files and never executed scripts in the mail. Outlook stores attachments as complete binary files and can be convinced to run scripts in email bodies. Go figure.

Question owner

Thanks for that idea, Matt. I have "Windows Defender" (who knew?) and I can create an exception by specifying the type of file. See attached screenshot. Would I use *.eml? Anything else I need to add?

Thanks for that idea, Matt. I have "Windows Defender" (who knew?) and I can create an exception by specifying the type of file. See attached screenshot. Would I use *.eml? Anything else I need to add?
Matt
  • Top 10 Contributor
  • Moderator
3213 solutions 21974 answers

Helpful Reply

Thunderbird does not put a file extension on mail files. They have no "type" according to windows because of that.

Thunderbird does not put a file extension on mail files. They have no "type" according to windows because of that.
sfhowes
  • Top 10 Contributor
1438 solutions 6814 answers

Helpful Reply

Click 'Excluded files and folders' in Options in your picture, and add the TB profile folder, which is located at:

C:\Users\Windows user name\AppData\Roaming\Thunderbird\Profiles\8charstring.default

Add the Profiles folder if you have multiple profiles.

Click 'Excluded files and folders' in Options in your picture, and add the TB profile folder, which is located at: C:\Users\''Windows user name''\AppData\Roaming\Thunderbird\Profiles\''8charstring.default'' Add the Profiles folder if you have multiple profiles.