Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Using message filter to move email to local folder doesn't delete from server

  • 2 replies
  • 1 has this problem
  • 26 views
  • Last reply by nsolot

more options

Every month or so, I try to move emails to a local folder using message filter. I'm using a few GMail accounts with TB. The filter does move the emails from my GMail inbox to the local folder, but doesn't delete them from the GMail server, so the next time I reboot and start TB, it re-synchs to the GMail server and downloads the emails again. The only solution I have come up with is to open GMail via browser and delete the emails in that manner.

Is there a way to move emails from GMail inbox to local folder AND delete them from Gmail server so they don't download again? TIA

Chosen solution

Perhaps try copy and delete, that is what happens in the background on a lot of IMAP servers anyway.

Gmail is however an odd fish, their IMAP is not really IMAP, they even call it GIMAP because they have no intention of making it IMAP. So what works and does not work is really anyone's guess until you try it. GMail only has one copy of mail, in the all mail folder. anything else is an illusion created by adding tags with folder names to the original mail. It is for this reason I suggest you try the copy delete instead. Perhaps that will work better with the GIMAP.

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

Perhaps try copy and delete, that is what happens in the background on a lot of IMAP servers anyway.

Gmail is however an odd fish, their IMAP is not really IMAP, they even call it GIMAP because they have no intention of making it IMAP. So what works and does not work is really anyone's guess until you try it. GMail only has one copy of mail, in the all mail folder. anything else is an illusion created by adding tags with folder names to the original mail. It is for this reason I suggest you try the copy delete instead. Perhaps that will work better with the GIMAP.

more options

Thanks! That seems to work well. Appreciate the help