X
Tap here to go to the mobile version of the site.

Support Forum

How Do I Get "WebGL2" To Work With FF v52.9.0 ESR on XP?

Posted

Windows XP FF v52.9.0 ESR Display Card EVGA GeForce GT240 512MB GDDR5 nVidia GeForce Driver v340.52

config:suport shows

WebGL Render: Working OK

WebGL2 Render: WebGL creation failed: * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Exhausted GL driver caps.

I've searched can't find anything helpful

Windows 7 running on the same hardware in a separate partition renders WebGL 1 & 2 OK. FF v56.0.2 nVidia GeForce Driver v341.95

Windows XP FF v52.9.0 ESR Display Card EVGA GeForce GT240 512MB GDDR5 nVidia GeForce Driver v340.52 config:suport shows WebGL Render: Working OK WebGL2 Render: WebGL creation failed: * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Exhausted GL driver caps. I've searched can't find anything helpful Windows 7 running on the same hardware in a separate partition renders WebGL 1 & 2 OK. FF v56.0.2 nVidia GeForce Driver v341.95

Chosen solution

This seems to be working:

In about.config

Webgl.disable-angle False (default) --> True

Webgl.force-enabled False (default) --> True

about.support now indicates both Webgl1 and Webgl2 are working. Also verified on Webgl2 test pages.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Shockwave Flash 32.0 r0
  • VLC media player Web Plugin
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

Chosen Solution

This seems to be working:

In about.config

Webgl.disable-angle False (default) --> True

Webgl.force-enabled False (default) --> True

about.support now indicates both Webgl1 and Webgl2 are working. Also verified on Webgl2 test pages.

This seems to be working: In about.config Webgl.disable-angle False (default) --> True Webgl.force-enabled False (default) --> True about.support now indicates both Webgl1 and Webgl2 are working. Also verified on Webgl2 test pages.