X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

News sites say I am ad-blocking, and want to charge me a paywall unless I remove it. I have tried to follow their instructions and can't get it done.

Posted

For instance this morning, National Post says I've looked at one free page with ad-blocking, and I'll be limited unless I subscribe or disable ad-blocking. I would disable ad-blocking but I have been unable to figure out how to do it, even following their instructions. Their instructions (which are typical of sites who give this notification) are:

"If you are using Firefox Private Browsing with Tracking Protection, a shield icon is displayed to the left of the Firefox address bar. Tracking Protection blocks ads from being displayed.

   1. Click the shield icon to the left of the address bar.
   2. Select Disable protection for this session.
   3. Click Done below to close this window and refresh the page. "

When I go to Firefox, I don't find what they're talking about. I did find the shield, but I didn't see Disable protection. Under Options/Browser Privacy, I see Content Blocking, but that only addresses Trackers and Third-party Cookies. Under Permissions, I have Block Pop-Up Windows selected, and wonder if that's what I need to disable. Under Security, there are three categories, none of which seem wise to disable. I just don't see options that match the instructions. And I don't see a "refresh" button for saving my changes. How do I get this done? Thanks.

For instance this morning, National Post says I've looked at one free page with ad-blocking, and I'll be limited unless I subscribe or disable ad-blocking. I would disable ad-blocking but I have been unable to figure out how to do it, even following their instructions. Their instructions (which are typical of sites who give this notification) are: "If you are using Firefox Private Browsing with Tracking Protection, a shield icon is displayed to the left of the Firefox address bar. Tracking Protection blocks ads from being displayed. 1. Click the shield icon to the left of the address bar. 2. Select Disable protection for this session. 3. Click Done below to close this window and refresh the page. " When I go to Firefox, I don't find what they're talking about. I did find the shield, but I didn't see Disable protection. Under Options/Browser Privacy, I see Content Blocking, but that only addresses Trackers and Third-party Cookies. Under Permissions, I have Block Pop-Up Windows selected, and wonder if that's what I need to disable. Under Security, there are three categories, none of which seem wise to disable. I just don't see options that match the instructions. And I don't see a "refresh" button for saving my changes. How do I get this done? Thanks.

Chosen solution

In the screenshot below : if that is what you are seeing - you can either click on the yellow 'Allow ads' button or the closing X ......

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

McCoy
  • Top 10 Contributor
397 solutions 3486 answers

Hello KingAlexander,

You say that you do see that shield icon - when you click on it
you will get a dropdown, and there you should see :

"Disable Blocking For This Site " .......

Hello KingAlexander, You say that you do see that shield icon - when you click on it <BR>you will get a dropdown, and there you should see : "''Disable Blocking For This Site'' " .......
Was this helpful to you?
Quote
WestEnd
  • Top 10 Contributor
59 solutions 5129 answers

If not addons then your security software is doing the blocking then. There is more than one way it can happen.

If not addons then your security software is doing the blocking then. There is more than one way it can happen.
Was this helpful to you? 0
Quote

Question owner

The only shield-like thing I see when looking at the site is the "pocket" icon. I saw the shield when I opened Firefox in a separate tab for settings. I don't know what just happened, but now I'm seeing the article without the message-- I'm still not seeing any ads, just white on both sides. The message comes frequently with various different sites, and I would like to support news sources, preferably by allowing their ads if I can rather than by subscribing. Thank you for responding. I'll continue trying to figure it out when it happens again, which I trust it will.

The only shield-like thing I see when looking at the site is the "pocket" icon. I saw the shield when I opened Firefox in a separate tab for settings. I don't know what just happened, but now I'm seeing the article without the message-- I'm still not seeing any ads, just white on both sides. The message comes frequently with various different sites, and I would like to support news sources, preferably by allowing their ads if I can rather than by subscribing. Thank you for responding. I'll continue trying to figure it out when it happens again, which I trust it will.
Was this helpful to you?
Quote
WestEnd
  • Top 10 Contributor
59 solutions 5129 answers

So what is the actual link that your using then?

So what is the actual link that your using then?
Was this helpful to you?
Quote

Question owner

This: about:preferences#privacy -- found in the drop-down menu at the top right of my screen in the icon that is a stack of four horizontal lines. When I click there I see as the second item the proper shield with "Content Blocking" out to the right.

This: about:preferences#privacy -- found in the drop-down menu at the top right of my screen in the icon that is a stack of four horizontal lines. When I click there I see as the second item the proper shield with "Content Blocking" out to the right.
Was this helpful to you?
Quote

Question owner

I should add that I am the rankest sort of button-pusher, but you probably already gathered that.

I should add that I am the rankest sort of button-pusher, but you probably already gathered that.
Was this helpful to you?
Quote
WestEnd
  • Top 10 Contributor
59 solutions 5129 answers

If you can't provide the link to the site news that is giving you that error this makes it even harder for others to see what is going on.

If you can't provide the link to the site news that is giving you that error this makes it even harder for others to see what is going on.
Was this helpful to you?
Quote

Question owner

The link to the news site? It was this one: https://nationalpost.com/ But the same things happens with any number of them: New York Times, Washington Post, Wall Street Journal, Daily Caller, to name a few. It's always the same thing: "We see you're blocking ads." They ask me to allow ads to support their efforts. Some will charge if I don't, others not, but all prefer I allow the ads, and I don't mind. Then they walk me through the supposed steps to allow the ads, referring first to a red stop sign logo, but that doesn't apply to Firefox. With Firefox, they refer me to the shield. And finding that, I still don't see how to unblock ads, and frankly I don't recall ever selecting ad-blocking in the first place. Thanks for your efforts to help me with this.

The link to the news site? It was this one: https://nationalpost.com/ But the same things happens with any number of them: New York Times, Washington Post, Wall Street Journal, Daily Caller, to name a few. It's always the same thing: "We see you're blocking ads." They ask me to allow ads to support their efforts. Some will charge if I don't, others not, but all prefer I allow the ads, and I don't mind. Then they walk me through the supposed steps to allow the ads, referring first to a red stop sign logo, but that doesn't apply to Firefox. With Firefox, they refer me to the shield. And finding that, I still don't see how to unblock ads, and frankly I don't recall ever selecting ad-blocking in the first place. Thanks for your efforts to help me with this.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
397 solutions 3486 answers

McCoy said

You say that you do see that shield icon - when you click on it
you will get a dropdown, and there you should see : "Disable Blocking For This Site " .......

Dear KingAlexander, I know that it's a lot to take in and quite confusing, but would you please click on that "Disable Blocking For This Site"  ?

Maybe this article will explain why :

https://support.mozilla.org/en-US/kb/what-happened-tracking-protection?redirectlocale=en-US&redirectslug=tracking-protection

''McCoy [[#answer-1188086|said]]'' <blockquote> You say that you do see that shield icon - when you click on it <BR>you will get a dropdown, and there you should see : "''Disable Blocking For This Site'' " ....... </blockquote> Dear KingAlexander, I know that it's a lot to take in and quite confusing, but would you please click on that "Disable Blocking For This Site" ? Maybe this article will explain why : https://support.mozilla.org/en-US/kb/what-happened-tracking-protection?redirectlocale=en-US&redirectslug=tracking-protection
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
397 solutions 3486 answers

Chosen Solution

In the screenshot below : if that is what you are seeing - you can either click on the yellow 'Allow ads' button or the closing X ......

In the screenshot below : if that is what you are seeing - you can either click on the yellow 'Allow ads' button or the closing '''X''' ......
Was this helpful to you? 1
Quote

Question owner

When I click on that, it isn't automatic. It gives me another window with instructions to find and click the red octagon which is the Adblock Plus icon. I don't see that anywhere. It says if I don't see that, click this other link that says _Don't see the red octagon?_ When I click that it gives me a drop-down menu titled _Which of these are you using?_ There I have selected Firefox Private Browsing (icon: purple square containing white cat-eye face mask) not that I really know that I'm using that specifically, I just know that I'm using Mozilla Firefox browser. That says this: If you are using Firefox Private Browsing with Tracking Protection, a shield icon is displayed to the left of the Firefox address bar. Tracking Protection blocks ads from being displayed.

   Click the shield icon to the left of the address bar.
   Select Disable protection for this session.
   Click Done below to close this window and refresh the page.

I get to the shield icon labeled "Content Blocking" from the top right menu (four horizontal lines). When I open that, I am presented with a lot of choices for different things, but I don't see an option that says "Disable protection for this session." I've done trial and error on different things, unsuccessfully so far.

When I click on that, it isn't automatic. It gives me another window with instructions to find and click the red octagon which is the Adblock Plus icon. I don't see that anywhere. It says if I don't see that, click this other link that says _Don't see the red octagon?_ When I click that it gives me a drop-down menu titled _Which of these are you using?_ There I have selected Firefox Private Browsing (icon: purple square containing white cat-eye face mask) not that I really know that I'm using that specifically, I just know that I'm using Mozilla Firefox browser. That says this: If you are using Firefox Private Browsing with Tracking Protection, a shield icon is displayed to the left of the Firefox address bar. Tracking Protection blocks ads from being displayed. Click the shield icon to the left of the address bar. Select Disable protection for this session. Click Done below to close this window and refresh the page. I get to the shield icon labeled "Content Blocking" from the top right menu (four horizontal lines). When I open that, I am presented with a lot of choices for different things, but I don't see an option that says "Disable protection for this session." I've done trial and error on different things, unsuccessfully so far.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
397 solutions 3486 answers

Yes, I get those same instructions - but you can just ignore them and follow my advice .....

Yes, I get those same instructions - but you can just ignore them and follow my advice .....
Was this helpful to you?
Quote

Question owner

Right, I can get past their message. I was trying to accommodate their wishes rather than just continue to freeload, but at this point I feel like I've made more than an honest effort. Thanks again.

Right, I can get past their message. I was trying to accommodate their wishes rather than just continue to freeload, but at this point I feel like I've made more than an honest effort. Thanks again.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.