Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox blocking connection to trusted private network site

  • 5 replies
  • 1 has this problem
  • 42 views
  • Last reply by jscher2000

more options

There is a private network at work, and the security certifcates aren't actively managed (computing cluster, maintenance network access on the compute nodes). Earlier versions of Firefox used to allow me to accept the risk for going forward with the connection, but the latest version is not currently allowing me to do that.

This is a Fedora linux system, current version Fedora 29. Thank you.

All Replies (5)

more options

What is the exact error messages?

more options

From the browser window:


Secure Connection Failed

An error occurred during a connection to 192.168.176.210. You have received an invalid certificate.


There is more output. I understand in principle why the browser is not connecting. I want to proceed anyway. How do I get the browser to accept my direction?

more options
more options

What I am reporting is that under Fedora 29, FF does not present the 'Advanced' button to allow end-user to choose to proceed. Please see attached image.

Latest FF on Win10 does provide this functionality, and it is accessible. Under Fedora 29, I'm sure the functionality is there, and yet in the http page rendering, no option is visible to engage with the advanced options and move to the site.

Cheers, ~ Em

more options

Hi emdrago, there are two different pages. The "Secure Connection Failed" page doesn't allow exceptions, only the "Your connection is not secure" page.

With the "re-used serial" error, the most common explanation is that you saved an exception before with the same serial number but something doesn't match, so Firefox stops trying to connect.

Try removing previously saved exceptions generated by the same server or device here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type cert and Firefox should filter to the "View Certificates" button, which you can click.

Most likely the exception with the duplicate serial number will be on the Servers tab. Look for ones you've added; ignore the ones that list * as the server, which are global distrust entries added by Firefox.

By analogy, here's a Dell support page: https://www.dell.com/support/article/us/en/04/sln118879/drac-sec_error_reused_issuer_and_serial-error-when-connecting-to-idrac6-with-firefox?lang=en