X
Tap here to go to the mobile version of the site.

Support Forum

I can no longer get my favorites toolbar at the top of the screen, it will come up as a sidebar but not at the top.

Posted

When I first open Firefox I see the bookmarks bar at the top like it is supposed to be, but by the time it's fully opened the bookmarks are no longer at the top. I've tried closing and restarting Firefox, rebooting the computer and "Hiding and viewing" the bookmarks bar but can get it back on top. I am however able to open the bookmarks in the sidebar.

When I first open Firefox I see the bookmarks bar at the top like it is supposed to be, but by the time it's fully opened the bookmarks are no longer at the top. I've tried closing and restarting Firefox, rebooting the computer and "Hiding and viewing" the bookmarks bar but can get it back on top. I am however able to open the bookmarks in the sidebar.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

hellosct1 15 solutions 149 answers

Helpful Reply

Hi,

I share the link of the documentation that will help you get your bar back permanently

https://support.mozilla.org/en-US/kb/bookmarks-toolbar-display-favorite-websites

best regard

Hi, I share the link of the documentation that will help you get your bar back permanently https://support.mozilla.org/en-US/kb/bookmarks-toolbar-display-favorite-websites best regard
jscher2000
  • Top 10 Contributor
8772 solutions 71718 answers

Hi DavidK., the problem of the "vanishing Bookmarks Toolbar" has been occurring out of the blue for some users for the past few versions. It seems to be linked to the session restore feature.

I realize the following is an elaborate version of the cliché “turn it off and on again” but it is the simplest known remedy at this time.

(A) Complete any work in private windows because we're going to exit Firefox

(B) Open the Options page --

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

-- and uncheck the box for "Restore previous session"

(C) Exit Firefox using the menu command, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

(D) Start Firefox

At this point, the Bookmarks Toolbar should be displayed and not vanishing

(E) Restore your previous session manually, either:

  • "3-bar" menu button > Restore Previous Session
  • (menu bar) History > Restore Previous Session

(F) If the Options page doesn't come back, re-open the Options page

(G) Turn "Restore previous session" back on

Hi DavidK., the problem of the "vanishing Bookmarks Toolbar" has been occurring out of the blue for some users for the past few versions. It seems to be linked to the session restore feature. ''I realize the following is an elaborate version of the cliché “turn it off and on again” but it is the simplest known remedy at this time.'' (A) Complete any work in private windows because we're going to exit Firefox (B) Open the Options page -- * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it -- and uncheck the box for "Restore previous session" (C) Exit Firefox using the menu command, either: * "3-bar" menu button > Exit * (menu bar) File > Exit (D) Start Firefox '''At this point, the Bookmarks Toolbar should be displayed and not vanishing''' (E) Restore your previous session manually, either: * "3-bar" menu button > Restore Previous Session * (menu bar) History > Restore Previous Session (F) If the Options page doesn't come back, re-open the Options page (G) Turn "Restore previous session" back on