X
Tap here to go to the mobile version of the site.

Support Forum

Tools>Options missing, trying to change read/unread delay settings - solution

Posted

FYI - I've been using T=Bird for years so not a noob. Developers: This is an important security feature and should be repaired.

Just "upgraded" to 18.04 Xubuntu 32-bit which includes T-bird 60.2 and experienced the following. (no add-ons) New messages were being marked "read" immediately when moused over or selected, no delay. Not usually a problem because there was a settings in Tools>Options>Display... The problem is that with 60.2 this Tools feature is gone (on my install) and there is no access to the unread/read delay setting. I solved the problem by going into the flags ("Here be Dragons", accessed via Preferences>Advanced > Config Editor) Warning! Do not use the config editor unless you are confident you won't damage anything. Open Config Editor> Search: "message_read" no quotes You should see the three results / flags below. To enable delay change "read.delay;false" to true. This is done by either a double click or right click > select Toggle. After you change it it will be bold, that's normal. It's just to let you know it was modified. Leave the other two as is unless you want more or less of a delay then change the number at "delay.interval" mine was 5 so it's fine. Leave "read.auto" set to true. Close the editor and it's done.

(this is how it looks when delay is disabled) mailnews.mark_message_read.auto;true mailnews.mark_message_read.delay;false mailnews.mark_message_read.delay.interval;5

(this is delay enabled) mailnews.mark_message_read.auto;true mailnews.mark_message_read.delay;true mailnews.mark_message_read.delay.interval;5

That's it. Your messages will now change from unread to read in 5 seconds not instantly. If you have the Tools>Options on your system by all means avoid the Config Editor but since it's missing on mine it's probably missing on others' as well. I searched for a solution before posting this and didn't find it so hope this is helpful to someone.

FYI - I've been using T=Bird for years so not a noob. Developers: This is an important security feature and should be repaired. Just "upgraded" to 18.04 Xubuntu 32-bit which includes T-bird 60.2 and experienced the following. (no add-ons) New messages were being marked "read" immediately when moused over or selected, no delay. Not usually a problem because there was a settings in Tools>Options>Display... The problem is that with 60.2 this Tools feature is gone (on my install) and there is no access to the unread/read delay setting. I solved the problem by going into the flags ("Here be Dragons", accessed via Preferences>Advanced > Config Editor) Warning! Do not use the config editor unless you are confident you won't damage anything. Open Config Editor> Search: "message_read" no quotes You should see the three results / flags below. To enable delay change "read.delay;false" to true. This is done by either a double click or right click > select Toggle. After you change it it will be bold, that's normal. It's just to let you know it was modified. Leave the other two as is unless you want more or less of a delay then change the number at "delay.interval" mine was 5 so it's fine. Leave "read.auto" set to true. Close the editor and it's done. (this is how it looks when delay is disabled) mailnews.mark_message_read.auto;true mailnews.mark_message_read.delay;false mailnews.mark_message_read.delay.interval;5 (this is delay enabled) mailnews.mark_message_read.auto;true mailnews.mark_message_read.delay;true mailnews.mark_message_read.delay.interval;5 That's it. Your messages will now change from unread to read in 5 seconds not instantly. If you have the Tools>Options on your system by all means avoid the Config Editor but since it's missing on mine it's probably missing on others' as well. I searched for a solution before posting this and didn't find it so hope this is helpful to someone.

Modified by Tony_MarsNow

Chosen solution

I would have thought the Display options were under Edit/Preferences on your system, but if you manage to access that window, do you see Formatting Tags Advanced look like a single tab rather than 3 separate tabs? This is a problem with some Linux setups, but you can still switch tabs by clicking on the tab title.

https://support.mozilla.org/en-US/questions/1224215

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/70.0.3538.77 Chrome/70.0.3538.77 Safari/537.36

More Information

sfhowes
  • Top 10 Contributor
1438 solutions 6818 answers

Chosen Solution

I would have thought the Display options were under Edit/Preferences on your system, but if you manage to access that window, do you see Formatting Tags Advanced look like a single tab rather than 3 separate tabs? This is a problem with some Linux setups, but you can still switch tabs by clicking on the tab title.

https://support.mozilla.org/en-US/questions/1224215

I would have thought the Display options were under Edit/Preferences on your system, but if you manage to access that window, do you see Formatting Tags Advanced look like a single tab rather than 3 separate tabs? This is a problem with some Linux setups, but you can still switch tabs by clicking on the tab title. https://support.mozilla.org/en-US/questions/1224215

Question owner

Hi Sf, lol, I see the problem now. For some reason the tabs aren't rendering just the labels and to be honest i didn't realize they were tabs. They do work though. Before I posted I searched and the link you sent didn't come up. So to sum up, access to the settings is there in the advanced panel but the tabs don't show up just the labels. Thanks!!

Hi Sf, lol, I see the problem now. For some reason the tabs aren't rendering just the labels and to be honest i didn't realize they were tabs. They do work though. Before I posted I searched and the link you sent didn't come up. So to sum up, access to the settings is there in the advanced panel but the tabs don't show up just the labels. Thanks!!