Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I control the archiving locations for local folders?

  • 1 reply
  • 1 has this problem
  • 28 views
  • Last reply by davidec

more options

The question I have is:

  • Where do I control the location of the archived emails within "Local Folders"?

Specifically, this question is motivated by the following, strange behavior:

  • I have one very large folder of email in "Local Folders". Until now, when I selected emails to "Archive" (keyboard "A") they would end up in a subfolder of "Local Folders/Archives", e.g. "Local Folders/Archives/2017".
  • Now, however, when I click "A" those emails are moved back to the Archives folder of my IMAP account, not my Local Folder.
  • I know that I can select the location of archived emails for my IMAP folder by going to "Tools > Account Settings > [MyIMAPaccount] > Copies & Folders" and there under "Message Archives".
  • There, for "[MyIMAPaccount]", I have already selected "Keep message archives in: > "'Archives' Folder on Local Folders".
  • But there is not such an option to select where to archive messages for "Local Folders" (there is no sub-bullet "Copies & Folders" under "Local Folders" account settings).
  • So it's even more bizarre that, when I archive something from within "Local Folders", they end up back in my IMAP account. (And strangely, this was not the case until a couple of days ago).
  • adding to this strange behavior, when I copy emails from "[MyIMAPaccount]/Archives/YYYY" back to "Local Folders/Archives/YYYY", they suddenly appear twice in "Local Folders/Archives/YYYY" (every email appears twice).
The question I have is: * Where do I control the location of the archived emails within "Local Folders"? Specifically, this question is motivated by the following, strange behavior: * I have one very large folder of email in "Local Folders". Until now, when I selected emails to "Archive" (keyboard "A") they would end up in a subfolder of "Local Folders/Archives", e.g. "Local Folders/Archives/2017". * Now, however, when I click "A" those emails are moved back to the Archives folder of my IMAP account, not my Local Folder. * I know that I can select the location of archived emails for my IMAP folder by going to "Tools > Account Settings > [MyIMAPaccount] > Copies & Folders" and there under "Message Archives". * There, for "[MyIMAPaccount]", I have already selected "Keep message archives in: > "'Archives' Folder on Local Folders". * But there is not such an option to select where to archive messages for "Local Folders" (there is no sub-bullet "Copies & Folders" under "Local Folders" account settings). * So it's even more bizarre that, when I archive something from within "Local Folders", they end up back in my IMAP account. (And strangely, this was not the case until a couple of days ago). * adding to this strange behavior, when I copy emails from "[MyIMAPaccount]/Archives/YYYY" back to "Local Folders/Archives/YYYY", they suddenly appear twice in "Local Folders/Archives/YYYY" (every email appears twice).

All Replies (1)

more options

Updates to this question – still unresolved:

1) I have rebuilt the global database, to no avail.

2) More importantly, I have tried to better understand the behavior of Thunderbird, and understand in which cases

  • a message is moved to the IMAP's "Archive" folder
  • and when a message is moved to the Local Folder's "Archive".

In short: I do not understand it. A rather general pattern seems that when I select only one message and press "A", then it ends up in the Local Folder's "Archive", whereas if I select several messages, they end up in the IMAP's "Archive". But even this pattern is not very consistent.

One last note: My IMAP server is an Exchange server. In case that's of any relevance here.