Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I permanently disable the Scratchpad?

  • 5 replies
  • 1 has this problem
  • 327 views
  • Last reply by McCoy

more options

I never use Scratchpad or any other Java features. When typing a message every time I hit shift for a capital the Scratchpad appears. Then I have to hit Control W every time I type a capital to get rid of the Scratchpad. I just want to disable this feature once and for all. Simple step by step guide please. Many thanks.

Chosen solution

After re-booting and testing the problem seems to have gone away. I will remember the F4 possibility for the future. I very rarely use the F keys on my computer. Many thanks and best regards, Pigface

Read this answer in context 👍 0

All Replies (5)

more options

Hello pigface,

Would you do this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar : devtools.scratchpad.

and look for the preference devtools.scratchpad.enabled

Make sure its value is set to false

If you had to change the value, then close and restart Firefox.

Does that help  ?

Modified by McCoy

more options

Many thanks McCoy. I have done exactly as you indicated. To my surprise the devtools.scratchpad.enabled was already set to false ! I will now restart my computer and hope the problem is solved. Many thanks for your very fast response. I will keep it for future reference. Pigface

more options

If the value was already set to false, then nothing has changed  :(

If that scratchpad still comes up every time you press Shift, then maybe your F4 key is stuck - would you press it a few times to see if that will help  ?

more options

Chosen Solution

After re-booting and testing the problem seems to have gone away. I will remember the F4 possibility for the future. I very rarely use the F keys on my computer. Many thanks and best regards, Pigface

more options

I'm glad that the problem is solved - well done  !

Wishing you all the best  !