X
Tap here to go to the mobile version of the site.

Support Forum

Videos autoplaying even with all the new settings

Posted

Until today the options for stopping videos auto playing worked OK, suddenly they don't work at all. I had changed all the settings in about:config - please see screen shot attached - a couple of weeks ago when they suddenly started auto playing and that solved the issue, but now I am back to square one. Even when I have ensured that the autoplay option is changed in the preferences section they are still auto-playing. Any suggestions please as this is driving me crazy!

Thanks in advance for your help. It is much appreciated.

Until today the options for stopping videos auto playing worked OK, suddenly they don't work at all. I had changed all the settings in about:config - please see screen shot attached - a couple of weeks ago when they suddenly started auto playing and that solved the issue, but now I am back to square one. Even when I have ensured that the autoplay option is changed in the preferences section they are still auto-playing. Any suggestions please as this is driving me crazy! Thanks in advance for your help. It is much appreciated.
Attached screenshots

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • Firefox 63.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:63.0) Gecko/20100101 Firefox/63.0
  • Support URL: https://support.mozilla.org/1/firefox/63.0.1/Darwin/en-US/

Extensions

  • Adblock Plus 3.3.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • New Tab Tools 89.1 (newtabtools@darktrojan.net)
  • Video DownloadHelper 7.3.5 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • IBM Security Rapport 2.1.24 (rapportext@trusteer.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x0a2e
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • contentUsesTiling: True
  • crashGuards: []
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'opt-in', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • info: {u'TileHeight': 512, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'TileWidth': 512, u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 3
  • usesTiling: True
  • webgl1DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: Intel Inc. -- Intel Iris OpenGL Engine
  • webgl1Version: 4.1 INTEL-10.6.33
  • webgl1WSIInfo: CGL
  • webgl2DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
  • webgl2Renderer: Intel Inc. -- Intel Iris OpenGL Engine
  • webgl2Version: 4.1 INTEL-10.6.33
  • webgl2WSIInfo: CGL
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
McCoy
  • Top 10 Contributor
489 solutions 4500 answers

Hello KezzerN,

This must be pretty annoying ....

The only pref on the "about:config" page that you might want to toggle, is :

"media.autoplay.allow-muted" = false

But there is this add-on (even though I don't think that you should need to use an add-on) :

https://addons.mozilla.org/en-US/firefox/addon/disable-autoplay/

'Can't think of anything else that might do the trick (sorry ....), but maybe someone else does.

Hello KezzerN, This must be pretty annoying .... The only pref on the "about:config" page that you might want to toggle, is : "media.autoplay.allow-muted" = false But there is this add-on (even though I don't think that you should need to use an add-on) : https://addons.mozilla.org/en-US/firefox/addon/disable-autoplay/ 'Can't think of anything else that might do the trick (sorry ....), but maybe someone else does.

Question owner

Many thanks for your speedy help. I have just changed the setting you suggest, but that has made no difference. I had earlier tried the add-on after seeing it mentioned in another thread, but that also doesn't stop the issue. It is so strange as everything was working fine last night and now it suddenly isn't.

Many thanks for your speedy help. I have just changed the setting you suggest, but that has made no difference. I had earlier tried the add-on after seeing it mentioned in another thread, but that also doesn't stop the issue. It is so strange as everything was working fine last night and now it suddenly isn't.

Question owner

As you can see from this attachment it should be blocked.

As you can see from this attachment it should be blocked.
McCoy
  • Top 10 Contributor
489 solutions 4500 answers

KezzerN said

As you can see from this attachment it should be blocked.

If you hadn't attached that screenshot, I would have asked you if you had closed and restarted Firefox after changing prefs on the about:config page (even though that seemed like a rhetorical question to me).

But if even that extension doesn't work, I must admit that I'm baffled.

Stab in the dark, but the only thing that I can think of now is to ask you to go over this article :

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

(keeping my fingers crossed ..... )

''KezzerN [[#answer-1170883|said]]'' <blockquote> As you can see from this attachment it should be blocked. </blockquote> If you hadn't attached that screenshot, I would have asked you if you had closed and restarted Firefox after changing prefs on the about:config page (even though that seemed like a rhetorical question to me). But if even that extension doesn't work, I must admit that I'm baffled. Stab in the dark, but the only thing that I can think of now is to ask you to go over this article : https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save (keeping my fingers crossed ..... )

Question owner

Thank you I shall try the link. And yes I did try closing Firefox down: I always try that one first with any problem with my computer as I find it can often fix the glitch.

Thank you I shall try the link. And yes I did try closing Firefox down: I always try that one first with any problem with my computer as I find it can often fix the glitch.

Question owner

Before I try the options in the link just suggested (they make me feel like banging my head on the desk!), the only thing I did differently yesterday was to set up a second screen. That was literally just plugging it in on mini mac and switching it on. That wouldn't affect Firefox would it?

Thanks for all your help. Where would people like me be without you!

Before I try the options in the link just suggested (they make me feel like banging my head on the desk!), the only thing I did differently yesterday was to set up a second screen. That was literally just plugging it in on mini mac and switching it on. That wouldn't affect Firefox would it? Thanks for all your help. Where would people like me be without you!
McCoy
  • Top 10 Contributor
489 solutions 4500 answers

KezzerN said

Before I try the options in the link just suggested (they make me feel like banging my head on the desk!),

I don't blame you  ! And quite frankly : I have my doubts about it changing anything, because of the fact that the extension doesn't work either.

the only thing I did differently yesterday was to set up a second screen. That was literally just plugging it in on mini mac and switching it on. That wouldn't affect Firefox would it?

I'm not going to lie to you : I have no idea ....

But I am going to ask for help - we're dealing with different time zones, so you may have to wait a few hours ......

Thanks for all your help. Where would people like me be without you!

Aww, I haven't been of any help though (so sorry .... )

''KezzerN [[#answer-1170904|said]]'' <blockquote> Before I try the options in the link just suggested (they make me feel like banging my head on the desk!), </blockquote> I don't blame you ! And quite frankly : I have my doubts about it changing anything, because of the fact that the extension doesn't work either. <blockquote> the only thing I did differently yesterday was to set up a second screen. That was literally just plugging it in on mini mac and switching it on. That wouldn't affect Firefox would it? </blockquote> I'm not going to lie to you : I have no idea .... But I am going to ask for help - we're dealing with different time zones, so you may have to wait a few hours ...... <blockquote> Thanks for all your help. Where would people like me be without you! </blockquote> Aww, I haven't been of any help though (so sorry .... )
jscher2000
  • Top 10 Contributor
8568 solutions 70080 answers

Autoplay is tricky because Firefox needs to determine whether the page started a video on its own or whether a user triggered the video starting. Some sites are fooling Firefox and it's helpful to get reports of those pages.


These are the current settings to manage media autoplaying:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

To set your preferred behavior:

Block autoplay by default

  • Double-click the media.autoplay.default preference and set it to 1
  • Some people suggest you also: Double-click the media.autoplay.allow-muted preference to switch the value from true to false

=> Does that work for you?

Ask on a site-by-site basis (default for "Nightly")

  • Double-click the media.autoplay.default preference and set it to 2
  • Double-click the media.autoplay.ask-permission preference to switch the value from false to true
  • Double-click the media.autoplay.enabled.user-gestures-needed preference to switch the value from false to true

Allow autoplay by default (default for Release)

  • Double-click the media.autoplay.default preference and set it to 0 (or right-click > Reset)

I'm sure we'll learn more about the interaction of these various preferences and what sites can bypass them as more users begin to run Firefox 63.

Autoplay is tricky because Firefox needs to determine whether the page started a video on its own or whether a user triggered the video starting. Some sites are fooling Firefox and it's helpful to get reports of those pages. ---- These are the current settings to manage media autoplaying: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''autop''' and pause while the list is filtered To set your preferred behavior: '''''Block autoplay by default''''' * Double-click the '''media.autoplay.default''' preference and set it to '''1''' * ''Some people suggest you also:'' Double-click the '''media.autoplay.allow-muted''' preference to switch the value from true to false => ''Does that work for you?'' '''''Ask on a site-by-site basis''''' (default for "Nightly") * Double-click the '''media.autoplay.default''' preference and set it to '''2''' * Double-click the '''media.autoplay.ask-permission''' preference to switch the value from false to true * Double-click the '''media.autoplay.enabled.user-gestures-needed''' preference to switch the value from false to true '''''Allow autoplay by default''''' (default for Release) * Double-click the '''media.autoplay.default''' preference and set it to '''0''' (or right-click > Reset) I'm sure we'll learn more about the interaction of these various preferences and what sites can bypass them as more users begin to run Firefox 63.

Question owner

Thanks for your input Jscher2000. I have those settings but the videos are still auto-playing. Even with auto-play switched off on youtube the videos are still playing.

Thanks for your input Jscher2000. I have those settings but the videos are still auto-playing. Even with auto-play switched off on youtube the videos are still playing.
jscher2000
  • Top 10 Contributor
8568 solutions 70080 answers

Hi KezzerN, thank you for mentioning YouTube. Those settings should work for YouTube; I tested on channel pages and individual video pages. Example screenshots attached. Is that where you are seeing the problem?

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi KezzerN, thank you for mentioning YouTube. Those settings should work for YouTube; I tested on channel pages and individual video pages. Example screenshots attached. Is that where you are seeing the problem? Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?

Question owner

Thanks again for the input. I tried in safe mode and still the same problem: videos automatically start playing. I have been trying various other pages on the web with videos and it seems that it is a youtube problem so perhaps they have changed a setting?

Thanks again for the input. I tried in safe mode and still the same problem: videos automatically start playing. I have been trying various other pages on the web with videos and it seems that it is a youtube problem so perhaps they have changed a setting?
McCoy
  • Top 10 Contributor
489 solutions 4500 answers

A mere stab in the dark, but would you give this a try :

When you're on YouTube, click on the 'i' in a circle, next to the padlock at the left side of the address bar. That will take you to "Page Info". Then click on the little black arrow on the dropdown and then on "More Information". Click on the 'Permissions" tab and scroll down to "Automatically Play Media with Sound". Uncheck "Use Default" and check "Block".

Then close and restart Firefox.

A mere stab in the dark, but would you give this a try : When you're on YouTube, click on the 'i' in a circle, next to the padlock at the left side of the address bar. That will take you to "Page Info". Then click on the little black arrow on the dropdown and then on "More Information". Click on the 'Permissions" tab and scroll down to "Automatically Play Media with Sound". Uncheck "Use Default" and check "Block". Then close and restart Firefox.

Question owner

I don't get the screen that you describe when I click on that 'i'. I have attached a screen shot of what I get. Though I had it blocked under permissions I also tried doing an exception and blocked it there as well. Oddly, on the one page it is blocked, but if I open up another page with youtube on it isn't blocked and starts to autoplay. Screenshots attached.

I don't get the screen that you describe when I click on that 'i'. I have attached a screen shot of what I get. Though I had it blocked under permissions I also tried doing an exception and blocked it there as well. Oddly, on the one page it is blocked, but if I open up another page with youtube on it isn't blocked and starts to autoplay. Screenshots attached.

Question owner

It has missed off one the screen shots the second youtube window where it isn't blocking, so that is now attached.

It has missed off one the screen shots the second youtube window where it isn't blocking, so that is now attached.
McCoy
  • Top 10 Contributor
489 solutions 4500 answers

KezzerN said

I don't get the screen that you describe when I click on that 'i'. I have attached a screen shot of what I get.

Your screenshot shows what you get after you've clicked on the little "i" in a circle .....

What you should do next : Then click on the little black arrow on the dropdown and then on "More Information". Click on the 'Permissions" tab and scroll down to "Automatically Play Media with Sound". Uncheck "Use Default" and check "Block".

Then close and restart Firefox.

''KezzerN [[#answer-1171022|said]]'' <blockquote> I don't get the screen that you describe when I click on that 'i'. I have attached a screen shot of what I get. </blockquote> Your screenshot shows what you get after you've clicked on the little "i" in a circle ..... What you should do next : Then click on the little black arrow on the dropdown and then on "More Information". Click on the 'Permissions" tab and scroll down to "Automatically Play Media with Sound". Uncheck "Use Default" and check "Block". Then close and restart Firefox.

Question owner

Thank you. I was being thick! Right I did what you suggested and though there the blocked option was showing a dot in it, the default was ticked. I unticked default, made sure blocked was ticked and restarted Firefox. It is a bit odd what is happening: if I right click on a video and open it in a new tab the auto-play works, but if I just open a new tab and go to youtube it doesn't work.

Thank you. I was being thick! Right I did what you suggested and though there the blocked option was showing a dot in it, the default was ticked. I unticked default, made sure blocked was ticked and restarted Firefox. It is a bit odd what is happening: if I right click on a video and open it in a new tab the auto-play works, but if I just open a new tab and go to youtube it doesn't work.

Question owner

That should saying blocking the auto-play works if I right click, but doesn't work if I open a new tab or window.

That should saying blocking the auto-play works if I right click, but doesn't work if I open a new tab or window.
McCoy
  • Top 10 Contributor
489 solutions 4500 answers

'Found this extension, especially for YouTube (earlier I thought that this was happening for you on all sites that have videos) :

https://addons.mozilla.org/en-US/firefox/addon/disable-autoplay-for-youtube/

What I don't understand : when I go to YouTube, I want to play videos - the video I want to play, doesn't start untill I click on it. To keep the next video from autoplaying, I have turned it off permanently by clicking on the blue "Autoplay" button, which is now greyed out ......

And somehow that doesn't work for you - videos start to play without you clicking on a video ...... Weird.

'Found this extension, especially for YouTube (earlier I thought that this was happening for you on all sites that have videos) : https://addons.mozilla.org/en-US/firefox/addon/disable-autoplay-for-youtube/ What I don't understand : when I go to YouTube, I want to play videos - the video I want to play, doesn't start untill I click on it. To keep the next video from autoplaying, I have turned it off permanently by clicking on the blue "Autoplay" button, which is now greyed out ...... And somehow that doesn't work for you - videos start to play without you clicking on a video ...... Weird.

Question owner

Yes I also have the autoplay greyed out and until today that always worked: a video didn't start until I clicked on it.

I have just downloaded the addon and bizarrely even that won't work! Very strange!

If I go on to the 'i' and go through the same procedure with each tab I open it will stop autoplay, but then with a new tab there is no effect.

Yes I also have the autoplay greyed out and until today that always worked: a video didn't start until I clicked on it. I have just downloaded the addon and bizarrely even that won't work! Very strange! If I go on to the 'i' and go through the same procedure with each tab I open it will stop autoplay, but then with a new tab there is no effect.
McCoy
  • Top 10 Contributor
489 solutions 4500 answers

KezzerN said

I have just downloaded the addon and bizarrely even that won't work! Very strange!

It's beginnig to sound like the script for a SciFi movie ......

I'm all out of ideas - 'wish I could have come up with a solution, but I hope that somebody else will.

''KezzerN [[#answer-1171040|said]]'' <blockquote> I have just downloaded the addon and bizarrely even that won't work! Very strange! </blockquote> It's beginnig to sound like the script for a SciFi movie ...... I'm all out of ideas - 'wish I could have come up with a solution, but I hope that somebody else will.