X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

remove "searchitnow"

Posted

Firefox browser has defaulted to "searchitnow" as the home page and default search engine, which was not wanted, appeared to come with a Java update, has also impacted Chrome. Help getting rid of it appreciated.

Firefox browser has defaulted to "searchitnow" as the home page and default search engine, which was not wanted, appeared to come with a Java update, has also impacted Chrome. Help getting rid of it appreciated.

Chosen solution

You may have ad/mal-ware. Further information can be found in this article; https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:61.0) Gecko/20100101 Firefox/61.0

More Information

FredMcD
  • Top 10 Contributor
4077 solutions 56898 answers

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; (<Control> [Mac=<Command>] <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove “ searchitnow “ Anything.

Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine

Now do the same in the computer’s Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the Applications folder. Linux: Check your user manual.

Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''(<Control> ''[Mac=<Command>]'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Remove “ searchitnow “ '''Anything. ''' Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine Now do the same in the computer’s '''Programs Folder. ''' '''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the '''Applications''' folder. '''Linux:''' Check your user manual.
jscher2000
  • Top 10 Contributor
8315 solutions 68040 answers

Once the rogue add-on(s) have been removed, you should be able to regain control of your search settings. For more on using that part of the Preferences page, see:

Change your default search settings in Firefox

Once the rogue add-on(s) have been removed, you should be able to regain control of your search settings. For more on using that part of the Preferences page, see: [[Change your default search settings in Firefox]]

Question owner

Hi Fred No sign of Searchitnow or anything that shouldn't be there in the addons. I've had a look through the programs and utilities as well and can't see anything odd there either.

Hi Fred No sign of Searchitnow or anything that shouldn't be there in the addons. I've had a look through the programs and utilities as well and can't see anything odd there either.
FredMcD
  • Top 10 Contributor
4077 solutions 56898 answers

Chosen Solution

You may have ad/mal-ware. Further information can be found in this article; https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

You may have ad/mal-ware. Further information can be found in this article; https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Question owner

Cool, ran malwarebytes scanner, followed instructions, have now reset preferences and all seems good, thanks for your help

Cool, ran malwarebytes scanner, followed instructions, have now reset preferences and all seems good, thanks for your help
FredMcD
  • Top 10 Contributor
4077 solutions 56898 answers

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.