Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problem with oauth2 in Thunderbird, go to Enter credential screen to get error message concerning javascript turned off

  • 8 replies
  • 3 have this problem
  • 857 views
  • Last reply by Matt

more options

My university turned on 2 factor authentication for gmail (optional now, but mandatory in January). I use Thunderbird to get my e-mail. When I turned oauth2 on in Thunderbird a box opens up for Enter credentials for me on imap.gmail.com but then it gives an error saying javascript is turned off in my browser but 1) I'm still in Thunderbird, and 2) my browser is running javascript (but the browser itself is not open). I changed my google account to give Thunderbird access to my gmail, and I enable the setting in google for less secure apps to access my account. I'm getting this error on my laptop at home but not on my computer at work. I reinstalled Thunderbird fresh at home and I still get this odd javascript message. Please help. I am using Windows 10 64 bit both at home and at work.

Chosen solution

use the Config Editor to change the setting javascript.enabled to true.

oAuth is a browser security thing. Because Yahoo and Google are forcing it down the throats of mail clients it is supported, but to work, thunderbird has to dust off it's browser roots in Firefox and work as a browser. Hence messages about a browser. At that point Thunderbird is a browser.

I assume some over zealous security has seen the JavaScript enabled setting turned off. IF not I am not sure why you ould see such an error.

Read this answer in context 👍 0

All Replies (8)

more options

Chosen Solution

use the Config Editor to change the setting javascript.enabled to true.

oAuth is a browser security thing. Because Yahoo and Google are forcing it down the throats of mail clients it is supported, but to work, thunderbird has to dust off it's browser roots in Firefox and work as a browser. Hence messages about a browser. At that point Thunderbird is a browser.

I assume some over zealous security has seen the JavaScript enabled setting turned off. IF not I am not sure why you ould see such an error.

more options

use the Config Editor to change the setting javascript.enabled to true.

oAuth is a browser security thing. Because Yahoo and Google are forcing it down the throats of mail clients it is supported, but to work, thunderbird has to dust off it's browser roots in Firefox and work as a browser. Hence messages about a browser. At that point Thunderbird is a browser.

I assume some over zealous security has seen the JavaScript enabled setting turned off. IF not I am not sure why you ould see such an error.

more options

Thank you! I didn't know about config editor. When I pulled it up, javascript was disabled. I enabled it, and the credentials screen worked. Thank you, thank you, thank you.

more options

I was having brain fade when I wrote that.

Options > Privacy has a user interface to toggling that stuff. Oh well, now you know there are two ways to change options.

more options

Hi, Matt. I don't see the choices Options > Privacy in the Thunderbird menu. Is Options supposed to be a top-level menu item? And are we talking about the menu at the three-little-stacked-bars on the far right of the URL bar? (Obviously, I don't know what stuff is called...)

Please help a lost soul! Thanks. I'm using Thunderbird version 60.2.1, in Ubuntu Linux 18.10.

-Amazing Blair

more options

amazingblair said

Hi, Matt. I don't see the choices Options > Privacy in the Thunderbird menu. Is Options supposed to be a top-level menu item? And are we talking about the menu at the three-little-stacked-bars on the far right of the URL bar? (Obviously, I don't know what stuff is called...) Please help a lost soul! Thanks. I'm using Thunderbird version 60.2.1, in Ubuntu Linux 18.10. -Amazing Blair

Linux options is called preferences and is on the edit menu. Apple OSX is is also called preferences but is on the Thunderbird menu.

more options

Thanks, Matt. That got me into the Thunderbird Preferences dialog box.

I did finally go into Config Editor, where "javascript.enabled" was set to "true" by default. So I don't know why I ran into the original problem where a video wouldn't run because JavaScript supposedly wasn't enabled in Thunderbird. Oh well. Thanks anyway.

more options

amazingblair said

So I don't know why I ran into the original problem where a video wouldn't run because JavaScript supposedly wasn't enabled in Thunderbird.

javascript is not enabled in mail. Ever. It is a huge security risk. Neither is flash, vb script etc. The option you speak about is for http/https JavaScript.