On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Get SEC_ERROR_BAD_SIGNATUR when connecting to well known sites.

  • 7 replies
  • 1 has this problem
  • 7 views
  • Last reply by mickbee

more options

Issue started Oct-4. Get error when trying to connect to popular sites such as Home Depot, Lowes, Bank of Montreal. DO NOT have a problem when trying to connect to foregoing sites using MS EDGE. Turning off Anti - Malware and Windows Defender had no affect on the problem.

Issue started Oct-4. Get error when trying to connect to popular sites such as Home Depot, Lowes, Bank of Montreal. DO NOT have a problem when trying to connect to foregoing sites using MS EDGE. Turning off Anti - Malware and Windows Defender had no affect on the problem.

Chosen solution

I previously read an article regarding this problem that suggested renaming or deleting the CERT8 file to resolve the problem however I could not find the file path to this file. I found a UTube video that showed the path and renamed both CERT8 and CERT9. Presto. Problem solved! Checked the folder in which these files where located and saw that new versions had been created. URLs previously resulting in the error were again reachable.

Read this answer in context 👍 0

All Replies (7)

more options
more options

Thanks for the responses however none of the suggestions solved the problem. In addition to trying suggested solutions, again tried to disable ESET and Windows Defender without effect. Now using EI which appears to be immune to the root cause problem.

more options

mickbee said

Thanks for the responses however none of the suggestions solved the problem. In addition to trying suggested solutions, again tried to disable ESET and Windows Defender without effect. Now using EI which appears to be immune to the root cause problem.

Why disable ESET when that would not fix anything in this case.

See https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message#w_eset-and-nod32-security-products

Modified by James

more options

Hello, Press Ctrl-Shift-Delete in the Time range select everything Be sure that Active Login is checked Select clear now PS be sure that you have exported all your password https://github.com/kspearrin/ff-password-exporter Happy Sunday!

Modified by AnnaSycamore

more options

James,

I'm shooting in the dark. Although I believe I did it previously, I tried disabling ESET again as a troubleshooting measure to be doubly sure it is not at the root of the problem.

Anna,

I tried the steps that you laid out but did not perform the export password step as I'm unfamiliar with what password(s) are exported, to where they are exported, or why passwords would need to be exported. Without more information, exporting passwords seems dangerous.

Thanks for your responses James and Anna, Best Regards, Mike

more options

Chosen Solution

I previously read an article regarding this problem that suggested renaming or deleting the CERT8 file to resolve the problem however I could not find the file path to this file. I found a UTube video that showed the path and renamed both CERT8 and CERT9. Presto. Problem solved! Checked the folder in which these files where located and saw that new versions had been created. URLs previously resulting in the error were again reachable.

more options

BTW. For tech-challenged users such as my self the file path I used was: C:\Users\<my name>\AppData\Roaming\Mozilla\Firefox\Profiles\3ty54pzl.default-1465421084087