X
Tap here to go to the mobile version of the site.

Support Forum

Dark theme isn't automatically enabled in macOS 10.14 dark mode

Posted

I recently found out that according to the 62.0 changelog (https://www.mozilla.org/en-US/firefox/62.0/releasenotes/), "Dark theme is automatically enabled in macOS 10.14 dark mode". This was news to me, since I'm on Firefox 62.0.2, and I'd been using Mojave for a few days, and f.lux automatically switches it to Dark Mode when the sun sets, and yet I'd never once seen Firefox switch to Dark Theme when this happened. I just restarted Firefox in Safe Mode to see if that helped, but it still isn't working.

I recently found out that according to the 62.0 changelog (https://www.mozilla.org/en-US/firefox/62.0/releasenotes/), "Dark theme is automatically enabled in macOS 10.14 dark mode". This was news to me, since I'm on Firefox 62.0.2, and I'd been using Mojave for a few days, and f.lux automatically switches it to Dark Mode when the sun sets, and yet I'd never once seen Firefox switch to Dark Theme when this happened. I just restarted Firefox in Safe Mode to see if that helped, but it still isn't working.

Chosen solution

Do you have the default theme enabled in Firefox?

You can check the current theme via the "Themes" button at the bottom of the Customize palette window.


  • Bug 1466335 - Automatically enable the dark theme in macOS 10.14 dark mode

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17342 solutions 156774 answers

Chosen Solution

Do you have the default theme enabled in Firefox?

You can check the current theme via the "Themes" button at the bottom of the Customize palette window.


  • Bug 1466335 - Automatically enable the dark theme in macOS 10.14 dark mode

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Do you have the default theme enabled in Firefox? You can check the current theme via the "Themes" button at the bottom of the Customize palette window. ---- *[https://bugzilla.mozilla.org/show_bug.cgi?id=1466335 Bug 1466335] - Automatically enable the dark theme in macOS 10.14 dark mode (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)

Question owner

Usually I have the Light Theme enabled. Why? Does it only work if you have Default Theme enabled first?

[reads the bug report]

Oh wow. So if you pick the Light or Dark Theme, it stays like that, but if you pick the Default Theme, it switches to appear like Dark Theme when macOS Dark Mode is enabled. Well, that's definitely something that should've been mentioned in the changelog. And also seems like a poor way to design this, since it means that the user is forced to use Default Theme all the time in order to take advantage of this behaviour. I believe a far better solution to the problems they were discussing would have been letting the user decide if they want to use this behaviour at all, and if they decide to use it, have it work regardless of what theme they use in macOS Light Mode. Or even let them decide both themes.

Oh well, at least now it works. Thank you for your help!

Usually I have the Light Theme enabled. Why? Does it only work if you have Default Theme enabled first? ''[reads the bug report]'' Oh wow. So if you pick the Light or Dark Theme, it stays like that, but if you pick the Default Theme, it switches to appear like Dark Theme when macOS Dark Mode is enabled. Well, that's definitely something that should've been mentioned in the changelog. And also seems like a poor way to design this, since it means that the user is forced to use Default Theme all the time in order to take advantage of this behaviour. I believe a far better solution to the problems they were discussing would have been letting the user decide if they want to use this behaviour at all, and if they decide to use it, have it work regardless of what theme they use in macOS Light Mode. Or even let them decide ''both'' themes. Oh well, at least now it works. Thank you for your help!
James
  • Moderator
1593 solutions 11223 answers

SavannahJ said

since I'm on Firefox 62.0.2,

Since you are using Mac OSX 10.14 Mojave you should use Firefox 62.0.3 as it has a fix hangs when various dialog windows are activated.

https://www.mozilla.org/firefox/62.0.3/releasenotes/

''SavannahJ [[#question-1236100|said]]'' <blockquote> since I'm on Firefox 62.0.2, </blockquote> Since you are using Mac OSX '''10.14 Mojave''' you should use Firefox 62.0.'''3''' as it has a fix hangs when various dialog windows are activated. https://www.mozilla.org/firefox/62.0.3/releasenotes/

Modified by James