X
Tap here to go to the mobile version of the site.

Support Forum

Need to change the font size of the "listing of all e-mails" pane. Not the reading pane. To increase font size or row height.

Posted

Thunderbird latest version 60.0

Thunderbird latest version 60.0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36

More Information

Matt
  • Top 10 Contributor
  • Moderator
3139 solutions 21370 answers
See https://addons.thunderbird.net/en-US/thunderbird/addon/theme-font-size-changer-for-tb/?src=search

Question owner

Thanks Matt for the link. Will try this add on.

Thanks Matt for the link. Will try this add on.
Wayne Mery
  • Top 25 Contributor
  • Moderator
568 solutions 5265 answers

This "fixed" version works for me.

Does it work for you??

https://addons.thunderbird.net/en-US/thunderbird/addon/theme-font-size-changer-fixed/

This "fixed" version works for me. Does it work for you?? https://addons.thunderbird.net/en-US/thunderbird/addon/theme-font-size-changer-fixed/

Question owner

No. I used Thunderbirdsetup 60.2.1.exe (30,680KB) to install TB. I am using windows 10 pro (64bit) It says that “ theme_font_size_changer_fixed-64.4-tb.xpi “ is incompatible with TB 60.2.1

No. I used Thunderbirdsetup 60.2.1.exe (30,680KB) to install TB. I am using windows 10 pro (64bit) It says that “ theme_font_size_changer_fixed-64.4-tb.xpi “ is incompatible with TB 60.2.1
Wayne Mery
  • Top 25 Contributor
  • Moderator
568 solutions 5265 answers

chris-m1's screen shot is

chris-m1's screen shot is
Wayne Mery
  • Top 25 Contributor
  • Moderator
568 solutions 5265 answers

someone reported similar issue in https://support.mozilla.org/en-US/questions/1236088 (different addon)

So far no one else can reproduce it

someone reported similar issue in https://support.mozilla.org/en-US/questions/1236088 (different addon) So far no one else can reproduce it
Toad-Hall
  • Top 25 Contributor
1625 solutions 10763 answers

Workaround: This may seem a little daunting, but it is simple. It requires you to be able to follow instructions, create folders, copy paste and save files. You do not need to actually write code.

Make Hidden files and folder visible:

In Thunderbird:

  • Help > Troubleshooting Information
  • click on 'Open folder' button
  • a new window opens showing your Profile folder.
  • Close Thunderbird now - this is important.
  • Create new folder and call it chrome note the spelling - use a lower case 'c' It should be in the same place as the 'Mail' folder.
  • open Notepad:

usually located under All Programs > Accessories > Notepad

  • Copy all the text between lines below and paste it into the Notepad document.

/*
 
* Do not remove the @namespace line -- it's required for correct functioning
 */

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); 

/* Effects the Message list */
#threadTree treechildren:-moz-tree-row 
{
height: 18pt !important; 
}

#threadTree treechildren:-moz-tree-cell-text
{
font-size: 16px !important;
}


If this proves to be too small you can edit the 16px to say 18px etc

  • Save the document as filename userChrome.css in the chrome folder. Note the spelling all lower case except for the 'C'.
  • Restart Thunderbird.
Workaround: This may seem a little daunting, but it is simple. It requires you to be able to follow instructions, create folders, copy paste and save files. You do not need to actually write code. Make Hidden files and folder visible: * http://kb.mozillazine.org/Show_hidden_files_and_folders In Thunderbird: * Help > Troubleshooting Information * click on 'Open folder' button * a new window opens showing your Profile folder. * Close Thunderbird now - this is important. * Create new folder and call it '''chrome''' note the spelling - use a lower case 'c' It should be in the same place as the 'Mail' folder. * open Notepad: usually located under All Programs > Accessories > Notepad * Copy all the text between lines below and paste it into the Notepad document. ------------------------------------ <pre> /* * Do not remove the @namespace line -- it's required for correct functioning */ @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* Effects the Message list */ #threadTree treechildren:-moz-tree-row { height: 18pt !important; } #threadTree treechildren:-moz-tree-cell-text { font-size: '''16px''' !important; } </pre> ------------------------------------- If this proves to be too small you can edit the 16px to say 18px etc * Save the document as filename '''userChrome.css''' in the '''chrome''' folder. Note the spelling all lower case except for the 'C'. * Restart Thunderbird.
Wayne Mery
  • Top 25 Contributor
  • Moderator
568 solutions 5265 answers
https://addons.thunderbird.net/en-US/thunderbird/addon/theme-font-size-changer-fixed/ should work now

Question owner

Toad-Hall said

Workaround: This may seem a little daunting, but it is simple. It requires you to be able to follow instructions, create folders, copy paste and save files. You do not need to actually write code. Make Hidden files and folder visible: In Thunderbird:
  • Help > Troubleshooting Information
  • click on 'Open folder' button
  • a new window opens showing your Profile folder.
  • Close Thunderbird now - this is important.
  • Create new folder and call it chrome note the spelling - use a lower case 'c' It should be in the same place as the 'Mail' folder.
  • open Notepad:
usually located under All Programs > Accessories > Notepad
  • Copy all the text between lines below and paste it into the Notepad document.

/*
 
* Do not remove the @namespace line -- it's required for correct functioning
 */

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); 

/* Effects the Message list */
#threadTree treechildren:-moz-tree-row 
{
height: 18pt !important; 
}

#threadTree treechildren:-moz-tree-cell-text
{
font-size: 16px !important;
}


If this proves to be too small you can edit the 16px to say 18px etc

  • Save the document as filename userChrome.css in the chrome folder. Note the spelling all lower case except for the 'C'.
  • Restart Thunderbird.

Not sure what this is supposed to do but have followed these instructions. It still says that it is incompatible.

''Toad-Hall [[#answer-1161158|said]]'' <blockquote> Workaround: This may seem a little daunting, but it is simple. It requires you to be able to follow instructions, create folders, copy paste and save files. You do not need to actually write code. Make Hidden files and folder visible: * http://kb.mozillazine.org/Show_hidden_files_and_folders In Thunderbird: * Help > Troubleshooting Information * click on 'Open folder' button * a new window opens showing your Profile folder. * Close Thunderbird now - this is important. * Create new folder and call it '''chrome''' note the spelling - use a lower case 'c' It should be in the same place as the 'Mail' folder. * open Notepad: usually located under All Programs > Accessories > Notepad * Copy all the text between lines below and paste it into the Notepad document. ------------------------------------ <pre> /* * Do not remove the @namespace line -- it's required for correct functioning */ @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* Effects the Message list */ #threadTree treechildren:-moz-tree-row { height: 18pt !important; } #threadTree treechildren:-moz-tree-cell-text { font-size: '''16px''' !important; } </pre> ------------------------------------- If this proves to be too small you can edit the 16px to say 18px etc * Save the document as filename '''userChrome.css''' in the '''chrome''' folder. Note the spelling all lower case except for the 'C'. * Restart Thunderbird. </blockquote> Not sure what this is supposed to do but have followed these instructions. It still says that it is incompatible.
Toad-Hall
  • Top 25 Contributor
1625 solutions 10763 answers

It has nothing to do with the addon.

It is a workaround to get Thunderbird to use special settings.

  1. Post an image which shows me where you saved the 'chrome' folder .
  2. Post an image which shows me where you saved the 'userChrome.css' file .
  3. Post an image showing all the contents of your 'userChrome.css' file.
It has nothing to do with the addon. It is a workaround to get Thunderbird to use special settings. # Post an image which shows me where you saved the 'chrome' folder . # Post an image which shows me where you saved the 'userChrome.css' file . # Post an image showing all the contents of your 'userChrome.css' file.

Question owner

See attached images.

See attached images.
Toad-Hall
  • Top 25 Contributor
1625 solutions 10763 answers

In 'Folder Options' where you made hidden files and folders visible, can you make sure the option 'Hide extensions for known file types' is Not selected. Then double check that the name of that file really is 'userChrome.css' and not 'userChrome.css.css' right click on that file and select 'Properties' to locate info.

Whilst in 'Properties' make sure 'Attributes' is not 'read-only' and check the 'Security' tab to make sure you have full permissions on this file.

Can you confirm that in the 'userChrome.css' file, at the end of the line where it says -moz-tree-row, the | is not really there, but it is the cursor flashing and it got captured in the image?

note any modifications must be done with Thunderbird closed - not running. Regarding this line: #threadTree treechildren:-moz-tree-cell-text try removing the part I've set in bold so everything looks like the section below and save the file.


#threadTree treechildren
{
font-size: 16px !important;
}


Otherwise all seems ok, but please check out the following.

Assuming all seems to be correct, then maybe you have downloaded and installed an addon extension which is overwriting or causing a conflict with the userChrome.css instruction. To find out, you would need to disable any addon extension which could influence UI design and also use the default theme.

then restart Thunderbird.

In 'Folder Options' where you made hidden files and folders visible, can you make sure the option 'Hide extensions for known file types' is Not selected. Then double check that the name of that file really is 'userChrome.css' and not 'userChrome.css.css' right click on that file and select 'Properties' to locate info. Whilst in 'Properties' make sure 'Attributes' is not 'read-only' and check the 'Security' tab to make sure you have full permissions on this file. Can you confirm that in the 'userChrome.css' file, at the end of the line where it says -moz-tree-row, the '''|''' is not really there, but it is the cursor flashing and it got captured in the image? note any modifications must be done with Thunderbird closed - not running. Regarding this line: #threadTree treechildren''':-moz-tree-cell-text''' try removing the part I've set in bold so everything looks like the section below and save the file. ---------------- <pre> #threadTree treechildren { font-size: 16px !important; } </pre> -------------------------------- Otherwise all seems ok, but please check out the following. Assuming all seems to be correct, then maybe you have downloaded and installed an addon extension which is overwriting or causing a conflict with the userChrome.css instruction. To find out, you would need to disable any addon extension which could influence UI design and also use the default theme. then restart Thunderbird.

Question owner

Followed all instructions and still it does not load. 1. File really is userChrome.css See attached 2. Under Properties the Attribute is "A" 3. Full Permissions are ON under Security for SYSTEM / My e-mail / Administrators: All are ticked under the Allow column except for Special permission which is greyed out and not available. 4. "At the end of the line where it says -moz-tree-row, the | is not really there, but it is the cursor flashing and it got captured in the image" Correct. See new image where cursor was moved to the front. 5. See the new modified userChrome.css file as per instructions. 6. Other Addon extensions are diabled. See attached. Also addon debugging.

Followed all instructions and still it does not load. 1. File really is userChrome.css See attached 2. Under Properties the Attribute is "A" 3. Full Permissions are ON under Security for SYSTEM / My e-mail / Administrators: All are ticked under the Allow column except for Special permission which is greyed out and not available. 4. "At the end of the line where it says -moz-tree-row, the | is not really there, but it is the cursor flashing and it got captured in the image" Correct. See new image where cursor was moved to the front. 5. See the new modified userChrome.css file as per instructions. 6. Other Addon extensions are diabled. See attached. Also addon debugging.

Modified by chris-m1