X
Tap here to go to the mobile version of the site.

Safely share files online with encrypted links that “self-destruct.” Try Firefox Send.

Give hackers a swift kick in the cookies. See if your data has been affected by a breach with Firefox Monitor. Try it now.

Access your history, passwords and open tabs wherever you are with Sync. Connect a second device.

Support Forum

how can I download Firefox 52.2.1 (64 bit)? I have software (necessary for work) that runs on that version. And how can I prevent FF from overriding this ver

Posted

I do use the latest version of FF. but today the older version was wiped out. This seems to happen frequently,, but I've been able to find a version of 52.2.1

Today I can't seem to locate this version.

BTW: The work software requires Silverlight. There's a bug somewhere, as the Silverlight "Can't be found and needs to be installed". But the new version of FF states Silver is already installed.

Yes, I know - the work software is horrible and is the problem!

I do use the latest version of FF. but today the older version was wiped out. This seems to happen frequently,, but I've been able to find a version of 52.2.1 Today I can't seem to locate this version. BTW: The work software requires Silverlight. There's a bug somewhere, as the Silverlight "Can't be found and needs to be installed". But the new version of FF states Silver is already installed. Yes, I know - the work software is horrible and is the problem!

Chosen solution

The last version of Firefox that runs Silverlight is the Extended Support Release of Firefox 52 (52.9.0esr, I think). This article has the link to the server with old versions: Install an older version of Firefox.

That version is not supported for use on the wilds of the web. You could consider using a "Portable" version of Firefox 52 (which is isolated in its own folder) for that one application instead of rolling back Firefox for all of your browsing. See: https://portableapps.com/apps/internet/firefox-portable-legacy-52

Another option is to use Internet Explorer 11 for Silverlight applications.

Read this answer in context 2

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; Touch; .NET4.0C; .NET4.0E; .NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729; Tablet PC 2.0; wbx 1.0.0; rv:11.0) like Gecko

More Information

jscher2000
  • Top 10 Contributor
8105 solutions 66211 answers

Chosen Solution

The last version of Firefox that runs Silverlight is the Extended Support Release of Firefox 52 (52.9.0esr, I think). This article has the link to the server with old versions: Install an older version of Firefox.

That version is not supported for use on the wilds of the web. You could consider using a "Portable" version of Firefox 52 (which is isolated in its own folder) for that one application instead of rolling back Firefox for all of your browsing. See: https://portableapps.com/apps/internet/firefox-portable-legacy-52

Another option is to use Internet Explorer 11 for Silverlight applications.

The last version of Firefox that runs Silverlight is the Extended Support Release of Firefox 52 (52.9.0esr, I think). This article has the link to the server with old versions: [[Install an older version of Firefox]]. That version is not supported for use on the wilds of the web. You could consider using a "Portable" version of Firefox 52 (which is isolated in its own folder) for that one application instead of rolling back Firefox for all of your browsing. See: https://portableapps.com/apps/internet/firefox-portable-legacy-52 Another option is to use Internet Explorer 11 for Silverlight applications.