Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

All sites insecure after Firefox Refresh

more options

I've just done a Firefox Refresh which has been a bit of a disaster as any attempt to connect to any sites now gives a message to say that they don't have the right certificate and are insecure. The same goes for your own site!

Any help please??

Chosen solution

thanks, so it appears that the avast/avg software on your system is tampering with secure connections. you should try disabling https scanning in its webshield settings like described here: https://support.avast.com/en-ww/article/189/ (instructions are for windows, but i think it should be fairly similar on osx)

Read this answer in context 👍 0

All Replies (9)

more options

hi, first please make sure that the date, time & timezone are set correctly on your system. if this doesn't solve the issue (or it is already set properly), a solution depends on the individual circumstances:

  • what is the error code shown when you click on advanced on that error page?
  • please also give us more information about the error by clicking on the error code, copying the text to the clipboard and then pasting it here into a reply in the forum like shown in the screenshot.

thank you!

more options

Hi Thanks for your very prompt response. There have been no changes to date and time etc. Here below is a screenshot typical of the response I receive from every site I now try to contact.

The two additional screenshots are for a different site.

Mike

more options

thanks, we'd need to have this information from the 3rd screenshot in text form to know what's going on though - please use the dedicated "copy text to clipboard" button, as transcribing all that would be too much work :))

more options

Try to copy the cert9.db file from the "Old Firefox Data" folder on the desktop to the current profile folder with Firefox closed to recover all certificates.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

I can press the Copy Text to Clipboard button, but don't see the text anywhere so how do I send it to you?

more options

after clicking the "Copy Text to Clipboard" button, you can paste it here into the reply box on the forum by pressing command+v.

more options

Hope this helps:

https://www.google.com/search?q=moodyowners&ie=utf-8&oe=utf-8&client=firefox-b-ab

Peer's Certificate issuer is not recognised.

HTTP Strict Transport Security: false HTTP Public Key Pinning: true

Certificate chain:


BEGIN CERTIFICATE-----

MIIDqTCCApGgAwIBAgICHsMwDQYJKoZIhvcNAQELBQAwaDELMAkGA1UEBhMCQ1ox DzANBgNVBAgTBlByYWd1ZTEOMAwGA1UEChMFQVZBU1QxHTAbBgNVBAsTFFNvZnR3 YXJlIERldmVsb3BtZW50MRkwFwYDVQQDExBBdmFzdCB0cnVzdGVkIENBMB4XDTE4 MDgyMTA4MDUwMFoXDTE4MTExMzA4MDUwMFowaDELMAkGA1UEBhMCVVMxEzARBgNV BAgMCkNhbGlmb3JuaWExFjAUBgNVBAcMDU1vdW50YWluIFZpZXcxEzARBgNVBAoM Ckdvb2dsZSBMTEMxFzAVBgNVBAMMDnd3dy5nb29nbGUuY29tMIIBIjANBgkqhkiG 9w0BAQEFAAOCAQ8AMIIBCgKCAQEApWM+l3jZeyEHyrLuZi4gIbkIy0IHUrqvyp7x 4XYG3zWvqpem1COWHz9a3akz2nPH1sWshmVOAhco+t39wG7lmbKHnwKWnheMUfno CSaPNDZd6svxLNJdeGvEQFSrMww1vkAop0+ImUtEDYx7EHwjA80p6bgb1Mo2WrJg V2es8/3ZIFyOSsq+RuEFM18Hvzfyr6aBlcKlWM21xA4424wQ19rRzCsCvOG9EYL3 YSgLgRd5Yyau6xmwNwMpQfZd0r+eBONzpN5fvm+Zo39PwOIe4nOSClqzqZL1Mw+1 jwW5wEui81lIBAldZB2WkXO9OYA1QM6o5UyXAvmC8uuKrCxo2wIDAQABo10wWzAd BgNVHQ4EFgQUNX2XMf16WI4dsiBYmg3JiZMZNyMwHwYDVR0jBBgwFoAUeOnL9tvK bKd1VCxzzWTmyIzuu4QwGQYDVR0RBBIwEIIOd3d3Lmdvb2dsZS5jb20wDQYJKoZI hvcNAQELBQADggEBAJnX/1Obvu0UKmHieZVa9f0Ve3EIp4zytyM/QMp258HvqT6b VtFz8Sz8VAcnqjpp/3d/pnyGQFUV8SltLhLKQdMHyhZ26NmRY8Z5d43Kk6uQ460t 5qZ05+qsSrFnE08sYtlLwdp9eSo6m6zsLOWeEVop8nlygcW9v+dHTHTw3sEMSCI3 cb5tftQz+RUCynjV7qisF8zO4ufvvIp0ROLRhSem3/GR/MSwvy/hlFMu6GU/XnBj CAbksCROP4qJ6FGgLLQCsqq/zoXcvtFs1eK06Jb/oJVC84SLj6Vi15/BdP7bcUTw QaUwAs70vxSQBVbBYuj4vkrdHLymqp5n/YNhSwI=


END CERTIFICATE-----
more options

Chosen Solution

thanks, so it appears that the avast/avg software on your system is tampering with secure connections. you should try disabling https scanning in its webshield settings like described here: https://support.avast.com/en-ww/article/189/ (instructions are for windows, but i think it should be fairly similar on osx)

more options

That did the trick. Thank you for your help.