Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

my system is a windows 7 product, why do I no longer qualify to get updates?

  • 3 replies
  • 1 has this problem
  • 19 views
  • Last reply by Loise

more options

I just received the notice that my system is too old to update Firefox, yet down the page a bit, my system is listed as a supported OS. Why is this? And what can I do that does not require taking a month or six to understand a new OS? ( ps: I'm old, too ) Also, my system is Windows Home 7, NOT Vista.

Chosen solution

Your useragent in More System Details appears to be Firefox 52 on Windows Vista. Mozilla/5.0 (Windows NT 6.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

Two possibilities. Either you have been running Firefox in Windows Vista compatibility mode for some time or you have modified the useragent. The NT 6.0 is for Vista.

Could you turn off any compatibility settings on your Firefox shortcut?

To do that, find the icon you use the start Firefox, and either:

  • Right-click a desktop shortcut, then click Properties
  • Right-click a Firefox icon pinned to the Taskbar then right-click Mozilla Firefox, then click Properties

You should clear all the boxes on the Compatibility tab for best results (giant screenshot below).

Any difference the next time you start Firefox? (credits to jscher2000 for above part).

Or you have a modified useragent for some reason. See https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

Your useragent in More System Details appears to be Firefox 52 on Windows Vista. Mozilla/5.0 (Windows NT 6.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

Two possibilities. Either you have been running Firefox in Windows Vista compatibility mode for some time or you have modified the useragent. The NT 6.0 is for Vista.

Could you turn off any compatibility settings on your Firefox shortcut?

To do that, find the icon you use the start Firefox, and either:

  • Right-click a desktop shortcut, then click Properties
  • Right-click a Firefox icon pinned to the Taskbar then right-click Mozilla Firefox, then click Properties

You should clear all the boxes on the Compatibility tab for best results (giant screenshot below).

Any difference the next time you start Firefox? (credits to jscher2000 for above part).

Or you have a modified useragent for some reason. See https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox

Modified by James

more options

Note after you fix the useragent you should download the current Firefox 62.0 Release from www.mozilla.org/firefox/all as doing a Update in Firefox will serve you 60.2.0 ESR instead.

more options

This worked!! Thank You so much! I was getting desperate, and you were my knight in shining...... uh, overkill, huh? But still, Thank you for your help.