Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

too many processes for a single tab in firefox (ubuntu 18.04)

  • 6 replies
  • 1 has this problem
  • 21 views
  • Last reply by carefreekk

more options

Opened a single tab in Firefox and checked the CPU resources used. There are 40+ processes created by Firefox. Could someone please explain why these many processes are required? currently using ubuntu 18.04 and firefox version: 61.0.1 64 bit

All Replies (6)

more options

screenshot attached

more options

Thanks for the screenshot.

That's bizarre. There should only be one content process with

-childID 1

per instance of Firefox.

more options

Is there some other info required which can help in debugging the issue. I really do not want to reinstall Firefox again.

more options

Hi, Firefox 62.0 is released now. If want to work with a even number : Pick your language or back URL up to 32 bit : https://archive.mozilla.org/pub/firefox/releases/62.0/linux-x86_64/

I have no idea if any of this applies to you (Windows person & bold)

To be Checked and turned off unless needed for accessibility : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Multi-Processor Support : Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Only Disable as last resort.

Multi-processor Can completely disable it this way in about:config : dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Only move to esr if low ram and old system.

Firefox Extended Release Version : Firefox ESR does not come with the latest features but it has the latest security and stability fixes.

If do please :

I would also suggest a Malware scan, yes I know... but do so as your not invulnerable as you think you are.

https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram

I do not know why a comment was made with out a suggestion by jscher2000 as is not like him to do that.

Please also try : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Performance > Uncheck to view)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

more options

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

You can find the full version of the current Firefox release (62.0) in all languages and all operating systems here:

more options

thank you for the replies. I'll follow the steps mentioned and post the results asap.