Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Languages Incompatibe

  • 11 replies
  • 2 have this problem
  • 7 views
  • Last reply by groucho43

more options

The Hebrew language packs are incompatible like many others I read about. Any ideas?

The Hebrew language packs are incompatible like many others I read about. Any ideas?

Modified by Darshovits

Chosen solution

Yes, toggling the preference doesn't work in this case, so we need to apply the old trick of editing the install.rdf file. 1. download the dictionary xpi file and change the extension to .zip, i.e. hebrew_spell_checking_dictionary_from_hspell-1.4.zip 2. extract the install.rdf file from the zip file, open it in a text editor 3. change line 19 so the maxVersion reads: maxVersion>60.0 instead of maxVersion>3.1a1pre (or 60.* to ensure compatibility with future releases of TB 60) 4. save the new install.rdf and add it to the zip, replacing the original one 5. change the zip extension back to xpi 6. in Tools/Add-ons/Dictionaries, click the gear icon next to the search box, Install add-on from file..., select the xpi file (or drag and drop)

See the attached picture; appears to be working on Hebrew text.

Read this answer in context 👍 2

All Replies (11)

more options

Have you got this add-on?

https://addons.thunderbird.net/en-US/thunderbird/addon/bidi-mail-ui/ That is about all that is available.

more options

I found the way to properly add in that bidi add on. Not manually but through the web page. So thank you for this. And I am amazed bidi is add-on and not inside the product.

So now we are still left with the Hebrew spelling packs. What am I missing or should I use some other specific release that you provide?

Modified by Darshovits

more options

Darshovits said

I found the way to properly add in that bidi add on. Not manually but through the web page. So thank you for this. And I am amazed bidi is add-on and not inside the product.

The add-on has less that 3,000 users. hardly justifies developer resources for so few users.

So now we are still left with the Hebrew spelling packs. What am I missing or should I use some other specific release that you provide?

Did you download the Hebrew version? See https://www.thunderbird.net/en-US/thunderbird/all/

I would assume it comes with the relevant dictionaries installed.

more options

OK....

Modified by Darshovits

more options

Keep in mind that 'language packs' change the TB interface, and are separate from dictionaries, used for spell checking. The Hebrew dictionary is here:

https://addons.thunderbird.net/en-US/thunderbird/addon/hebrew-spell-checking-dictiona/

Drag the Download Now button and drop it onto Tools/Add-ons/Extensions in TB. If you get an 'incompatible' error message, as you might with TB 60, change the preference extensions.strictCompatibility to false (double-click to toggle) before installing the add-on. The default dictionary is set in Tools/Options/Composition/Spelling.

more options

Dragging the download button is swell idea. But after I did toggle extensions.strictCompatibility in advanced/config editor , it does not work.

Certainly this must be the way to go -- just the editing.

more options

Chosen Solution

Yes, toggling the preference doesn't work in this case, so we need to apply the old trick of editing the install.rdf file. 1. download the dictionary xpi file and change the extension to .zip, i.e. hebrew_spell_checking_dictionary_from_hspell-1.4.zip 2. extract the install.rdf file from the zip file, open it in a text editor 3. change line 19 so the maxVersion reads: maxVersion>60.0 instead of maxVersion>3.1a1pre (or 60.* to ensure compatibility with future releases of TB 60) 4. save the new install.rdf and add it to the zip, replacing the original one 5. change the zip extension back to xpi 6. in Tools/Add-ons/Dictionaries, click the gear icon next to the search box, Install add-on from file..., select the xpi file (or drag and drop)

See the attached picture; appears to be working on Hebrew text.

Modified by sfhowes

more options

Mr. Sfhowes, this is exactly what I was looking for. A workable recipe for having this work for me. Your recipe should hang in big letters next to the pages where people download the program - this maxversion issue that many have been tampering with in Greek and what not.

Modified by Darshovits

more options

Language packs in newer versions of THunderbird should now work by default

more options

Wayne Mery said

Language packs in newer versions of THunderbird should now work by default

Correction, dictionaries should work. But Language Packs like https://addons.thunderbird.net/en-US/thunderbird/addon/hebrew-il-language-pack-thunde/ apparently not.

SUMO folk take note - these add-ons are created by US as part of release automation - but the automation is broken, so the add-ons on ATN have not been updated

more options

sfhowes said

Yes, toggling the preference doesn't work in this case, so we need to apply the old trick of editing the install.rdf file. 1. download the dictionary xpi file and change the extension to .zip, i.e. hebrew_spell_checking_dictionary_from_hspell-1.4.zip 2. extract the install.rdf file from the zip file, open it in a text editor 3. change line 19 so the maxVersion reads: maxVersion>60.0 instead of maxVersion>3.1a1pre (or 60.* to ensure compatibility with future releases of TB 60) 4. save the new install.rdf and add it to the zip, replacing the original one 5. change the zip extension back to xpi 6. in Tools/Add-ons/Dictionaries, click the gear icon next to the search box, Install add-on from file..., select the xpi file (or drag and drop) See the attached picture; appears to be working on Hebrew text.

THANKS!