X
Tap here to go to the mobile version of the site.

Safely share files online with encrypted links that “self-destruct.” Try Firefox Send.

Give hackers a swift kick in the cookies. See if your data has been affected by a breach with Firefox Monitor. Try it now.

Access your history, passwords and open tabs wherever you are with Sync. Connect a second device.

Support Forum

Cannot view PDF in firefox

Posted

Hi there,

I'm unable to view PDFs in Firefox 60.1.0esr using either the built in viewer or Acrobat Reader. When I click on a link containing a PDF, I receive an Open/Save As dialog box to view the file external to Firefox or save it to a local drive.

I've read a few different threads similar to this that all seem to recommend changing the Application Action for PDF/Portable Document Format. Unfortunately, I don't have PDF, Portable Document Format or any other Adobe related Content Types listed in the Menu -> Options -> Applications section. Can somebody please help? I love Firefox, but this is a major drawback.

For info: Internet Explorer is able to open/view PDFs within the browser, so the issue seems to be tied to the Firefox installation.

Thanks in advance!

Hi there, I'm unable to view PDFs in Firefox 60.1.0esr using either the built in viewer or Acrobat Reader. When I click on a link containing a PDF, I receive an Open/Save As dialog box to view the file external to Firefox or save it to a local drive. I've read a few different threads similar to this that all seem to recommend changing the Application Action for PDF/Portable Document Format. Unfortunately, I don't have PDF, Portable Document Format or any other Adobe related Content Types listed in the Menu -> Options -> Applications section. Can somebody please help? I love Firefox, but this is a major drawback. For info: Internet Explorer is able to open/view PDFs within the browser, so the issue seems to be tied to the Firefox installation. Thanks in advance!

Chosen solution

(To other readers finding this thread, please start with the support article: View PDF files in Firefox)

Hi dawger1, does this affect all PDFs from all sites?

Some sites may not send the specific content type header ("application/pdf") that triggers the built-in viewer, so it's helpful to see whether it's that issue before diving into extended troubleshooting.

Application Settings

You definitely should have Portable Document Format (PDF) in the box. It's one of the basics that Firefox creates at installation or in a new profile:

If that does not appear, it's possible the settings file which stores your download preferences has become corrupted. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then right-click > Rename handlers.json to something like handlersOLD.json. If you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf.

Start Firefox back up again. Any improvement?

Is pdfjs disabled?

While it is unlikely, you could check the setting here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste pdf and pause while the list is filtered

(3) If the pdfjs.disabled preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false

Any progress so far?

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 30.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

jscher2000
  • Top 10 Contributor
8100 solutions 66197 answers

Chosen Solution

(To other readers finding this thread, please start with the support article: View PDF files in Firefox)

Hi dawger1, does this affect all PDFs from all sites?

Some sites may not send the specific content type header ("application/pdf") that triggers the built-in viewer, so it's helpful to see whether it's that issue before diving into extended troubleshooting.

Application Settings

You definitely should have Portable Document Format (PDF) in the box. It's one of the basics that Firefox creates at installation or in a new profile:

If that does not appear, it's possible the settings file which stores your download preferences has become corrupted. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then right-click > Rename handlers.json to something like handlersOLD.json. If you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf.

Start Firefox back up again. Any improvement?

Is pdfjs disabled?

While it is unlikely, you could check the setting here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste pdf and pause while the list is filtered

(3) If the pdfjs.disabled preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false

Any progress so far?

''(To other readers finding this thread, please start with the support article: [[View PDF files in Firefox]])'' Hi dawger1, does this affect all PDFs from all sites? Some sites may not send the specific content type header ("application/pdf") that triggers the built-in viewer, so it's helpful to see whether it's that issue before diving into extended troubleshooting. '''''Application Settings''''' You definitely should have '''Portable Document Format (PDF)''' in the box. It's one of the basics that Firefox creates at installation or in a new profile: <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2018-08-29-11-27-10-d02146.png" width="500"> If that does not appear, it's possible the settings file which stores your download preferences has become corrupted. You can rename the file and have Firefox rebuild it. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > Exit * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then right-click > Rename '''handlers.json''' to something like '''handlersOLD.json'''. If you see a file named '''mimeTypes.rdf''', rename that one to '''mimeTypesOLD.rdf'''. Start Firefox back up again. Any improvement? '''''Is pdfjs disabled?''''' While it is unlikely, you could check the setting here: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''pdf''' and pause while the list is filtered (3) If the '''pdfjs.disabled''' preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false Any progress so far?

Modified by jscher2000

Question owner

Hi jscher2000,

Thank you very much for the quick response! I'm unable to view PDFs from any website within Firefox.

I should've added that I removed and re-installed Firefox yesterday afternoon in an effort to solve this issue, to no avail.

I renamed handlers.json in an attempt to rebuild the file as you suggested, but the PDF/Portable Document Format content type was still not listed after restarting Firefox.

I checked pdfjs.disabled, and it was set to true initially. However, changing it to false made no difference in the browsing session. Clicking on links/opening bookmarks with PDFs results in an Open With/Save File dialog box. In fact, when I closed Firefox and re-opened it again, pdfjs.disabled was automatically re-set to true.

So at a high level, I see two main issues: 1. The Portable Document Format not being listed as a content type; and 2. The built in PDF viewer is automatically resetting to disabled each time I open the browser

Hi jscher2000, Thank you very much for the quick response! I'm unable to view PDFs from any website within Firefox. I should've added that I removed and re-installed Firefox yesterday afternoon in an effort to solve this issue, to no avail. I renamed handlers.json in an attempt to rebuild the file as you suggested, but the PDF/Portable Document Format content type was still not listed after restarting Firefox. I checked pdfjs.disabled, and it was set to true initially. However, changing it to false made no difference in the browsing session. Clicking on links/opening bookmarks with PDFs results in an Open With/Save File dialog box. In fact, when I closed Firefox and re-opened it again, pdfjs.disabled was automatically re-set to true. So at a high level, I see two main issues: 1. The Portable Document Format not being listed as a content type; and 2. The built in PDF viewer is automatically resetting to disabled each time I open the browser
jscher2000
  • Top 10 Contributor
8100 solutions 66197 answers

dawger1 said

I checked pdfjs.disabled, and it was set to true initially. However, changing it to false made no difference in the browsing session. Clicking on links/opening bookmarks with PDFs results in an Open With/Save File dialog box. In fact, when I closed Firefox and re-opened it again, pdfjs.disabled was automatically re-set to true.

Are you using a "managed" version of Firefox that could have its features modified by a company IT department?

If not, there are a number of reasons that a settings change you make during your session might be lost between sessions. This article discusses a number of potential explanations/solutions: How to fix preferences that won't save.

''dawger1 [[#answer-1148168|said]]'' <blockquote>I checked pdfjs.disabled, and it was set to true initially. However, changing it to false made no difference in the browsing session. Clicking on links/opening bookmarks with PDFs results in an Open With/Save File dialog box. In fact, when I closed Firefox and re-opened it again, pdfjs.disabled was automatically re-set to true. </blockquote> Are you using a "managed" version of Firefox that could have its features modified by a company IT department? If not, there are a number of reasons that a settings change you make during your session might be lost between sessions. This article discusses a number of potential explanations/solutions: [[How to fix preferences that won't save]].

Question owner

I'm not sure what happened, but Portable Document Format is now listed as a Content Type in my copy of Firefox, and I'm able to preview within the web browser. I followed the instructions to rebuild the handlers.json file earlier today, but that's all I've done to the laptop.

Thank you for your help, jscher2000!

I'm not sure what happened, but Portable Document Format is now listed as a Content Type in my copy of Firefox, and I'm able to preview within the web browser. I followed the instructions to rebuild the handlers.json file earlier today, but that's all I've done to the laptop. Thank you for your help, jscher2000!