Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot remove update box or click on it

  • 15 replies
  • 1 has this problem
  • 14 views
  • Last reply by Shadow110

more options

The box to update Firefox "A new Firefox update is available...Download update" is stuck on my main Firefox browser window in the top left corner.. I cannot click on it or close it and it appears on all of my tabs. I could just close the browser but frankly I've got a lot of tabs open and my Firefox settings mean that if I closed the window and reopened them all in a bookmark folder, I'd have to log in to all my sites again. Also I don't know if the same thing wouldn't just happen again.

I don't know if this is Firefox's way of forcing you into submission to update the browser but it is quite frustrating, I shouldn't have to go through such a massive effort just to get rid of an update box that obscures my view. I also don't want to get rid of the box appearing altogether as I like to know when there is an update so I can choose to download it or not.

Any suggestions appreciated. Thanks

All Replies (15)

more options

Separate Security Issue: Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 30.0.0.113

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

It looks like you are using the current version. Do Not Update Or Use Any Links until we tell you.


In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

Thanks for responding.

I've attached a screenshot, with my tab details removed for privacy. (FYI I tried attaching this on OP but after 5 minutes of it not uploading I gave up)

How do you know which version I am using?

more options

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Now in the Reply Box on the forum page, do a right-click in the box and select Paste.

This will show us your system details. No Personal Information Is Collected.

Note: Your Firefox version is also displayed here.

more options

Hi FredMcD, if you tell me which bits of information you need specifically from that page I will be more than happy to provide those. I do not really want to paste all of it here due to personal privacy reasons.

Thanks

more options

FredMcD said

No Personal Information Is Collected.

Just the first section; Application Basics.

more options

FredMcD said

FredMcD said
Just the first section; Application Basics.

Modified by Jognel

more options

Okay. You are using Firefox 60.0 The current is 60.0.2

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no

more options

FredMcD said

Okay. You are using Firefox 60.0 The current is 60.0.2 https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no

Right yes I am aware I am on a slightly outdated version. The point is I don't want to update yet and also in doing so close all my tabs / log ins to restart the browser.

I don't believe a browser should coerce me into updating by forcing a static box over my screen that I can't even click to remove.

I just want to close the box and return to my browsing, are you able to help with that?

more options

Hi, the 2 fixes that will do this are to Start Firefox in Safe Mode and to Reinstall with a full version installer of which version 61 will be out in the next day or so.

So when you feel like you can accommodate finding a solution for you please come back then.

more options

Pkshadow said

So when you feel like you can accommodate finding a solution for you please come back then.

I'm not sure what the purpose of saying this is. My problem is not being able to close the update box (which normally closes upon selection) without restarting the browser, so I am more than open to any solution that solves this problem.

If you think it's not possible to close the box, please inform me and I will act accordingly. If you think that it might be possible but don't want to entertain the idea and rather to tell me I'm not open to alternative solutions, then I would kindly ask not to post.

Thank you

Modified by Jognel

more options

Hi, it as Fred gave you link to update to see if that would fix the issue , but you told a story of not wanting to. This it seemed you were not ready to do anything at the moment as you had things going on like a session. Thus the comeback when.

Please try this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 60.0.2 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

First, Type about:preferences#advanced<enter> in the address bar. Under Advanced, Select Update.

[v56+] Type about:preferences#general<enter> in the address bar. Select Update.

Select Never Check For Updates.

Also turn off Use a background service to install updates <Windows Only>

more options

FredMcD said

First, Type about:preferences#advanced<enter> in the address bar. Under Advanced, Select Update. [v56+] Type about:preferences#general<enter> in the address bar. Select Update. Select Never Check For Updates. Also turn off Use a background service to install updates <Windows Only>

There is no "Advanced" field for me.

There also is no "Update" field or option specifically, though there is a "Firefox Updates" field with the "Never check for updates" option and "Use background service" field (that can be unchecked) that you mentioned.

I have to say unfortunately I cannot tell you if this fixes the problem, because I decided to just restart the browser (before seeing your post) and go through the process of restoring my tabs.

If it happens again I will be sure to try your proposed solution, and if it works I will certainly select the "Solved the problem" option here.

Sorry, but it was 14 hours of that box there and my patience ran out.. and it seemed like there wasn't going to be a solution to the problem here.

Thanks for your help

Modified by Jognel

more options

What you miss when do not update :