Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox won't open websites and local sites

more options

I use Firefox Quantum Version 60.0.2 64 Bit on a Windows Server 2008 R2 complete patched with the Role Remoteserver.

If I use Firefox to open a website on the Internet or a website on the LAN, nothing happens. IE loads both pages on the same machine.

I can see with process monitor from sysinternals that the firefox.exe does not even try to generate traffic to the destination IP.

I have uninstalled the Firefox, deleted all related folders and registry entries. I cleaned about:support Firefox. I have disabled all security features on the machine like GPO, antivirus, firewall, proxy. Nothing happens! The firefox does not even try to open a website.

Is there a logfile somewhere? What can I do to make the firefox work?

Attached screenshots

Chosen solution

The 32Bit Firefox 60 works!!! Thanks for helping me!!!

Read this answer in context 👍 0

All Replies (14)

more options

I know that you said that you disabled proxy, but is it possible that you overlooked Firefox's independent proxy setting? Try making sure that it's disabled, by doing the following:

  1. Type about:preferences in the Firefox address bar
  2. Select the General tab
  3. Go to the Network Proxy section at the very bottom of the page
  4. Press the Settings... button
  5. Select No proxy
  6. Restart Firefox
more options

Hi Wesley, attached a picture. the firefox uses no Proxy.

more options

I assume that Firefox is able to access other websites? Have you tried accessing the IP address using Firefox on another computer in the local network?

more options

Firefox does not open a webpage. not a single one. no internet website and no lan website. the IE opens every web page and runs on the same system.

Firefox does not even open about:config. just about a trick I can open about:config. I need to open the troubleshooter and then replace the word support in the URL with config. then opens about:config

more options

When you tried uninstalling Firefox, did you also remove your Firefox profile? Also, have you tried Firefox Safe Mode at all?

more options

Are there any errors on the browser console (Ctrl+Shift+J)

more options

Hello, yes i remove the profiles and created a new local user with as admin. same error. nothing happens.

In the Safe Mode the same.

The Browser Console Show no error, when i use a URL.

I do not understand why I just typed in a URL (WAN URL, local IP, WAN IP, ...) nothing happens. Absolutely no reaction.

more options

Ok, so after reviewing the screenshots that you have attached, it appears that Firefox is sending traffic to the loopback address instead of the internet. Have you tried flushing your system's DNS records to ensure that it's not a DNS caching issue?

After you wipe the cache, see if it works. If not, type about:networking in the Firefox address bar and select DNS Lookup from the sidebar. Then try entering a domain into the search bar (has to be a domain, not an IP address). See if it's able to point find an IP address that isn't a loopback address.

There is also a Logging option there to log HTTP requests, if you feel like using that to diagnose further.

more options

I flush the dns and try to resolve a Domain. This works fine - but when i use the same URL in the adressbar, nothing happens. The small Animation Icon in the Tab still runs from right to left, but the tab keeps White.

The Logfile is here: []

more options

Does this issue only occur on the ESR/RR version (not sure which one you are running)? Try installing whichever version you are not running to a different install location to see if the issue still happens with that version.

This still seems like a proxy issue to me, given the fact that everything is directed to the loopback address and given the port numbers of the requests. However, if you've disabled the proxy then I don't see why it's happening, unless there is some sort of proxy still on your router or something that you have overlooked.

more options

I found out that the problem does not occur when I use an RDP session. The servers are virtual servers with the remote server / terminal server role. Furthermore, Citrix is installed. Say the ICA protocol. When I set up an RDP session, Firefox does not work. However, if I log in to the console via vSphere Client, I can use Firefox. On other systems with the role remote server / terminal server but without Citrix the Firefox works as expected also over RDP. It seems like ICA is causing the problem. Do you have an explanation for this?

more options

Citrix was one of the software companies impacted by Firefox's removal of NPAPI plugin support. Have you changed any Citrix settings since Firefox 53?

See Firefox 52 and Citrix Receiver for Web for more information.

more options

Chosen Solution

The 32Bit Firefox 60 works!!! Thanks for helping me!!!

more options

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.