Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

DRM Problem on Netflix - FF Version 59.0.1

  • 12 replies
  • 6 have this problem
  • Last reply by user1510099

more options


Any attempt of streaming a video on Netflix results in an error window showing the following code: F7701-1003

This occurs only on Netflix. YouTube works fine. Other sites that stream media too. Yes FF is up to date. Yes DRM-content is enabled. Yes Widevine runs on the latest version: Yes Widevine is "always active"

Thanks for your time! Best regards, ibudiful

All Replies (12)

more options

Screen shot of the error?

more options

Please consider turning on send info to Mozilla from with in Firefox before posting a question. This helps us help you. I have no info from your system that would help see things that cause issues. I have no add-ons, no video card driver info and errors, no version of Firefox, Give us something to work with please.


In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

more options


Is there any way to get you the data that FF would have extracted afterwards?

1. Safemode did not solve my problem. 2. Screenshot is attached but in Spanish and I cannot change the language.

"Something went wrong... Playback error Seems that there is a problem with FF which prevents Netflix form starting the playback. Make sure that you have got the newest version of FF. To get more help to solve this problem, visit our support center. Error code: F7701-1003"

3. My specs are on the screenshots of dxdiag and i have got you my addons and plugins.

I hope it is something you can work on with. If there is something else I can provide, just let me know.

Best reagrds, ibudiful

more options

I just refreshed FF and Netflix worked.

Then I set up some changes in the privacy settings of FF: -Disable "remember forms and passwords" -Never remember History -Always tracking protection -Always send "do not track signal" -Blocking microphone access requests -Blocking camera access requests -Blocking location access requests

Afterwards I installed Https Everywhere and Noscript. Netflix got all permissions on no Noscript but now the same error occurred.

Then I disabled Noscript and HTTPS Everywhere getting the same error message.

Maybe this is a clue.

If Netflix does not run because of my privacy settings, then I will stop using Netflix.

Best regards, Ibudiful

more options

Got you the screen shots. :)

more options

Heyho, I hope this intel might help. Is there a way to activate the option that provides you the required files? Best regards ibudiful

more options

Screen shots in Spanish are not going to help, Screen shots seem to be of little use if you can describe the issue.

Since Safe Mode did not work and that has all extensions disabled.

Then what you did and had it working then it stopped.

Would think you need to repeat the process but stop before you get it stopped. Then decide if can live with those settings.

more options

OK Thanks. I hope it is going to solve itself with future versions of FF.

Best regards and thank you for your efforts, ibudiful

more options

ibudiful said

If Netflix does not run because of my privacy settings, then I will stop using Netflix.

Netflix says here : " Turn off private browsing. "

more options


J'ai exactement le même problème et les mêmes caractéristiques. j'ai contacté le support de Netflix et ils m'ont dit que le problème vient de Firefox...

C'est donc a Firefox de corriger ce problème...

Quelqu’un pourrait me dire comment notifier firefox de ce problème pour qu'ils le corrigent ?

Cordialement, Simon Brocart

more options

You need to disable Private Browsing mode (remember history).

more options


I check and the Private Browsing mode le disable.